summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-04-25 16:02:58 +0100
committerRichard Leitner <richard.leitner@skidata.com>2018-06-19 09:56:17 +0200
commit3918402ea146a93747170de3a3fd266ec89e521f (patch)
tree91ef167fd65cfeb6519c03e790f75da93e3bba7a
parentc99c748d587df0f1e294ecf817f1391b9175797e (diff)
downloadmeta-java-3918402ea146a93747170de3a3fd266ec89e521f.tar.gz
classpath: harmonise -native and -initial-native recipes
removing lots of code-duplication Signed-off-by: André Draszik <andre.draszik@jci.com> Tested-by: Richard Leitner <richard.leitner@skidata.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/classpath/classpath-initial-native_0.93.bb54
-rw-r--r--recipes-core/classpath/classpath-native.inc25
-rw-r--r--recipes-core/classpath/classpath-native_0.99.bb31
3 files changed, 51 insertions, 59 deletions
diff --git a/recipes-core/classpath/classpath-initial-native_0.93.bb b/recipes-core/classpath/classpath-initial-native_0.93.bb
index 0cfa693..51229ec 100644
--- a/recipes-core/classpath/classpath-initial-native_0.93.bb
+++ b/recipes-core/classpath/classpath-initial-native_0.93.bb
@@ -4,7 +4,6 @@
4require classpath-native.inc 4require classpath-native.inc
5 5
6DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native." 6DESCRIPTION="Java1.4-compatible GNU Classpath variant that is used as bootclasspath for jikes-native."
7LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
8DEPENDS += "jikes-native" 7DEPENDS += "jikes-native"
9 8
10PR = "${INC_PR}.2" 9PR = "${INC_PR}.2"
@@ -13,38 +12,35 @@ SRC_URI += " \
13 file://autotools.patch \ 12 file://autotools.patch \
14 file://miscompilation.patch \ 13 file://miscompilation.patch \
15 " 14 "
15SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d"
16SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945"
16 17
17EXTRA_OECONF = " \ 18EXTRA_OECONF += "\
18 --with-jikes=jikes \ 19 --with-jikes=jikes \
19 --with-fastjar=fastjar \ 20 --with-fastjar=fastjar \
20 --with-glibj \ 21 --disable-local-sockets \
21 --disable-Werror \ 22 --with-glibj-dir=${STAGING_DATADIR_NATIVE}/classpath-initial \
22 --disable-local-sockets \ 23 --with-native-libdir=${STAGING_LIBDIR_NATIVE}/classpath-initial \
23 --disable-alsa \ 24 --includedir=${STAGING_INCDIR_NATIVE}/classpath-initial \
24 --disable-gconf-peer \ 25 --with-vm=java \
25 --disable-gtk-peer \ 26"
26 --disable-plugin \
27 --disable-dssi \
28 --disable-examples \
29 --with-glibj-dir=${STAGING_DATADIR_NATIVE}/classpath-initial \
30 --with-native-libdir=${STAGING_LIBDIR_NATIVE}/classpath-initial \
31 --includedir=${STAGING_INCDIR_NATIVE}/classpath-initial \
32 --with-vm=java \
33 "
34 27
35# Ensure tools.zip is not installed at same path as classpath-native 28# Ensure tools.zip is not installed at same path as classpath-native
36EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial" 29EXTRA_OEMAKE += "pkgdatadir=${STAGING_DATADIR_NATIVE}/classpath-initial"
37 30
38# remove files clashing with classpath-native in sysroot
39do_install_append() { 31do_install_append() {
40 32 # remove files clashing with classpath-native in sysroot
41 for i in gappletviewer gjarsigner gkeytool gjar gnative2ascii gserialver grmiregistry gtnameserv gorbd grmid 33 rm \
42 do 34 ${D}${bindir}/gappletviewer \
43 rm ${D}${bindir}/${i} 35 ${D}${bindir}/gjarsigner \
44 done 36 ${D}${bindir}/gkeytool \
45 rm ${D}${libdir}/logging.properties 37 ${D}${bindir}/gjar \
46 rm ${D}${libdir}/security/classpath.security 38 ${D}${bindir}/gnative2ascii \
39 ${D}${bindir}/gserialver \
40 ${D}${bindir}/grmiregistry \
41 ${D}${bindir}/gtnameserv \
42 ${D}${bindir}/gorbd \
43 ${D}${bindir}/grmid \
44 ${D}${libdir}/logging.properties \
45 ${D}${libdir}/security/classpath.security
47} 46}
48SRC_URI[md5sum] = "ffa9e9cac31c5acbf0ea9eff9efa923d"
49SRC_URI[sha256sum] = "df2d093612abd23fe67e9409d89bb2a8e79b1664fe2b2da40e1c8ed693e32945"
50
diff --git a/recipes-core/classpath/classpath-native.inc b/recipes-core/classpath/classpath-native.inc
index 6a56337..b1de458 100644
--- a/recipes-core/classpath/classpath-native.inc
+++ b/recipes-core/classpath/classpath-native.inc
@@ -1,6 +1,7 @@
1SUMMARY = "GNU Classpath standard Java libraries - For native Java-dependent programs" 1SUMMARY = "GNU Classpath standard Java libraries - For native Java-dependent programs"
2HOMEPAGE = "http://www.gnu.org/software/classpath/" 2HOMEPAGE = "http://www.gnu.org/software/classpath/"
3LICENSE = "GPL-2.0 & SAX-PD" 3LICENSE = "GPL-2.0 & SAX-PD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
4 5
5DEPENDS = "fastjar-native zip-native" 6DEPENDS = "fastjar-native zip-native"
6 7
@@ -14,17 +15,13 @@ export JAVA="${STAGING_BINDIR_NATIVE}/java-initial"
14export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial" 15export JAVAC="${STAGING_BINDIR_NATIVE}/ecj-initial"
15export JAVACFLAGS="-nowarn" 16export JAVACFLAGS="-nowarn"
16 17
17EXTRA_OECONF = " \ 18EXTRA_OECONF = "\
18 --with-glibj \ 19 --with-glibj \
19 --enable-local-sockets \ 20 --disable-Werror \
20 --disable-Werror \ 21 --disable-alsa \
21 --disable-alsa \ 22 --disable-gconf-peer \
22 --disable-gconf-peer \ 23 --disable-gtk-peer \
23 --disable-gtk-peer \ 24 --disable-plugin \
24 --disable-plugin \ 25 --disable-dssi \
25 --disable-dssi \ 26 --disable-examples \
26 --disable-gjdoc \ 27"
27 --disable-examples \
28 --enable-tools \
29 --includedir=${STAGING_INCDIR}/classpath \
30 "
diff --git a/recipes-core/classpath/classpath-native_0.99.bb b/recipes-core/classpath/classpath-native_0.99.bb
index a97cae0..a1e1e0f 100644
--- a/recipes-core/classpath/classpath-native_0.99.bb
+++ b/recipes-core/classpath/classpath-native_0.99.bb
@@ -1,6 +1,5 @@
1require classpath-native.inc 1require classpath-native.inc
2 2
3LIC_FILES_CHKSUM = "file://COPYING;md5=af0004801732bc4b20d90f351cf80510"
4DEPENDS += "classpath-initial-native ecj-initial-native virtual/java-initial-native" 3DEPENDS += "classpath-initial-native ecj-initial-native virtual/java-initial-native"
5 4
6PR = "${INC_PR}.0" 5PR = "${INC_PR}.0"
@@ -12,21 +11,21 @@ SRC_URI += " \
12 file://miscompilation.patch \ 11 file://miscompilation.patch \
13 file://toolwrapper-exithook.patch \ 12 file://toolwrapper-exithook.patch \
14 " 13 "
15
16# tools using java-initial rather than java sed it out
17do_compile_append () {
18
19 COMMANDS="gappletviewer gjarsigner gkeytool \
20 gjar gnative2ascii gserialver grmiregistry \
21 gtnameserv gorbd grmid grmic gjavah \
22 "
23
24 for i in ${COMMANDS};
25 do
26 sed -i -e "s/java-initial/java/g" tools/${i}
27 done
28}
29
30SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4" 14SRC_URI[md5sum] = "0ae1571249172acd82488724a3b8acb4"
31SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8" 15SRC_URI[sha256sum] = "f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8"
32 16
17EXTRA_OECONF += "\
18 --enable-local-sockets \
19 --disable-gjdoc \
20 --enable-tools \
21 --includedir=${STAGING_INCDIR}/classpath \
22"
23
24do_compile_append () {
25 # tools using java-initial rather than java sed it out
26 cd tools
27 sed -e "s/java-initial/java/g" \
28 -i gappletviewer gjarsigner gkeytool \
29 gjar gnative2ascii gserialver grmiregistry \
30 gtnameserv gorbd grmid grmic gjavah
31}