summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFang Jia <fang.jia@windriver.com>2019-02-21 11:23:07 +0800
committerRichard Leitner <richard.leitner@skidata.com>2019-12-27 11:35:59 +0100
commit2eb86a8feffc98471f5fc3f9c20dba41844b74a5 (patch)
tree2f915be9ecf8b6302d85243e36bb72c4d0f310d2
parent327c75c49d2fb294cd863e77810d014acfe0c31f (diff)
downloadmeta-java-2eb86a8feffc98471f5fc3f9c20dba41844b74a5.tar.gz
Revert "base-files: Define JAVA_HOME by default"thud
This reverts commit ada652564f09756a81f54495cbc2091125239625. When enable multilib on a 64-bit system, probably both base-file and lib32-base-files are installed. Then both packages want to modify the file "profile", there will be an error like: " Error: Transaction check error: file /etc/profile conflicts between attempted installs of lib32-base-files-3.0.14-r148.gpb_virt and base-files-3.0.14-r148.gpb_virt " The task can be added by adding a file to ${sysconfdir}/profile.d/. Signed-off-by: Fang Jia <fang.jia@windriver.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/base-files/base-files_3.0.14.bbappend13
1 files changed, 0 insertions, 13 deletions
diff --git a/recipes-core/base-files/base-files_3.0.14.bbappend b/recipes-core/base-files/base-files_3.0.14.bbappend
deleted file mode 100644
index 4651185..0000000
--- a/recipes-core/base-files/base-files_3.0.14.bbappend
+++ /dev/null
@@ -1,13 +0,0 @@
1do_install_append() {
2 cat >> ${D}${sysconfdir}/profile << EOT
3JAVA_HOME=""
4for dir in ${libdir}/jvm/*; do
5 if [ -x "\${dir}/bin/java" ]; then
6 [ -z "\${JAVA_HOME}" ] && JAVA_HOME="\${dir}"
7 fi
8done
9if [ -n "\${JAVA_HOME}" ]; then
10 export JAVA_HOME=\${JAVA_HOME}
11fi
12EOT
13}