summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2018-09-18 15:48:44 +0100
committerRichard Leitner <dev@g0hl1n.net>2018-10-22 15:15:12 +0200
commit1fdd55930690c3c7abd7458b795c26dd7bfebc08 (patch)
tree415b8a5a55282b45ca7d1f6e86195a8f4965fc4f
parent634ac5baf998abd256309cc41f5f8a24045de8a3 (diff)
downloadmeta-java-1fdd55930690c3c7abd7458b795c26dd7bfebc08.tar.gz
openjdk: remove incorrect PROVIDES (java2-vm java2-runtime)
There are two issues here: * PROVIDES is not package specific * it doesn't look like the intention is to be able to DEPENDS on java2-vm or java2-runtime anyway Regarding java2-vm: ------------------- java2-vm was originally used in the OpenJDK 6 & 7 recipes to be able to select shark, zero, cacao, or jamvm VMs. OpenJDK-6 is not available any more, and OpenJDK-7 has removed support for most of this in commit 38f4c1365c11 ("openjdk7: remove broken/unsupported VM's") It is not clear why it was added to the OpenJDK-8 recipe either. Given OpenJDK-7 has no way of using the VM compiled as part of OpenJDK-8, and given that no part of the OpenJDK-8 makes use of the java2-vm part, the correct solution here is to actually *remove* the incorrect PROVIDES as well as *R*PROVIDES statements for java2-vm completely. Regarding java2-runtime: ------------------------ Again, looking at the other uses of this: java2-runtime is a virtual runtime package name, which is provided by different *runtime* packages (created by the OpenJDK-7, OpenJDK-8, JamVM, or Cacao recipes). Other recipes only ever RDEPEND on java2-runtime. It makes no sense for the OpenJDK-8 recipe to PROVIDES java2-runtime given the above. Remove the incorrect (R)PROVIDES statements. Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/openjdk/openjdk-8_172b11.bb3
-rw-r--r--recipes-core/openjdk/openjre-8_172b11.bb3
2 files changed, 0 insertions, 6 deletions
diff --git a/recipes-core/openjdk/openjdk-8_172b11.bb b/recipes-core/openjdk/openjdk-8_172b11.bb
index c1c6e1e..72f208e 100644
--- a/recipes-core/openjdk/openjdk-8_172b11.bb
+++ b/recipes-core/openjdk/openjdk-8_172b11.bb
@@ -47,10 +47,7 @@ FILES_${PN}-doc_append = "\
47 47
48FILES_${PN}-source = " ${JDK_HOME}/src.zip " 48FILES_${PN}-source = " ${JDK_HOME}/src.zip "
49 49
50RPROVIDES_${PN} = "java2-vm"
51PROVIDES_${PN} = "java2-vm"
52RPROVIDES_${PN} = "java2-runtime" 50RPROVIDES_${PN} = "java2-runtime"
53PROVIDES_${PN} = "java2-runtime"
54 51
55inherit update-alternatives 52inherit update-alternatives
56 53
diff --git a/recipes-core/openjdk/openjre-8_172b11.bb b/recipes-core/openjdk/openjre-8_172b11.bb
index dd29691..e9b930b 100644
--- a/recipes-core/openjdk/openjre-8_172b11.bb
+++ b/recipes-core/openjdk/openjre-8_172b11.bb
@@ -35,10 +35,7 @@ FILES_${PN}-doc_append = "\
35 ${JRE_HOME}/THIRD_PARTY_README \ 35 ${JRE_HOME}/THIRD_PARTY_README \
36" 36"
37 37
38RPROVIDES_${PN} = "java2-vm"
39PROVIDES_${PN} = "java2-vm"
40RPROVIDES_${PN} = "java2-runtime" 38RPROVIDES_${PN} = "java2-runtime"
41PROVIDES_${PN} = "java2-runtime"
42 39
43inherit update-alternatives 40inherit update-alternatives
44 41