summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2018-01-04 14:19:09 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2018-01-09 13:41:35 -0200
commitf1ceb8474deb3670a9a1cd86e283e4fffd162bc6 (patch)
tree7561b6ca8951067766a96d23c0b088d61f7874fb
parent5c1f57bffad8550e60949fcc6c75878f23d6a88f (diff)
downloadmeta-java-f1ceb8474deb3670a9a1cd86e283e4fffd162bc6.tar.gz
jamvm: avoid checking x11 distro feature for native build
x11 is not a mandatory distro feature for building jamvm-native, so avoid checking it for native build, or else it would lead parsing errors. Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-core/jamvm/jamvm.inc3
-rw-r--r--recipes-core/jamvm/jamvm_git.bb4
2 files changed, 2 insertions, 5 deletions
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index da1ca29..7a6b6b6 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -15,8 +15,9 @@ RPROVIDES_${PN}_class-native = ""
15 15
16BBCLASSEXTEND = "native" 16BBCLASSEXTEND = "native"
17 17
18inherit java autotools update-alternatives pkgconfig relative_symlinks distro_features_check
18 19
19inherit java autotools update-alternatives pkgconfig relative_symlinks 20REQUIRED_DISTRO_FEATURES_class-target = "x11"
20 21
21# This uses 32 bit arm, so force the instruction set to arm, not thumb 22# This uses 32 bit arm, so force the instruction set to arm, not thumb
22ARM_INSTRUCTION_SET = "arm" 23ARM_INSTRUCTION_SET = "arm"
diff --git a/recipes-core/jamvm/jamvm_git.bb b/recipes-core/jamvm/jamvm_git.bb
index 6bbfa52..1762ade 100644
--- a/recipes-core/jamvm/jamvm_git.bb
+++ b/recipes-core/jamvm/jamvm_git.bb
@@ -3,10 +3,6 @@
3 3
4require jamvm.inc 4require jamvm.inc
5 5
6inherit distro_features_check
7
8REQUIRED_DISTRO_FEATURES = "x11"
9
10SRCREV = "6cef41d859fbc9ce7868a97cb2cb5dd2b10b9103" 6SRCREV = "6cef41d859fbc9ce7868a97cb2cb5dd2b10b9103"
11PV = "2.0.0-devel+git${SRCPV}" 7PV = "2.0.0-devel+git${SRCPV}"
12 8