summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-05-21 16:25:54 -0700
committerMaxin B. John <maxin.john@intel.com>2017-05-29 13:53:29 +0300
commitd9061060f6007d240a20d4b152bcce4f8f4fe919 (patch)
tree5bb95548e2898219361f70c14c1f5d299f6325ff
parentb04e1201e407533b0f6353d04183ebcab531bf53 (diff)
downloadmeta-java-d9061060f6007d240a20d4b152bcce4f8f4fe919.tar.gz
dom4j: unblacklist and fix build
- Add SUMMARY and expand DESCRIPTION - Update HOMEPAGE - Update URI for jaxme - Add LIC_FILE_CHECKSUM - Fix path for 'find org ...' - Move SRC_URI checksums to recommended location in recipe - Add virtual/javac-native to DEPENDS for RSS Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
-rw-r--r--recipes-core/xml-commons/dom4j_1.6.1.bb29
-rw-r--r--recipes-core/xml-commons/jaxen_1.1.6.bb2
2 files changed, 15 insertions, 16 deletions
diff --git a/recipes-core/xml-commons/dom4j_1.6.1.bb b/recipes-core/xml-commons/dom4j_1.6.1.bb
index 19dca74..97c9947 100644
--- a/recipes-core/xml-commons/dom4j_1.6.1.bb
+++ b/recipes-core/xml-commons/dom4j_1.6.1.bb
@@ -1,17 +1,22 @@
1SUMMARY = "A simple and flexible library for working with XML, XPath and XSLT"
1DESCRIPTION = "dom4j is a simple and flexible Java library for working with XML, XPath and XSLT" 2DESCRIPTION = "dom4j is a simple and flexible Java library for working with XML, XPath and XSLT"
2LICENSE = "BSD" 3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3f752b663f2a821c3b32482fc6aece3c"
3 5
4HOMEPAGE = "http://dom4j.org" 6HOMEPAGE = "http://dom4j.github.io"
5 7
6DEPENDS = "fastjar-native xerces-j xalan-j xpp2 xpp3 jaxen" 8DEPENDS = "fastjar-native virtual/javac-native \
9 xerces-j xalan-j xpp2 xpp3 jaxen"
7 10
8SRC_URI = "\ 11SRC_URI = "\
9 ${SOURCEFORGE_MIRROR}/dom4j/${P}.tar.gz;name=archive \ 12 ${SOURCEFORGE_MIRROR}/dom4j/${P}.tar.gz;name=archive \
10 http://apache.org/dist/ws/jaxme/source/ws-jaxme-0.5.2-src.tar.gz;name=jaxme \ 13 http://archive.apache.org/dist/ws/jaxme/source/ws-jaxme-0.5.2-src.tar.gz;name=jaxme \
11 file://debian.patch \ 14 file://debian.patch \
12 " 15"
13 16SRC_URI[archive.md5sum] = "1e7ef6d20939315714de4a8502f27b2d"
14PNBLACKLIST[dom4j] ?= "BROKEN: indirectly depends on broken 'xom'" 17SRC_URI[archive.sha256sum] = "01b4abf86bce337a2a900bf121b3107320ba63b4c0f352e1922fbec6e0736c6f"
18SRC_URI[jaxme.md5sum] = "084ebfe4a816058f8ff6bd731fa70df4"
19SRC_URI[jaxme.sha256sum] = "0415d721259acf95c564fb84606bb17f6227c1cc444e89b78d1cd9903c1c88dc"
15 20
16inherit java-library 21inherit java-library
17 22
@@ -22,16 +27,10 @@ do_compile() {
22 scp="src/java:${WORKDIR}/ws-jaxme-0.5.2/src/api" 27 scp="src/java:${WORKDIR}/ws-jaxme-0.5.2/src/api"
23 28
24 javac -sourcepath $scp -cp $cp -d build `find src/java -name "*.java" -and -not -wholename "*datatype*"` 29 javac -sourcepath $scp -cp $cp -d build `find src/java -name "*.java" -and -not -wholename "*datatype*"`
25 (cd src && find org -name "*.properties" -exec cp {} ../build/{} \;) 30 (cd src/java && find org -name "*.properties" -exec cp {} ../../build/{} \;)
26 31
27 rm -rf build/org/w3c 32 rm -rf build/org/w3c
28 rm -rf build/javax 33 rm -rf build/javax
29 34
30 fastjar -C build -c -f ${JARFILENAME} . 35 fastjar -C build -c -f ${JARFILENAME} .
31} 36}
32
33
34SRC_URI[archive.md5sum] = "1e7ef6d20939315714de4a8502f27b2d"
35SRC_URI[archive.sha256sum] = "01b4abf86bce337a2a900bf121b3107320ba63b4c0f352e1922fbec6e0736c6f"
36SRC_URI[jaxme.md5sum] = "084ebfe4a816058f8ff6bd731fa70df4"
37SRC_URI[jaxme.sha256sum] = "0415d721259acf95c564fb84606bb17f6227c1cc444e89b78d1cd9903c1c88dc"
diff --git a/recipes-core/xml-commons/jaxen_1.1.6.bb b/recipes-core/xml-commons/jaxen_1.1.6.bb
index 2e313fa..d75ce75 100644
--- a/recipes-core/xml-commons/jaxen_1.1.6.bb
+++ b/recipes-core/xml-commons/jaxen_1.1.6.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a2e66c2e2482aa23c11342f1469fa3b6"
9 9
10HOMEPAGE = "http://jaxen.org/" 10HOMEPAGE = "http://jaxen.org/"
11 11
12DEPENDS = "fastjar-native xerces-j xom" 12DEPENDS = "fastjar-native virtual/javac-native xerces-j xom"
13 13
14# upstream has moved to github, do not rely on ephemeral tarball, use git 14# upstream has moved to github, do not rely on ephemeral tarball, use git
15SRCREV = "7d7755ac8b19daa2ff6f319f432b864cc72d89b6" 15SRCREV = "7d7755ac8b19daa2ff6f319f432b864cc72d89b6"