diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2017-05-21 16:25:55 -0700 |
---|---|---|
committer | Maxin B. John <maxin.john@intel.com> | 2017-05-29 13:53:37 +0300 |
commit | d82bc78f0a63358f25e53c23a675d5d116ffc9e7 (patch) | |
tree | cce10c022954b9a8834d64ab77e504bab4765c87 | |
parent | d9061060f6007d240a20d4b152bcce4f8f4fe919 (diff) | |
download | meta-java-d82bc78f0a63358f25e53c23a675d5d116ffc9e7.tar.gz |
jdom: unblacklist and update to v1.1.3
- Add SUMMARY and expand DESCRIPTION
- Add LIC_FILES_CHECKSUM
- Move SRC_URI checksums to recommended location in recipe
- Add virtual/javac-native to DEPENDS for RSS
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Maxin B. John <maxin.john@intel.com>
-rw-r--r-- | recipes-core/xml-commons/jdom_1.1.3.bb | 25 | ||||
-rw-r--r-- | recipes-core/xml-commons/jdom_1.1.bb | 28 |
2 files changed, 25 insertions, 28 deletions
diff --git a/recipes-core/xml-commons/jdom_1.1.3.bb b/recipes-core/xml-commons/jdom_1.1.3.bb new file mode 100644 index 0000000..8997bcc --- /dev/null +++ b/recipes-core/xml-commons/jdom_1.1.3.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "Parses, manipulates, and outputs XML using standard Java constructs" | ||
2 | DESCRIPTION = "JDOM aims to provide a complete, Java-based solution for \ | ||
3 | accessing, manipulating, and outputting XML data from Java code." | ||
4 | LICENSE = "BSD" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=897c700e4c122d8f4ef8f6d253a6f744" | ||
6 | |||
7 | HOMEPAGE = "http://jdom.org/" | ||
8 | |||
9 | DEPENDS = "fastjar-native virtual/javac-native jaxen" | ||
10 | |||
11 | SRC_URI = "http://www.jdom.org/dist/source/archive/jdom-${PV}.tar.gz" | ||
12 | SRC_URI[md5sum] = "dc8391e84cfdb170fcd8279aa370019f" | ||
13 | SRC_URI[sha256sum] = "d471718c4ac7a1a2f10715b93cb3fcd2ecbab60384b73ad1c089712e47bd8d1f" | ||
14 | |||
15 | inherit java-library | ||
16 | |||
17 | do_compile() { | ||
18 | mkdir -p build | ||
19 | |||
20 | oe_makeclasspath cp -s jaxen | ||
21 | |||
22 | javac -sourcepath src/java -cp $cp -d build `find src/java -name "*.java"` | ||
23 | |||
24 | fastjar -C build -c -f ${JARFILENAME} . | ||
25 | } | ||
diff --git a/recipes-core/xml-commons/jdom_1.1.bb b/recipes-core/xml-commons/jdom_1.1.bb deleted file mode 100644 index 4867e82..0000000 --- a/recipes-core/xml-commons/jdom_1.1.bb +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | DESCRIPTION = "Parses, manipulates, and outputs XML using standard Java constructs" | ||
2 | LICENSE = "BSD" | ||
3 | |||
4 | HOMEPAGE = "http://jdom.org/" | ||
5 | |||
6 | DEPENDS = "fastjar-native jaxen" | ||
7 | |||
8 | SRC_URI = "\ | ||
9 | http://www.jdom.org/dist/binary/archive/jdom-${PV}.tar.gz \ | ||
10 | " | ||
11 | |||
12 | PNBLACKLIST[jdom] ?= "BROKEN: indirectly depends on broken 'xom'" | ||
13 | |||
14 | inherit java-library | ||
15 | |||
16 | do_compile() { | ||
17 | mkdir -p build | ||
18 | |||
19 | oe_makeclasspath cp -s jaxen | ||
20 | |||
21 | javac -sourcepath src/java -cp $cp -d build `find src/java -name "*.java"` | ||
22 | |||
23 | fastjar -C build -c -f ${JARFILENAME} . | ||
24 | } | ||
25 | |||
26 | |||
27 | SRC_URI[md5sum] = "22745cbaaddb12884ed8ee09083d8fe2" | ||
28 | SRC_URI[sha256sum] = "a13549087141be24ad176b659afdc2c675f1ffa5288ff999a193d6d44a282056" | ||