summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-05-24 13:36:39 -0700
committerHenning Heinold <heinold@inf.fu-berlin.de>2013-09-29 21:50:14 +0200
commitb81f7aafb3f8047faf89b1dd089062bcf2035462 (patch)
tree1f4038d828936087bbffac404ca1ceb03000a56b
parent0087b9260ba3ebc8098d8d87c08d4eea05070f39 (diff)
downloadmeta-java-b81f7aafb3f8047faf89b1dd089062bcf2035462.tar.gz
bcel,avalon-framework: Specify encoding to javac
when using javac from different JDK it does not like the encodings since default is ascii, so be specific. fastjar argument order was not correct when using other fastjar implementation it was strict about it so lets correct it as well. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-core/bcel/bcel_5.2.bb4
-rw-r--r--recipes-core/jakarta-libs/avalon-framework-api_4.3.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes-core/bcel/bcel_5.2.bb b/recipes-core/bcel/bcel_5.2.bb
index 27fd8d9..6ff345d 100644
--- a/recipes-core/bcel/bcel_5.2.bb
+++ b/recipes-core/bcel/bcel_5.2.bb
@@ -16,9 +16,9 @@ do_compile() {
16 16
17 oe_makeclasspath cp -s xercesImpl regexp 17 oe_makeclasspath cp -s xercesImpl regexp
18 18
19 javac -sourcepath src/java -d build -cp $cp `find src/java -name \*.java` 19 javac -encoding ISO-8859-1 -sourcepath src/java -d build -cp $cp `find src/java -name \*.java`
20 20
21 fastjar -C build -c -f ${JARFILENAME} . 21 fastjar cf ${JARFILENAME} -C build .
22} 22}
23 23
24SRC_URI[md5sum] = "905b7e718e30e7ca726530ecf106e532" 24SRC_URI[md5sum] = "905b7e718e30e7ca726530ecf106e532"
diff --git a/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb b/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb
index 25814d9..081cfe7 100644
--- a/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb
+++ b/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb
@@ -17,12 +17,12 @@ do_compile() {
17 # Allow reaching method definitions from logkit (stupid cyclic dependency). 17 # Allow reaching method definitions from logkit (stupid cyclic dependency).
18 srcpath=src/java:${WORKDIR}/logkit-1.2.2-dev/src/java 18 srcpath=src/java:${WORKDIR}/logkit-1.2.2-dev/src/java
19 19
20 javac -sourcepath $srcpath -d build `find src/java -name "*.java"` 20 javac -encoding ISO-8859-1 -sourcepath $srcpath -d build `find src/java -name "*.java"`
21 21
22 # Remove classes that belong to logkit ... 22 # Remove classes that belong to logkit ...
23 rm -rf ${S}/build/org/apache/log 23 rm -rf ${S}/build/org/apache/log
24 24
25 fastjar -C build -c -f ${JARFILENAME} . 25 fastjar cf ${JARFILENAME} -C build .
26} 26}
27 27
28 28