summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Ribalda Delgado <ricardo.ribalda@gmail.com>2016-09-13 14:37:57 +0200
committerMaxin B. John <maxin.john@intel.com>2016-09-16 14:26:36 +0300
commit28ba957b0f23c75900b7e3ce8132c926bf5724e6 (patch)
tree55efdf94dfca6787ff50817bdecbd004b83a4a05
parentaa3c79568dfaeb9c8747d49d12ac0396eaf6a4ea (diff)
downloadmeta-java-28ba957b0f23c75900b7e3ce8132c926bf5724e6.tar.gz
xpp3: Fix bashism
findpath var must also be fixed on its second occurrence. Without this patch: ERROR: xpp3-1.1.3.4.O-r0 do_compile: Function failed: do_compile (log file is located at /home/ricardo/curro/qt5022/build-qt5022-open/build/tmp/work/all-poky-linux/xpp3/1.1.3.4.O-r0/temp/log.do_compile.14262) ERROR: Logfile of failure stored in: /home/ricardo/curro/qt5022/build-qt5022-open/build/tmp/work/all-poky-linux/xpp3/1.1.3.4.O-r0/temp/log.do_compile.14262 Log data follows: | DEBUG: Executing shell function do_compile | ---------- | 1. WARNING in src/java/api/org/xmlpull/v1/XmlPullParserException.java (at line 11) | public class XmlPullParserException extends Exception { | ^^^^^^^^^^^^^^^^^^^^^^ | The serializable class XmlPullParserException does not declare a static final serialVersionUID field of type long /home/ricardo/curro/qt5022/build-qt5022-open/build/tmp/work/all-poky-linux/xpp3/1.1.3.4.O-r0/temp/run.do_compile.14262: Bad substitution | WARNING: exit code 2 from a shell command. Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
-rw-r--r--recipes-core/xml-commons/xpp3_1.1.3.4.O.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
index f264022..808a937 100644
--- a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
+++ b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
@@ -33,7 +33,7 @@ do_compile() {
33 mkdir -p build-xpath 33 mkdir -p build-xpath
34 34
35 sourcepath="src/java/xpath" 35 sourcepath="src/java/xpath"
36 findpath="${sourcepath//:/ }" 36 findpath=${sourcepath}
37 javac -sourcepath $sourcepath -cp build-oe -d build-xpath `find $findpath -name "*.java"` 37 javac -sourcepath $sourcepath -cp build-oe -d build-xpath `find $findpath -name "*.java"`
38 38
39 fastjar -C build-xpath -c -f xpp3-xpath-${PV}.jar . 39 fastjar -C build-xpath -c -f xpp3-xpath-${PV}.jar .