summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <henning@itconsulting-heinold.de>2014-01-04 22:57:25 +0100
committerHenning Heinold <henning@itconsulting-heinold.de>2014-01-09 01:26:06 +0100
commit0d37c98d62f6961eba5a43d6d9bd7d2ee2cf3f9e (patch)
treee0f68b810eae5ef3617bfb7ff7f0335610ec65fc
parent76c497ed3b21832b7561e872c14fe072065bd24d (diff)
downloadmeta-java-0d37c98d62f6961eba5a43d6d9bd7d2ee2cf3f9e.tar.gz
openjdk6: fix slpashscreen and jawt for host include and search path contamination
-rw-r--r--recipes-core/openjdk/openjdk-6-6b24/icedtea-crosscompile-fix.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-6-6b24/icedtea-crosscompile-fix.patch b/recipes-core/openjdk/openjdk-6-6b24/icedtea-crosscompile-fix.patch
index 652f7ac..f268290 100644
--- a/recipes-core/openjdk/openjdk-6-6b24/icedtea-crosscompile-fix.patch
+++ b/recipes-core/openjdk/openjdk-6-6b24/icedtea-crosscompile-fix.patch
@@ -214,3 +214,57 @@ Index: icedtea6-1.8.5/build/openjdk/jdk/make/sun/xawt/Makefile
214 fi 214 fi
215 @if [ "$(DOCOMPARE)$(suffix $@)" = "true.64" ]; then \ 215 @if [ "$(DOCOMPARE)$(suffix $@)" = "true.64" ]; then \
216 $(ECHO) COMPARING $@ and $(STORED_SIZES_TMPL_$(PLATFORM)_$(LIBARCH)); \ 216 $(ECHO) COMPARING $@ and $(STORED_SIZES_TMPL_$(PLATFORM)_$(LIBARCH)); \
217diff --git openjdk/jdk/make/launchers/Makefile.launcher openjdk/jdk/make/launchers/Makefile.launcher
218index f59a9d6..6edc880 100644
219--- openjdk/jdk/make/launchers/Makefile.launcher
220+++ openjdk/jdk/make/launchers/Makefile.launcher
221@@ -152,7 +152,7 @@ endif
222 ifeq ($(GUI_TOOL),true)
223 ifneq ($(PLATFORM), windows)
224 # Anything with a GUI needs X11 to be linked in.
225- OTHER_LDLIBS += -L$(OPENWIN_LIB) -lX11
226+ OTHER_LDLIBS += -lX11
227 endif
228 endif
229
230diff --git openjdk/jdk/make/sun/jawt/Makefile openjdk/jdk/make/sun/jawt/Makefile
231index 2021434..9035da7 100644
232--- openjdk/jdk/make/sun/jawt/Makefile
233+++ openjdk/jdk/make/sun/jawt/Makefile
234@@ -98,8 +98,7 @@ else # PLATFORM
235 #
236 # Other extra flags needed for compiling.
237 #
238-CPPFLAGS += -I$(OPENWIN_HOME)/include \
239- -I$(SHARE_SRC)/native/$(PKGDIR)/debug \
240+CPPFLAGS += -I$(SHARE_SRC)/native/$(PKGDIR)/debug \
241 -I$(SHARE_SRC)/native/$(PKGDIR)/image \
242 -I$(SHARE_SRC)/native/$(PKGDIR)/image/cvutils \
243 -I$(SHARE_SRC)/native/$(PKGDIR)/alphacomposite \
244diff --git openjdk/jdk/make/sun/splashscreen/Makefile openjdk/jdk/make/sun/splashscreen/Makefile
245index 6693e2a..58d05f1 100644
246--- openjdk/jdk/make/sun/splashscreen/Makefile
247+++ openjdk/jdk/make/sun/splashscreen/Makefile
248@@ -63,8 +63,7 @@ CFLAGS += -DSPLASHSCREEN -DPNG_NO_MMX_CODE
249
250 ifneq ($(PLATFORM), windows)
251 CFLAGS += -DWITH_X11
252- CPPFLAGS += -I$(OPENWIN_HOME)/include -I$(OPENWIN_HOME)/include/X11/extensions
253- OTHER_LDLIBS += -L$(OPENWIN_LIB) -lX11 -lXext $(LIBM) -lpng -ljpeg -lgif -lz -lpthread
254+ OTHER_LDLIBS += -lX11 -lXext $(LIBM) -lpng -ljpeg -lgif -lz -lpthread
255 else # PLATFORM
256 CFLAGS += -DWITH_WIN32
257 OTHER_LDLIBS += kernel32.lib user32.lib gdi32.lib
258diff --git openjdk/jdk/make/sun/xawt/Makefile openjdk/jdk/make/sun/xawt/Makefile
259index 440699b..ffa177d 100644
260--- openjdk/jdk/make/sun/xawt/Makefile
261+++ openjdk/jdk/make/sun/xawt/Makefile
262@@ -46,8 +46,6 @@ include FILES_export_unix.gmk
263 AUTO_FILES_JAVA_DIRS = sun/awt/X11
264 AUTO_JAVA_PRUNE = WrapperGenerator.java
265
266-LDFLAGS += -L$(OPENWIN_LIB)
267-
268 # For Xrender extension.
269 ifeq ($(PLATFORM), solaris)
270 LDFLAGS += -L/usr/openwin/sfw/lib$(ISA_DIR) -R/usr/openwin/sfw/lib$(ISA_DIR)