summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2015-12-22 22:26:16 -0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-01-04 09:21:06 -0200
commitec7b984fbd0662b7aa1707f229ab09c555bb2cf6 (patch)
treeddcccc61cad8998e96506319c30d12acd6edbfdb
parentaf90e3a9473e529dcbb4e7392a62f1d5c592f717 (diff)
downloadmeta-java-ec7b984fbd0662b7aa1707f229ab09c555bb2cf6.tar.gz
Revert "meta-java: rely on well known bootstrap-path"
This reverts commit 04d5d0bf414c05ca59618d77f17ff9898aa1c566. Detail reason is in the following commit. Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
-rw-r--r--classes/java-bootstrap-components.bbclass7
-rw-r--r--classes/java-library.bbclass3
-rw-r--r--recipes-core/ant/ant-native_1.8.1.bb2
-rw-r--r--recipes-core/antlr/antlr_2.7.7.bb2
-rw-r--r--recipes-core/cacao/cacao_1.6.1.bb4
-rw-r--r--recipes-core/classpath/classpath.inc4
-rw-r--r--recipes-core/classpathx/gnujaf_1.1.1.bb2
-rw-r--r--recipes-core/classpathx/gnumail_1.1.2.bb2
-rw-r--r--recipes-core/classpathx/inetlib_1.1.1.bb2
-rw-r--r--recipes-core/cup/cup_0.10k.bb2
-rw-r--r--recipes-core/ecj/ecj-bootstrap-native.bb2
-rw-r--r--recipes-core/ecj/libecj-bootstrap.inc2
-rw-r--r--recipes-core/icedtea/icedtea7-native.inc2
-rw-r--r--recipes-core/jacl/jacl_1.4.1.bb2
-rw-r--r--recipes-core/jakarta-commons/commons-logging_1.1.1.bb2
-rw-r--r--recipes-core/jakarta-commons/commons-net_1.4.1.bb2
-rw-r--r--recipes-core/jakarta-libs/avalon-framework-api_4.3.bb2
-rw-r--r--recipes-core/jakarta-libs/bsf_2.4.0.bb2
-rw-r--r--recipes-core/jakarta-libs/log4j1.2_1.2.17.bb2
-rw-r--r--recipes-core/jakarta-libs/logkit_1.2.2.bb2
-rw-r--r--recipes-core/jakarta-libs/oro_2.0.8.bb2
-rw-r--r--recipes-core/jakarta-libs/poi_3.0.bb2
-rw-r--r--recipes-core/jakarta-libs/regexp_1.5.bb2
-rw-r--r--recipes-core/jamvm/jamvm.inc4
-rw-r--r--recipes-core/jcraft/jsch_0.1.40.bb2
-rw-r--r--recipes-core/jcraft/jzlib_1.0.7.bb2
-rw-r--r--recipes-core/jdepend/jdepend_2.9.1.bb2
-rw-r--r--recipes-core/jlex/jlex_1.2.6.bb2
-rw-r--r--recipes-core/junit/junit4_4.3.1.bb4
-rw-r--r--recipes-core/junit/junit_3.8.2.bb2
-rw-r--r--recipes-core/rhino/rhino_1.7r4.bb2
-rw-r--r--recipes-core/servlet-api/servlet2.3_4.1.37.bb4
-rw-r--r--recipes-core/servlet-api/servlet2.4_5.5.26.bb2
-rw-r--r--recipes-core/xalan-j/xalan-j_2.7.1.bb2
-rw-r--r--recipes-core/xerces-j/xerces-j_2.11.0.bb6
-rw-r--r--recipes-core/xml-commons/jaxp1.3_1.4.01.bb4
-rw-r--r--recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb6
-rw-r--r--recipes-core/xml-commons/xpp2_2.1.10.bb2
-rw-r--r--recipes-core/xml-commons/xpp3_1.1.3.4.O.bb2
39 files changed, 51 insertions, 53 deletions
diff --git a/classes/java-bootstrap-components.bbclass b/classes/java-bootstrap-components.bbclass
deleted file mode 100644
index 0c62b5b..0000000
--- a/classes/java-bootstrap-components.bbclass
+++ /dev/null
@@ -1,7 +0,0 @@
1# This is to be used by recipes which rely on java-library.bbclass
2# infrastructure and their a *-native recipe are parts of the bootstrap
3# process
4#
5
6DEPENDS_prepend_class-native = " ecj-bootstrap-native "
7DEPENDS_prepend_class-target = " virtual/javac-native "
diff --git a/classes/java-library.bbclass b/classes/java-library.bbclass
index a192f14..144cd2f 100644
--- a/classes/java-library.bbclass
+++ b/classes/java-library.bbclass
@@ -35,8 +35,7 @@ def java_package_name(d):
35 35
36JPN ?= "${@java_package_name(d)}" 36JPN ?= "${@java_package_name(d)}"
37 37
38DEPENDS_prepend = " fastjar-native " 38DEPENDS_prepend = "virtual/javac-native fastjar-native "
39DEPENDS_prepend_class-target = " virtual/javac-native "
40 39
41PACKAGES += "${JPN}" 40PACKAGES += "${JPN}"
42 41
diff --git a/recipes-core/ant/ant-native_1.8.1.bb b/recipes-core/ant/ant-native_1.8.1.bb
index 6cdbc80..35b45d6 100644
--- a/recipes-core/ant/ant-native_1.8.1.bb
+++ b/recipes-core/ant/ant-native_1.8.1.bb
@@ -11,7 +11,7 @@ SRC_URI = "http://archive.apache.org/dist/ant/source/apache-ant-${PV}-src.tar.gz
11 11
12S = "${WORKDIR}/apache-ant-${PV}" 12S = "${WORKDIR}/apache-ant-${PV}"
13 13
14inherit java-library java-native java-bootstrap-components 14inherit java-library java-native
15 15
16DEPENDS = " \ 16DEPENDS = " \
17 jsch-native bsf-native xalan-j-native xerces-j-native \ 17 jsch-native bsf-native xalan-j-native xerces-j-native \
diff --git a/recipes-core/antlr/antlr_2.7.7.bb b/recipes-core/antlr/antlr_2.7.7.bb
index cff9535..9d9d2d4 100644
--- a/recipes-core/antlr/antlr_2.7.7.bb
+++ b/recipes-core/antlr/antlr_2.7.7.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=361934e706423915b4d9f413ad37fb65"
7SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz" 7SRC_URI = "http://www.antlr2.org/download/${BP}.tar.gz"
8SRC_URI_append_class-native = " file://runantlr" 8SRC_URI_append_class-native = " file://runantlr"
9 9
10inherit java-library java-bootstrap-components 10inherit java-library
11 11
12do_configure_class-native() { 12do_configure_class-native() {
13 sed -i -e"s|@JAR_FILE@|${STAGING_DATADIR_JAVA_NATIVE}/antlr.jar|" ${WORKDIR}/runantlr 13 sed -i -e"s|@JAR_FILE@|${STAGING_DATADIR_JAVA_NATIVE}/antlr.jar|" ${WORKDIR}/runantlr
diff --git a/recipes-core/cacao/cacao_1.6.1.bb b/recipes-core/cacao/cacao_1.6.1.bb
index 03ce0cc..ce1ffc2 100644
--- a/recipes-core/cacao/cacao_1.6.1.bb
+++ b/recipes-core/cacao/cacao_1.6.1.bb
@@ -7,9 +7,7 @@ SECTION = "interpreters"
7DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-native bdwgc-native" 7DEPENDS_class-native = "zlib-native libtool-native ecj-initial-native fastjar-native classpath-native bdwgc-native"
8#PROVIDES_class-native = "virtual/java-native" 8#PROVIDES_class-native = "virtual/java-native"
9 9
10DEPENDS_append_class-target = " virtual/javac-native " 10DEPENDS = "zlib libtool classpath virtual/javac-native bdwgc"
11
12DEPENDS = "zlib libtool classpath bdwgc"
13RPROVIDES_${PN} = "java2-runtime" 11RPROVIDES_${PN} = "java2-runtime"
14 12
15SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.xz \ 13SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.xz \
diff --git a/recipes-core/classpath/classpath.inc b/recipes-core/classpath/classpath.inc
index c56c0c3..1bdfd78 100644
--- a/recipes-core/classpath/classpath.inc
+++ b/recipes-core/classpath/classpath.inc
@@ -7,9 +7,9 @@ LICENSE = "Classpath"
7 7
8PBN = "classpath" 8PBN = "classpath"
9 9
10inherit autotools java gettext java-bootstrap-components 10inherit autotools java gettext
11 11
12DEPENDS = " fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file" 12DEPENDS = "virtual/javac-native fastjar-native zip-native gmp antlr-native gtk+ gconf libxtst file"
13 13
14RPROVIDES_${PN} = "" 14RPROVIDES_${PN} = ""
15 15
diff --git a/recipes-core/classpathx/gnujaf_1.1.1.bb b/recipes-core/classpathx/gnujaf_1.1.1.bb
index 5520ef7..0bd8b57 100644
--- a/recipes-core/classpathx/gnujaf_1.1.1.bb
+++ b/recipes-core/classpathx/gnujaf_1.1.1.bb
@@ -10,7 +10,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/classpathx/activation-${PV}.tar.gz \
10 file://MimeType-symbols-fix.patch \ 10 file://MimeType-symbols-fix.patch \
11 " 11 "
12 12
13inherit java-library java-bootstrap-components 13inherit java-library
14 14
15S = "${WORKDIR}/activation-${PV}" 15S = "${WORKDIR}/activation-${PV}"
16 16
diff --git a/recipes-core/classpathx/gnumail_1.1.2.bb b/recipes-core/classpathx/gnumail_1.1.2.bb
index b498c2b..f5033c5 100644
--- a/recipes-core/classpathx/gnumail_1.1.2.bb
+++ b/recipes-core/classpathx/gnumail_1.1.2.bb
@@ -9,7 +9,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/classpathx/mail-${PV}.tar.gz \
9 file://fix_makefile_race_condition.patch \ 9 file://fix_makefile_race_condition.patch \
10 " 10 "
11 11
12inherit java-library java-bootstrap-components autotools 12inherit java-library autotools
13 13
14S = "${WORKDIR}/mail-${PV}" 14S = "${WORKDIR}/mail-${PV}"
15 15
diff --git a/recipes-core/classpathx/inetlib_1.1.1.bb b/recipes-core/classpathx/inetlib_1.1.1.bb
index 3b3f299..f078e33 100644
--- a/recipes-core/classpathx/inetlib_1.1.1.bb
+++ b/recipes-core/classpathx/inetlib_1.1.1.bb
@@ -9,7 +9,7 @@ SRC_URI = "http://ftp.gnu.org/gnu/classpath/${BP}.tar.gz \
9 file://datadir_java.patch \ 9 file://datadir_java.patch \
10 " 10 "
11 11
12inherit java-library java-bootstrap-components autotools 12inherit java-library autotools
13 13
14JPN = "libgnuinet-java" 14JPN = "libgnuinet-java"
15 15
diff --git a/recipes-core/cup/cup_0.10k.bb b/recipes-core/cup/cup_0.10k.bb
index f2f254e..2a957f9 100644
--- a/recipes-core/cup/cup_0.10k.bb
+++ b/recipes-core/cup/cup_0.10k.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=2c9db91c00f38e52cfc8e67bafaa7c
7RDEPENDS_${PN} = "java2-runtime" 7RDEPENDS_${PN} = "java2-runtime"
8RDEPENDS_${PN}_virtclass-native = "" 8RDEPENDS_${PN}_virtclass-native = ""
9 9
10inherit java-library java-bootstrap-components 10inherit java-library
11 11
12SRC_URI = "http://www.cs.princeton.edu/~appel/modern/java/CUP/java_${BPN}_v10k.tar.gz \ 12SRC_URI = "http://www.cs.princeton.edu/~appel/modern/java/CUP/java_${BPN}_v10k.tar.gz \
13 file://cup \ 13 file://cup \
diff --git a/recipes-core/ecj/ecj-bootstrap-native.bb b/recipes-core/ecj/ecj-bootstrap-native.bb
index 28414c2..94ce6aa 100644
--- a/recipes-core/ecj/ecj-bootstrap-native.bb
+++ b/recipes-core/ecj/ecj-bootstrap-native.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
12 " 12 "
13PR = "r1" 13PR = "r1"
14 14
15DEPENDS = "libecj-bootstrap-native cacao-native" 15DEPENDS = "libecj-bootstrap-native virtual/java-native"
16 16
17SRC_URI = "file://ecj.in" 17SRC_URI = "file://ecj.in"
18 18
diff --git a/recipes-core/ecj/libecj-bootstrap.inc b/recipes-core/ecj/libecj-bootstrap.inc
index a634a31..020b8d3 100644
--- a/recipes-core/ecj/libecj-bootstrap.inc
+++ b/recipes-core/ecj/libecj-bootstrap.inc
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.eclipse.org/"
5LICENSE = "EPL-1.0" 5LICENSE = "EPL-1.0"
6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6" 6LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/EPL-1.0;md5=57f8d5e2b3e98ac6e088986c12bf94e6"
7 7
8DEPENDS = "fastjar-native jikes-initial-native cacao-initial-native" 8DEPENDS = "fastjar-native jikes-initial-native virtual/java-initial-native"
9 9
10INC_PR = "r5" 10INC_PR = "r5"
11 11
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc
index 279700b..43385e9 100644
--- a/recipes-core/icedtea/icedtea7-native.inc
+++ b/recipes-core/icedtea/icedtea7-native.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://icedtea.classpath.org"
3LICENSE = "GPL-2.0-with-classpath-exception" 3LICENSE = "GPL-2.0-with-classpath-exception"
4INC_PR = "r1" 4INC_PR = "r1"
5 5
6DEPENDS = "fastjar-native cacao-native classpath-native \ 6DEPENDS = "virtual/javac-native virtual/java-native classpath-native \
7 rhino-native ant-native libxslt-native attr-native \ 7 rhino-native ant-native libxslt-native attr-native \
8 giflib-native jpeg-native libpng-native \ 8 giflib-native jpeg-native libpng-native \
9 glib-2.0-native freetype-native zlib-native \ 9 glib-2.0-native freetype-native zlib-native \
diff --git a/recipes-core/jacl/jacl_1.4.1.bb b/recipes-core/jacl/jacl_1.4.1.bb
index f9808ca..b413719 100644
--- a/recipes-core/jacl/jacl_1.4.1.bb
+++ b/recipes-core/jacl/jacl_1.4.1.bb
@@ -10,7 +10,7 @@ HOMEPAGE = "http://sourceforge.net/projects/tcljava"
10 10
11SRC_URI = "http://downloads.sourceforge.net/tcljava/jacl${PV}.tar.gz" 11SRC_URI = "http://downloads.sourceforge.net/tcljava/jacl${PV}.tar.gz"
12 12
13inherit java-library java-bootstrap-components 13inherit java-library
14 14
15S = "${WORKDIR}/jacl${PV}" 15S = "${WORKDIR}/jacl${PV}"
16 16
diff --git a/recipes-core/jakarta-commons/commons-logging_1.1.1.bb b/recipes-core/jakarta-commons/commons-logging_1.1.1.bb
index 8b1efe0..b3b508a 100644
--- a/recipes-core/jakarta-commons/commons-logging_1.1.1.bb
+++ b/recipes-core/jakarta-commons/commons-logging_1.1.1.bb
@@ -1,7 +1,5 @@
1require jakarta-commons.inc 1require jakarta-commons.inc
2 2
3inherit java-bootstrap-components
4
5PR = "${INC_PR}.1" 3PR = "${INC_PR}.1"
6 4
7DESCRIPTION = "Java Internet protocol suite library" 5DESCRIPTION = "Java Internet protocol suite library"
diff --git a/recipes-core/jakarta-commons/commons-net_1.4.1.bb b/recipes-core/jakarta-commons/commons-net_1.4.1.bb
index 7c03b82..275ebb9 100644
--- a/recipes-core/jakarta-commons/commons-net_1.4.1.bb
+++ b/recipes-core/jakarta-commons/commons-net_1.4.1.bb
@@ -1,7 +1,5 @@
1require jakarta-commons.inc 1require jakarta-commons.inc
2 2
3inherit java-bootstrap-components
4
5PR = "${INC_PR}.1" 3PR = "${INC_PR}.1"
6 4
7DESCRIPTION = "Java Internet protocol suite library" 5DESCRIPTION = "Java Internet protocol suite library"
diff --git a/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb b/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb
index 2e2bb59..081cfe7 100644
--- a/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb
+++ b/recipes-core/jakarta-libs/avalon-framework-api_4.3.bb
@@ -9,7 +9,7 @@ SRC_URI = " \
9 http://archive.apache.org/dist/avalon/logkit/source/logkit-1.2.2-src.tar.gz;name=logkit \ 9 http://archive.apache.org/dist/avalon/logkit/source/logkit-1.2.2-src.tar.gz;name=logkit \
10 " 10 "
11 11
12inherit java-library java-bootstrap-components 12inherit java-library
13 13
14do_compile() { 14do_compile() {
15 mkdir -p build 15 mkdir -p build
diff --git a/recipes-core/jakarta-libs/bsf_2.4.0.bb b/recipes-core/jakarta-libs/bsf_2.4.0.bb
index e23503c..0213004 100644
--- a/recipes-core/jakarta-libs/bsf_2.4.0.bb
+++ b/recipes-core/jakarta-libs/bsf_2.4.0.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b1e01b26bacfc2232046c90a330332b3"
6 6
7SRC_URI = "http://archive.apache.org/dist/jakarta/bsf/source/bsf-src-${PV}.tar.gz" 7SRC_URI = "http://archive.apache.org/dist/jakarta/bsf/source/bsf-src-${PV}.tar.gz"
8 8
9inherit java-library java-bootstrap-components 9inherit java-library
10 10
11DEPENDS = "jacl commons-logging rhino xalan-j bcel" 11DEPENDS = "jacl commons-logging rhino xalan-j bcel"
12DEPENDS_virtclass-native = "jacl-native commons-logging-native rhino-native xalan-j-native bcel-native" 12DEPENDS_virtclass-native = "jacl-native commons-logging-native rhino-native xalan-j-native bcel-native"
diff --git a/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb
index 50ef4a2..b4ccd2c 100644
--- a/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb
+++ b/recipes-core/jakarta-libs/log4j1.2_1.2.17.bb
@@ -7,7 +7,7 @@ PR = "r2"
7 7
8SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/log4j-${PV}.tar.gz" 8SRC_URI = "http://archive.apache.org/dist/logging/log4j/${PV}/log4j-${PV}.tar.gz"
9 9
10inherit java-library java-bootstrap-components 10inherit java-library
11 11
12DEPENDS = "gnumail gnujaf" 12DEPENDS = "gnumail gnujaf"
13DEPENDS_virtclass-native = "gnumail-native gnujaf-native" 13DEPENDS_virtclass-native = "gnumail-native gnujaf-native"
diff --git a/recipes-core/jakarta-libs/logkit_1.2.2.bb b/recipes-core/jakarta-libs/logkit_1.2.2.bb
index 24fdfac..c3b612b 100644
--- a/recipes-core/jakarta-libs/logkit_1.2.2.bb
+++ b/recipes-core/jakarta-libs/logkit_1.2.2.bb
@@ -6,7 +6,7 @@ PR = "r1"
6 6
7SRC_URI = "http://archive.apache.org/dist/avalon/logkit/source/${BP}-src.tar.gz" 7SRC_URI = "http://archive.apache.org/dist/avalon/logkit/source/${BP}-src.tar.gz"
8 8
9inherit java-library java-bootstrap-components 9inherit java-library
10 10
11S = "${WORKDIR}/${BP}-dev" 11S = "${WORKDIR}/${BP}-dev"
12 12
diff --git a/recipes-core/jakarta-libs/oro_2.0.8.bb b/recipes-core/jakarta-libs/oro_2.0.8.bb
index 308eb55..0a7fba3 100644
--- a/recipes-core/jakarta-libs/oro_2.0.8.bb
+++ b/recipes-core/jakarta-libs/oro_2.0.8.bb
@@ -6,7 +6,7 @@ PR = "r1"
6 6
7SRC_URI = "http://archive.apache.org/dist/jakarta/oro/source/jakarta-${BP}.tar.gz" 7SRC_URI = "http://archive.apache.org/dist/jakarta/oro/source/jakarta-${BP}.tar.gz"
8 8
9inherit java-library java-bootstrap-components 9inherit java-library
10 10
11S = "${WORKDIR}/jakarta-${BP}" 11S = "${WORKDIR}/jakarta-${BP}"
12 12
diff --git a/recipes-core/jakarta-libs/poi_3.0.bb b/recipes-core/jakarta-libs/poi_3.0.bb
index 55279c1..f9178f2 100644
--- a/recipes-core/jakarta-libs/poi_3.0.bb
+++ b/recipes-core/jakarta-libs/poi_3.0.bb
@@ -9,7 +9,7 @@ S = "${WORKDIR}/${BPN}-3.0-rc4"
9 9
10inherit java-library 10inherit java-library
11 11
12DEPENDS = "commons-collections3 commons-logging commons-lang commons-beanutils log4j1.2 xalan-j" 12DEPENDS = "fastjar-native commons-collections3 commons-logging commons-lang commons-beanutils log4j1.2 xalan-j"
13 13
14do_compile() { 14do_compile() {
15 mkdir -p build 15 mkdir -p build
diff --git a/recipes-core/jakarta-libs/regexp_1.5.bb b/recipes-core/jakarta-libs/regexp_1.5.bb
index d482e4a..ce6150c 100644
--- a/recipes-core/jakarta-libs/regexp_1.5.bb
+++ b/recipes-core/jakarta-libs/regexp_1.5.bb
@@ -6,7 +6,7 @@ PR = "r1"
6 6
7SRC_URI = "http://archive.apache.org/dist/jakarta/regexp/source/jakarta-${BP}.tar.gz" 7SRC_URI = "http://archive.apache.org/dist/jakarta/regexp/source/jakarta-${BP}.tar.gz"
8 8
9inherit java-library java-bootstrap-components 9inherit java-library
10 10
11S = "${WORKDIR}/jakarta-${BP}" 11S = "${WORKDIR}/jakarta-${BP}"
12 12
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index 6480225..5893cbc 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://jamvm.sourceforge.net/"
3LICENSE = "GPL-2.0" 3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3" 4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5 5
6DEPENDS = "zlib classpath libffi" 6DEPENDS = "zlib classpath virtual/javac-native libffi"
7DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial-native libffi-native" 7DEPENDS_virtclass-native = "zlib-native classpath-native ecj-initial-native libffi-native"
8 8
9RDEPENDS_${PN} = "classpath" 9RDEPENDS_${PN} = "classpath"
@@ -21,7 +21,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/jamvm/jamvm-${PV}.tar.gz \
21 " 21 "
22 22
23 23
24inherit java autotools update-alternatives pkgconfig java-bootstrap-components 24inherit java autotools update-alternatives pkgconfig
25 25
26# This uses 32 bit arm, so force the instruction set to arm, not thumb 26# This uses 32 bit arm, so force the instruction set to arm, not thumb
27ARM_INSTRUCTION_SET = "arm" 27ARM_INSTRUCTION_SET = "arm"
diff --git a/recipes-core/jcraft/jsch_0.1.40.bb b/recipes-core/jcraft/jsch_0.1.40.bb
index d22eb0a..337a8eb 100644
--- a/recipes-core/jcraft/jsch_0.1.40.bb
+++ b/recipes-core/jcraft/jsch_0.1.40.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55e3b6a0987ccd0c34530f3df2d206ae"
5 5
6SRC_URI = "${SOURCEFORGE_MIRROR}/jsch/jsch-${PV}.zip" 6SRC_URI = "${SOURCEFORGE_MIRROR}/jsch/jsch-${PV}.zip"
7 7
8inherit java-library java-bootstrap-components 8inherit java-library
9 9
10DEPENDS = "jzlib" 10DEPENDS = "jzlib"
11DEPENDS_virtclass-native = "jzlib-native" 11DEPENDS_virtclass-native = "jzlib-native"
diff --git a/recipes-core/jcraft/jzlib_1.0.7.bb b/recipes-core/jcraft/jzlib_1.0.7.bb
index 79fc4d4..b6f3f64 100644
--- a/recipes-core/jcraft/jzlib_1.0.7.bb
+++ b/recipes-core/jcraft/jzlib_1.0.7.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://www.jcraft.com/jzlib"
6 6
7SRC_URI = "http://www.jcraft.com/jzlib/jzlib-${PV}.tar.gz" 7SRC_URI = "http://www.jcraft.com/jzlib/jzlib-${PV}.tar.gz"
8 8
9inherit java-library java-bootstrap-components 9inherit java-library
10 10
11do_compile() { 11do_compile() {
12 mkdir -p build 12 mkdir -p build
diff --git a/recipes-core/jdepend/jdepend_2.9.1.bb b/recipes-core/jdepend/jdepend_2.9.1.bb
index 8f41c00..9f74f44 100644
--- a/recipes-core/jdepend/jdepend_2.9.1.bb
+++ b/recipes-core/jdepend/jdepend_2.9.1.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "http://clarkware.com/software/JDepend.html"
8 8
9SRC_URI = "http://www.clarkware.com/software/jdepend-${PV}.zip" 9SRC_URI = "http://www.clarkware.com/software/jdepend-${PV}.zip"
10 10
11inherit java-library java-bootstrap-components 11inherit java-library
12 12
13do_compile() { 13do_compile() {
14 mkdir -p build 14 mkdir -p build
diff --git a/recipes-core/jlex/jlex_1.2.6.bb b/recipes-core/jlex/jlex_1.2.6.bb
index 9290fa5..4dbe63e 100644
--- a/recipes-core/jlex/jlex_1.2.6.bb
+++ b/recipes-core/jlex/jlex_1.2.6.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d
8RDEPENDS_${PN} = "java2-runtime" 8RDEPENDS_${PN} = "java2-runtime"
9RDEPENDS_${PN}_virtclass-native = "" 9RDEPENDS_${PN}_virtclass-native = ""
10 10
11inherit java-library java-bootstrap-components 11inherit java-library
12 12
13SRC_URI = "http://www.cs.princeton.edu/~appel/modern/java/JLex/Archive/${PV}/Main.java \ 13SRC_URI = "http://www.cs.princeton.edu/~appel/modern/java/JLex/Archive/${PV}/Main.java \
14 file://jlex \ 14 file://jlex \
diff --git a/recipes-core/junit/junit4_4.3.1.bb b/recipes-core/junit/junit4_4.3.1.bb
index 8d9dd31..1cb8674 100644
--- a/recipes-core/junit/junit4_4.3.1.bb
+++ b/recipes-core/junit/junit4_4.3.1.bb
@@ -8,7 +8,9 @@ SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar"
8 8
9S = "${WORKDIR}" 9S = "${WORKDIR}"
10 10
11inherit java-library java-bootstrap-components 11inherit java-library
12
13DEPENDS = "fastjar-native"
12 14
13do_compile() { 15do_compile() {
14 mkdir -p build 16 mkdir -p build
diff --git a/recipes-core/junit/junit_3.8.2.bb b/recipes-core/junit/junit_3.8.2.bb
index 54ce9fe..bae022d 100644
--- a/recipes-core/junit/junit_3.8.2.bb
+++ b/recipes-core/junit/junit_3.8.2.bb
@@ -11,7 +11,7 @@ S = "${WORKDIR}/junit${PV}"
11 11
12DEPENDS += "unzip-native" 12DEPENDS += "unzip-native"
13 13
14inherit java-library java-bootstrap-components 14inherit java-library
15 15
16do_unpackpost() { 16do_unpackpost() {
17 mkdir -p src 17 mkdir -p src
diff --git a/recipes-core/rhino/rhino_1.7r4.bb b/recipes-core/rhino/rhino_1.7r4.bb
index 76c3057..7898d23 100644
--- a/recipes-core/rhino/rhino_1.7r4.bb
+++ b/recipes-core/rhino/rhino_1.7r4.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8e2372bdbf22c99279ae4599a13cc458"
4 4
5BBCLASSEXTEND = "native" 5BBCLASSEXTEND = "native"
6 6
7inherit java-library java-bootstrap-components 7inherit java-library
8 8
9SRC_URI = "\ 9SRC_URI = "\
10 https://github.com/downloads/mozilla/rhino/rhino1_7R4.zip \ 10 https://github.com/downloads/mozilla/rhino/rhino1_7R4.zip \
diff --git a/recipes-core/servlet-api/servlet2.3_4.1.37.bb b/recipes-core/servlet-api/servlet2.3_4.1.37.bb
index f5f6d4a..fbda5c8 100644
--- a/recipes-core/servlet-api/servlet2.3_4.1.37.bb
+++ b/recipes-core/servlet-api/servlet2.3_4.1.37.bb
@@ -6,10 +6,12 @@ PR = "r1"
6 6
7SRC_URI = "http://archive.apache.org/dist/tomcat/tomcat-4/v${PV}/src/apache-tomcat-${PV}-src.tar.gz" 7SRC_URI = "http://archive.apache.org/dist/tomcat/tomcat-4/v${PV}/src/apache-tomcat-${PV}-src.tar.gz"
8 8
9inherit java-library java-bootstrap-components 9inherit java-library
10 10
11S = "${WORKDIR}/apache-tomcat-${PV}-src/servletapi" 11S = "${WORKDIR}/apache-tomcat-${PV}-src/servletapi"
12 12
13DEPENDS = "fastjar-native"
14
13# Value of implementation.revision in build.xml 15# Value of implementation.revision in build.xml
14IMPL_REVISION = "1" 16IMPL_REVISION = "1"
15 17
diff --git a/recipes-core/servlet-api/servlet2.4_5.5.26.bb b/recipes-core/servlet-api/servlet2.4_5.5.26.bb
index 7d0feb3..b34b23d 100644
--- a/recipes-core/servlet-api/servlet2.4_5.5.26.bb
+++ b/recipes-core/servlet-api/servlet2.4_5.5.26.bb
@@ -9,6 +9,8 @@ S = "${WORKDIR}/apache-tomcat-${PV}-src/servletapi/jsr154"
9 9
10inherit java-library 10inherit java-library
11 11
12DEPENDS = "fastjar-native"
13
12# Value of implementation.revision in build.xml 14# Value of implementation.revision in build.xml
13IMPL_REVISION = "1" 15IMPL_REVISION = "1"
14 16
diff --git a/recipes-core/xalan-j/xalan-j_2.7.1.bb b/recipes-core/xalan-j/xalan-j_2.7.1.bb
index 16f5396..317b3c9 100644
--- a/recipes-core/xalan-j/xalan-j_2.7.1.bb
+++ b/recipes-core/xalan-j/xalan-j_2.7.1.bb
@@ -21,7 +21,7 @@ SRC_URI = "\
21 21
22S = "${WORKDIR}/${BPN}_2_7_1" 22S = "${WORKDIR}/${BPN}_2_7_1"
23 23
24inherit java-library java-bootstrap-components 24inherit java-library
25 25
26JPN = "libxalan2-java" 26JPN = "libxalan2-java"
27 27
diff --git a/recipes-core/xerces-j/xerces-j_2.11.0.bb b/recipes-core/xerces-j/xerces-j_2.11.0.bb
index 4130457..f9e497e 100644
--- a/recipes-core/xerces-j/xerces-j_2.11.0.bb
+++ b/recipes-core/xerces-j/xerces-j_2.11.0.bb
@@ -16,12 +16,12 @@ SRC_URI = "http://archive.apache.org/dist/xerces/j/Xerces-J-src.${PV}.tar.gz"
16 16
17S = "${WORKDIR}/xerces-2_11_0" 17S = "${WORKDIR}/xerces-2_11_0"
18 18
19inherit java-library java-bootstrap-components 19inherit java-library
20 20
21JPN = "libxerces2-java" 21JPN = "libxerces2-java"
22 22
23DEPENDS = "jaxp1.3 xml-commons-resolver1.1" 23DEPENDS = "fastjar-native jaxp1.3 xml-commons-resolver1.1"
24DEPENDS_virtclass-native = "jaxp1.3-native xml-commons-resolver1.1-native" 24DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native xml-commons-resolver1.1-native"
25 25
26RDEPENDS_${PN} = "libjaxp1.3-java libxml-commons-resolver1.1-java" 26RDEPENDS_${PN} = "libjaxp1.3-java libxml-commons-resolver1.1-java"
27RDEPENDS_${PN}_virtclass-native = "" 27RDEPENDS_${PN}_virtclass-native = ""
diff --git a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb
index 765b766..a6eeb57 100644
--- a/recipes-core/xml-commons/jaxp1.3_1.4.01.bb
+++ b/recipes-core/xml-commons/jaxp1.3_1.4.01.bb
@@ -11,7 +11,9 @@ LIC_FILES_CHKSUM = " \
11 11
12SRC_URI = "http://archive.apache.org/dist/xml/commons/source/xml-commons-external-${PV}-src.tar.gz;subdir=${BPN}-${PV}" 12SRC_URI = "http://archive.apache.org/dist/xml/commons/source/xml-commons-external-${PV}-src.tar.gz;subdir=${BPN}-${PV}"
13 13
14inherit java-library java-bootstrap-components 14inherit java-library
15
16DEPENDS = "fastjar-native"
15 17
16JARFILENAME = "jaxp-1.3.jar" 18JARFILENAME = "jaxp-1.3.jar"
17ALTJARFILENAMES = "xml-apis.jar" 19ALTJARFILENAMES = "xml-apis.jar"
diff --git a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
index ca1f2f2..5853895 100644
--- a/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
+++ b/recipes-core/xml-commons/xml-commons-resolver1.1_1.2.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://LICENSE.resolver.txt;md5=d229da563da18fe5d58cd95a6467
6 6
7SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz" 7SRC_URI = "http://archive.apache.org/dist/xml/commons/xml-commons-resolver-${PV}.tar.gz"
8 8
9inherit java-library java-bootstrap-components 9inherit java-library
10 10
11S = "${WORKDIR}/xml-commons-resolver-${PV}" 11S = "${WORKDIR}/xml-commons-resolver-${PV}"
12 12
13DEPENDS = "jaxp1.3" 13DEPENDS = "fastjar-native jaxp1.3"
14DEPENDS_virtclass-native = "jaxp1.3-native" 14DEPENDS_virtclass-native = "fastjar-native jaxp1.3-native"
15 15
16do_unpackpost() { 16do_unpackpost() {
17 find src -exec \ 17 find src -exec \
diff --git a/recipes-core/xml-commons/xpp2_2.1.10.bb b/recipes-core/xml-commons/xpp2_2.1.10.bb
index 402d38d..d3baca4 100644
--- a/recipes-core/xml-commons/xpp2_2.1.10.bb
+++ b/recipes-core/xml-commons/xpp2_2.1.10.bb
@@ -9,6 +9,8 @@ S = "${WORKDIR}/PullParser${PV}"
9 9
10inherit java-library 10inherit java-library
11 11
12DEPENDS = "fastjar-native virtual/javac-native"
13
12do_compile() { 14do_compile() {
13 if [ -d build-oe ]; then 15 if [ -d build-oe ]; then
14 rm -rf build-oe 16 rm -rf build-oe
diff --git a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
index a472a0d..bedb8a9 100644
--- a/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
+++ b/recipes-core/xml-commons/xpp3_1.1.3.4.O.bb
@@ -8,6 +8,8 @@ SRC_URI = "http://www.extreme.indiana.edu/dist/java-repository/xpp3/distribution
8 8
9inherit java-library 9inherit java-library
10 10
11DEPENDS = "fastjar-native virtual/javac-native"
12
11PACKAGES = "libxpp3-xpath-java ${JPN}" 13PACKAGES = "libxpp3-xpath-java ${JPN}"
12 14
13do_compile() { 15do_compile() {