summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody P Schafer <dev@codyps.com>2016-11-18 10:25:13 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2016-12-06 16:25:08 -0200
commita70bf4a9e3e1c03ff1cc2d0db228a383943c54db (patch)
tree69398a2f0b197b637a54056797b03b13f11d5841
parent9edf7d5aa5bdcf9afc4365fd1d85feca72b4ef1a (diff)
downloadmeta-java-a70bf4a9e3e1c03ff1cc2d0db228a383943c54db.tar.gz
openjdk-7: ignore the readdir_r deprecation already ignored in openjdk-8
Without this, icedtea7-native (used to bootstrap openjdk) fails to build on my host system due to deprecation warnings being treated as errors. I haven't observed the same issue with openjdk-7 itself, but it seems likely to affect it as well, so I've added the -Wno-error flag there too. Signed-off-by: Cody P Schafer <dev@codyps.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
-rw-r--r--recipes-core/icedtea/openjdk-7-release-03b147.inc4
-rw-r--r--recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb4
2 files changed, 8 insertions, 0 deletions
diff --git a/recipes-core/icedtea/openjdk-7-release-03b147.inc b/recipes-core/icedtea/openjdk-7-release-03b147.inc
index 0685729..fe18ee5 100644
--- a/recipes-core/icedtea/openjdk-7-release-03b147.inc
+++ b/recipes-core/icedtea/openjdk-7-release-03b147.inc
@@ -113,3 +113,7 @@ export DISTRIBUTION_PATCHES = " \
113 patches/icedtea-jdk-unzip.patch \ 113 patches/icedtea-jdk-unzip.patch \
114 ${CLEAN_X11_DISTRIBUTION_PATCH} \ 114 ${CLEAN_X11_DISTRIBUTION_PATCH} \
115 " 115 "
116
117# readdir_r was deprecated in glibc-2.24. Ignore the error for now
118# NOTE: When updating the recipe, please check if this is still needed
119CFLAGS_append = " -Wno-error=deprecated-declarations"
diff --git a/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
index 711f572..eba353e 100644
--- a/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
+++ b/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb
@@ -64,3 +64,7 @@ DISTRIBUTION_PATCHES = "\
64" 64"
65 65
66export DISTRIBUTION_PATCHES 66export DISTRIBUTION_PATCHES
67
68# readdir_r was deprecated in glibc-2.24. Ignore the error for now
69# NOTE: When updating the recipe, please check if this is still needed
70CFLAGS_append = " -Wno-error=deprecated-declarations"