summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2016-06-21 15:07:07 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2016-06-30 12:06:14 -0300
commit6483010d92be7f6e1e0a268d1ca4b5fc4353c70e (patch)
tree7bcb58d0d58d93f124a856c2faecc8eec667c6e0
parent8ee871a86a9999a2272d103855033da4685165d8 (diff)
downloadmeta-java-6483010d92be7f6e1e0a268d1ca4b5fc4353c70e.tar.gz
icedtea7-native: make GCC 6 happy
GCC 6 sets the default C++ standard to C++14 and introduces dead store elimination by default. icedtea7 is not ready for either of these changes, so just set the C++ standard back to gnu++98 and disable dead store elimination. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com> Signed-off-by: Dan McGregor <dan.mcgregor@usask.ca> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-core/icedtea/icedtea7-native.inc9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-core/icedtea/icedtea7-native.inc b/recipes-core/icedtea/icedtea7-native.inc
index d624b7a..3344acb 100644
--- a/recipes-core/icedtea/icedtea7-native.inc
+++ b/recipes-core/icedtea/icedtea7-native.inc
@@ -17,6 +17,13 @@ PACKAGECONFIG[x11] = ",--disable-headful,libx11-native xproto-native libxt-nativ
17OEMAKE_BUILD_HEADLESS_ONLY = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', 'BUILD_HEADLESS_ONLY=1', d)}" 17OEMAKE_BUILD_HEADLESS_ONLY = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', 'BUILD_HEADLESS_ONLY=1', d)}"
18CFLAGS_append = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', ' -DHEADLESS=true', d)}" 18CFLAGS_append = "${@bb.utils.contains('PACKAGECONFIG', 'x11', '', ' -DHEADLESS=true', d)}"
19 19
20# Disable dead store elimination and set C++ standard to C++98.
21# There are dead stores in the JVM that would be pretty hard to
22# remove, so disable the optimisation in the compiler.
23CFLAGS_append = " -fno-tree-dse"
24CXXFLAGS_append = " -fno-tree-dse"
25CXX_append = " -std=gnu++98"
26
20inherit native java autotools pkgconfig 27inherit native java autotools pkgconfig
21 28
22JAVA_HOME[unexport] = "1" 29JAVA_HOME[unexport] = "1"
@@ -153,6 +160,8 @@ do_configure_append() {
153 for F in openjdk/hotspot/make/linux/makefiles/gcc.make openjdk/hotspot/agent/src/os/linux/Makefile ; 160 for F in openjdk/hotspot/make/linux/makefiles/gcc.make openjdk/hotspot/agent/src/os/linux/Makefile ;
154 do 161 do
155 sed -i \ 162 sed -i \
163 -e"s|HOST_GCC = gcc$|HOST_GCC = ${CC}|" \
164 -e"s|HOST_CPP = g++$|HOST_CPP = ${CXX}|" \
156 -e"s|gcc\$(GCC_SUFFIX)|${CC}|" \ 165 -e"s|gcc\$(GCC_SUFFIX)|${CC}|" \
157 -e"s|g++\$(GCC_SUFFIX)|${CXX}|" \ 166 -e"s|g++\$(GCC_SUFFIX)|${CXX}|" \
158 $F 167 $F