summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorErkka Kääriä <erkka.kaaria@intel.com>2016-03-21 13:39:11 +0200
committerMaxin B. John <maxin.john@intel.com>2016-03-23 11:52:26 +0200
commitd354a638e7e919bebbde3c21c830b19aca004809 (patch)
treeca8b747f2c4789fce490d99a756c625a3b2a8876
parent4c9dfc2b14676db414d915ba3bab9e101de73e05 (diff)
downloadmeta-java-d354a638e7e919bebbde3c21c830b19aca004809.tar.gz
Openjdk-8: Fix openjdk build when CXX contains assembler arguments
Builds currently fail, if CXX also contains assembler arguments. These arguments are in form "-Wa,args,are,here". When this string is then used in openjdk make process, it is inserted before the make evaluates its argument lists. As these lists are comma separated, the commas in assembler argument list are interpreted as list separators, which breaks the build. This is fixed by adding the extra '$', which means the string is inserted after make evaluates the list. Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
-rw-r--r--recipes-core/openjdk/openjdk-8_72b05.bb1
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/openjdk8-fix-assembler-flag-handling-in-makefile.patch20
2 files changed, 21 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-8_72b05.bb b/recipes-core/openjdk/openjdk-8_72b05.bb
index e0a786a..1a01630 100644
--- a/recipes-core/openjdk/openjdk-8_72b05.bb
+++ b/recipes-core/openjdk/openjdk-8_72b05.bb
@@ -9,6 +9,7 @@ PATCHES_URI_append = "\
9 file://openjdk8-fix-shark-build.patch;apply=no \ 9 file://openjdk8-fix-shark-build.patch;apply=no \
10 file://openjdk8-fix-shark-stdc++11.patch;apply=no \ 10 file://openjdk8-fix-shark-stdc++11.patch;apply=no \
11 file://openjdk8-use_builtin_frame_address_0_rather_than_returning_address_of_local_variable.patch;apply=no \ 11 file://openjdk8-use_builtin_frame_address_0_rather_than_returning_address_of_local_variable.patch;apply=no \
12 file://openjdk8-fix-assembler-flag-handling-in-makefile.patch;apply=no \
12" 13"
13 14
14do_compile_append() { 15do_compile_append() {
diff --git a/recipes-core/openjdk/patches-openjdk-8/openjdk8-fix-assembler-flag-handling-in-makefile.patch b/recipes-core/openjdk/patches-openjdk-8/openjdk8-fix-assembler-flag-handling-in-makefile.patch
new file mode 100644
index 0000000..5e02f28
--- /dev/null
+++ b/recipes-core/openjdk/patches-openjdk-8/openjdk8-fix-assembler-flag-handling-in-makefile.patch
@@ -0,0 +1,20 @@
1Delay $CXX insertion until after make has evaluated the comma-separated list,
2as any comma separated parameters in CXX (such as assembler arguments) would
3break the build
4
5Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com>
6
7Upstream-Status: Pending
8
9---
10--- make/common/NativeCompilation.gmk
11+++ make/common/NativeCompilation.gmk
12@@ -372,7 +372,7 @@ define SetupNativeCompilation
13 $$(foreach p,$$($1_SRCS), \
14 $$(eval $$(call add_native_source,$1,$$p,$$($1_OBJECT_DIR), \
15 $$($1_CFLAGS) $$($1_EXTRA_CFLAGS),$$($1_CC), \
16- $$($1_CXXFLAGS) $$($1_EXTRA_CXXFLAGS),$(CXX),$$($1_ASFLAGS))))
17+ $$($1_CXXFLAGS) $$($1_EXTRA_CXXFLAGS),$$(CXX),$$($1_ASFLAGS))))
18
19 # On windows we need to create a resource file
20 ifeq ($(OPENJDK_TARGET_OS), windows)