summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmy Fong <amy.fong@windriver.com>2015-04-16 14:22:59 -0400
committerOtavio Salvador <otavio@ossystems.com.br>2016-01-04 09:21:06 -0200
commit218db90441fff1fdb2e95a162fb3e7a483dd4efc (patch)
tree206bf716b6dbfc466e2a4d33c73f566322b4169c
parentc64369872559ba6604429070a72003719f54098f (diff)
downloadmeta-java-218db90441fff1fdb2e95a162fb3e7a483dd4efc.tar.gz
openjdk: autools not to override B var
${B} is set before autotools and thus is overrided by autotools. Some of the patches within icedtea are expected to be patched against ${S}/build (during do_configure() phase). As autotools to change B = "${WORKDIR}/build", so this causes some patches failed to apply and hence breaks do_configure() with the following errors: | patching file openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java | can't find file to patch at input line 13 | Perhaps you used the wrong -p or --strip option? | The text leading up to this was: | -------------------------- | |--- | | build/openjdk/corba/make/common/shared/Defs-utils.gmk | 6 +++--- | | build/openjdk/jdk/make/common/Demo.gmk | 2 +- | | build/openjdk/jdk/make/common/Release.gmk | 2 +- | | build/openjdk/jdk/make/common/internal/ImportComponents.gmk | 4 ++-- | | build/openjdk/jdk/make/common/shared/Defs-utils.gmk | 6 +++--- | | build/openjdk/jdk/make/common/shared/Sanity.gmk | 2 +- | | build/openjdk/jdk/make/java/redist/Makefile | 4 ++-- | | 7 files changed, 13 insertions(+), 13 deletions(-) | | | |--- a/build/openjdk/corba/make/common/shared/Defs-utils.gmk | |+++ b/build/openjdk/corba/make/common/shared/Defs-utils.gmk | -------------------------- | File to patch: | Skip this patch? [y] | File to patch: | Skip this patch? [y] | Skipping patch. Signed-off-by: Vu Tran <vu.tran@windriver.com> Signed-off-by: Amy Fong <amy.fong@windriver.com> Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
-rw-r--r--recipes-core/openjdk/openjdk-common.inc3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-core/openjdk/openjdk-common.inc b/recipes-core/openjdk/openjdk-common.inc
index dc26522..6a72572 100644
--- a/recipes-core/openjdk/openjdk-common.inc
+++ b/recipes-core/openjdk/openjdk-common.inc
@@ -7,7 +7,6 @@ SECTION = "libs"
7ICEDTEA_VERSION = "${@bb.parse.BBHandler.vars_from_file(d.getVar('FILE', False),d)[1].split("-")[1] or '1.0'}" 7ICEDTEA_VERSION = "${@bb.parse.BBHandler.vars_from_file(d.getVar('FILE', False),d)[1].split("-")[1] or '1.0'}"
8 8
9S = "${WORKDIR}/${ICEDTEA}" 9S = "${WORKDIR}/${ICEDTEA}"
10B = "${S}/build"
11 10
12DEPENDS_append_libc-uclibc = " virtual/libiconv " 11DEPENDS_append_libc-uclibc = " virtual/libiconv "
13 12
@@ -19,6 +18,8 @@ DEPENDS_append = " qemu-native "
19 18
20inherit java autotools gettext qemu pkgconfig 19inherit java autotools gettext qemu pkgconfig
21 20
21B = "${S}/build"
22
22# OpenJDK uses slightly different names for certain arches. We need to know 23# OpenJDK uses slightly different names for certain arches. We need to know
23# this to create some files which are expected by the build. 24# this to create some files which are expected by the build.
24def get_jdk_arch(d): 25def get_jdk_arch(d):