summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorErkka Kääriä <erkka.kaaria@intel.com>2016-08-23 11:14:56 +0300
committerMaxin B. John <maxin.john@intel.com>2016-08-24 13:49:22 +0300
commit216481ba09c187d0b0fc8f864944af6ae026ff73 (patch)
tree74480f02ead17b2b30486f4f6b8f6d6cfcc64e0c
parent0f127a49696696ac48c394f84232e7f56b29fbe7 (diff)
downloadmeta-java-216481ba09c187d0b0fc8f864944af6ae026ff73.tar.gz
openjdk-8: Fix QA error caused by a missing hash
EXTRA_LDFLAGS were not used when building certain shared objects. This means that the Yocto specific linker flags were lost, which caused build failures due to a bad hash style QA error. Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com> Signed-off-by: Maxin B. John <maxin.john@intel.com>
-rw-r--r--recipes-core/openjdk/openjdk-8_102b14.bb1
-rw-r--r--recipes-core/openjdk/openjre-8_102b14.bb1
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/openjdk8-add-missing-linker-flags.patch57
3 files changed, 59 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-8_102b14.bb b/recipes-core/openjdk/openjdk-8_102b14.bb
index 79c4cda..210c897 100644
--- a/recipes-core/openjdk/openjdk-8_102b14.bb
+++ b/recipes-core/openjdk/openjdk-8_102b14.bb
@@ -12,6 +12,7 @@ PATCHES_URI_append = "\
12 file://openjdk8-fix-adlc-flags.patch;apply=no \ 12 file://openjdk8-fix-adlc-flags.patch;apply=no \
13 file://openjdk8-silence-d_fortify_source-warning.patch;apply=no \ 13 file://openjdk8-silence-d_fortify_source-warning.patch;apply=no \
14 file://openjdk8-fix-zero-mode-crash.patch;apply=no \ 14 file://openjdk8-fix-zero-mode-crash.patch;apply=no \
15 file://openjdk8-add-missing-linker-flags.patch;apply=no \
15" 16"
16 17
17do_install() { 18do_install() {
diff --git a/recipes-core/openjdk/openjre-8_102b14.bb b/recipes-core/openjdk/openjre-8_102b14.bb
index 736269d..88160e1 100644
--- a/recipes-core/openjdk/openjre-8_102b14.bb
+++ b/recipes-core/openjdk/openjre-8_102b14.bb
@@ -12,6 +12,7 @@ PATCHES_URI_append = "\
12 file://openjdk8-fix-adlc-flags.patch;apply=no \ 12 file://openjdk8-fix-adlc-flags.patch;apply=no \
13 file://openjdk8-silence-d_fortify_source-warning.patch;apply=no \ 13 file://openjdk8-silence-d_fortify_source-warning.patch;apply=no \
14 file://openjdk8-fix-zero-mode-crash.patch;apply=no \ 14 file://openjdk8-fix-zero-mode-crash.patch;apply=no \
15 file://openjdk8-add-missing-linker-flags.patch;apply=no \
15" 16"
16 17
17do_install() { 18do_install() {
diff --git a/recipes-core/openjdk/patches-openjdk-8/openjdk8-add-missing-linker-flags.patch b/recipes-core/openjdk/patches-openjdk-8/openjdk8-add-missing-linker-flags.patch
new file mode 100644
index 0000000..92f29b0
--- /dev/null
+++ b/recipes-core/openjdk/patches-openjdk-8/openjdk8-add-missing-linker-flags.patch
@@ -0,0 +1,57 @@
1makefiles: Add missing EXTRA_LDFLAGS to certain files
2
3EXTRA_LDFLAGS were not used when building certain shared objects. This
4means that the Yocto specific linker flags were lost, which caused build
5failures due to a bad hash style.
6
7Signed-off-by: Erkka Kääriä <erkka.kaaria@intel.com>
8
9Upstream-Status: Pending
10---
11 hotspot/make/linux/makefiles/jsig.make | 2 +-
12 hotspot/make/linux/makefiles/saproc.make | 2 +-
13 hotspot/make/linux/makefiles/vm.make | 2 +-
14 3 files changed, 3 insertions(+), 3 deletions(-)
15
16diff --git hotspot/make/linux/makefiles/jsig.make hotspot/make/linux/makefiles/jsig.make
17index ce29eb1..e1d6c07 100644
18--- hotspot/make/linux/makefiles/jsig.amake
19+++ hotspot/make/linux/makefiles/jsig.make
20@@ -44,7 +44,7 @@ LIBJSIG_MAPFILE = $(MAKEFILES_DIR)/mapfile-vers-jsig
21 # cause problems with interposing. See CR: 6466665
22 # LFLAGS_JSIG += $(MAPFLAG:FILENAME=$(LIBJSIG_MAPFILE))
23
24-LFLAGS_JSIG += -D_GNU_SOURCE -D_REENTRANT $(LDFLAGS_HASH_STYLE)
25+LFLAGS_JSIG += -D_GNU_SOURCE -D_REENTRANT $(LDFLAGS_HASH_STYLE) $(EXTRA_LDFLAGS)
26
27 # DEBUG_BINARIES overrides everything, use full -g debug information
28 ifeq ($(DEBUG_BINARIES), true)
29diff --git hotspot/make/linux/makefiles/saproc.make hotspot/make/linux/makefiles/saproc.make
30index 7c6e4a8..369a0ba 100644
31--- hotspot/make/linux/makefiles/saproc.make
32+++ hotspot/make/linux/makefiles/saproc.make
33@@ -73,7 +73,7 @@ ALT_SAINCDIR=-I$(ALT_SASRCDIR) -DALT_SASRCDIR
34 else
35 ALT_SAINCDIR=
36 endif
37-SA_LFLAGS = $(MAPFLAG:FILENAME=$(SAMAPFILE)) $(LDFLAGS_HASH_STYLE)
38+SA_LFLAGS = $(MAPFLAG:FILENAME=$(SAMAPFILE)) $(LDFLAGS_HASH_STYLE) $(EXTRA_LDFLAGS)
39
40 SAARCH ?= $(BUILDARCH)
41
42diff --git hotspot/make/linux/makefiles/vm.make hotspot/make/linux/makefiles/vm.make
43index 1a48df9..72f8d11 100644
44--- hotspot/make/linux/makefiles/vm.make
45+++ hotspot/make/linux/makefiles/vm.make
46@@ -122,7 +122,7 @@ CFLAGS += $(CFLAGS/NOEX)
47
48 # Extra flags from gnumake's invocation or environment
49 CFLAGS += $(EXTRA_CFLAGS)
50-LFLAGS += $(EXTRA_CFLAGS)
51+LFLAGS += $(EXTRA_CFLAGS) $(EXTRA_LDFLAGS)
52
53 # Don't set excutable bit on stack segment
54 # the same could be done by separate execstack command
55--
562.7.4
57