diff options
author | Richard Leitner <richard.leitner@skidata.com> | 2022-02-28 14:07:45 +0100 |
---|---|---|
committer | Richard Leitner <richard.leitner@skidata.com> | 2022-02-28 14:07:45 +0100 |
commit | 1a8059f6b257ebe6fcae6416e499784d976afd24 (patch) | |
tree | d57230187becbe76f024776b947c768a67608e48 | |
parent | dd2c6dd17b8ee1c755750f4f23249071ed9375a3 (diff) | |
download | meta-java-1a8059f6b257ebe6fcae6416e499784d976afd24.tar.gz |
jaxme: drop broken package
This package is broken for ages now, so drop it. If somebody needs it in
a current release please send a patch adding a function version of it.
Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r-- | recipes-core/xml-commons/jaxme_0.5.2.bb | 77 |
1 files changed, 0 insertions, 77 deletions
diff --git a/recipes-core/xml-commons/jaxme_0.5.2.bb b/recipes-core/xml-commons/jaxme_0.5.2.bb deleted file mode 100644 index 8411255..0000000 --- a/recipes-core/xml-commons/jaxme_0.5.2.bb +++ /dev/null | |||
@@ -1,77 +0,0 @@ | |||
1 | SUMMARY = "Implementation of the JAXB API" | ||
2 | LICENSE = "Apache-2.0" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" | ||
4 | AUTHOR = "Apache Software Foundation" | ||
5 | HOMEPAGE = "http://ws.apache.org/jaxme" | ||
6 | |||
7 | SRC_URI = "\ | ||
8 | http://apache.org/dist/ws/jaxme/source/ws-${P}-src.tar.gz;name=archive \ | ||
9 | http://ftp.hosting-studio.de/pub/linux/apache/ant/source/apache-ant-1.7.1-src.tar.bz2;name=ant \ | ||
10 | " | ||
11 | |||
12 | # do_compile: | ||
13 | # 2. ERROR in src/jaxme/org/apache/ws/jaxme/generator/XJCTask.java (at line 30) | ||
14 | # import org.apache.ws.jaxme.generator.sg.SGFactoryChain; | ||
15 | # ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ | ||
16 | # The import org.apache.ws.jaxme.generator.sg.SGFactoryChain cannot be resolved | ||
17 | # ---------- | ||
18 | # 3. ERROR in src/jaxme/org/apache/ws/jaxme/generator/XJCTask.java (at line 1055) | ||
19 | # if (!SGFactoryChain.class.isAssignableFrom(c)) { | ||
20 | # ^^^^^^^^^^^^^^ | ||
21 | # SGFactoryChain cannot be resolved to a type | ||
22 | # ---------- | ||
23 | # ... and many more | ||
24 | SKIP_RECIPE[jaxme] ?= "BROKEN: do_compile fails" | ||
25 | |||
26 | S = "${WORKDIR}/ws-${P}" | ||
27 | |||
28 | inherit java-library | ||
29 | |||
30 | DEPENDS = "fastjar-native log4j1.2 xerces-j xalan-j commons-codec hsqldb antlr antlr-native" | ||
31 | |||
32 | do_compile() { | ||
33 | oe_makeclasspath cp -s log4j-1.2 xercesImpl xalan2 commons-codec hsqldb antlr | ||
34 | cp=build-api:build-jaxme:build-js:build-xs:build-pm:$cp | ||
35 | |||
36 | jaxme_build src/api build-api $cp jaxmeapi-${PV}.jar | ||
37 | |||
38 | runantlr -o src/js/org/apache/ws/jaxme/js/jparser src/js/org/apache/ws/jaxme/js/jparser/java15.g | ||
39 | jaxme_build src/js build-js $cp jaxmejs-${PV}.jar | ||
40 | |||
41 | jaxme_build src/xs build-xs $cp jaxmexs-${PV}.jar | ||
42 | |||
43 | jaxme_build src/jaxme build-jaxme $cp ${JARFILENAME} | ||
44 | |||
45 | # jaxme_build src/pm build-pm $cp jaxmepm-${PV}.jar | ||
46 | } | ||
47 | |||
48 | do_install:append() { | ||
49 | oe_jarinstall jaxmeapi-${PV}.jar jaxmeapi.jar | ||
50 | oe_jarinstall jaxmejs-${PV}.jar jaxmejs.jar | ||
51 | oe_jarinstall jaxmexs-${PV}.jar jaxmexs.jar | ||
52 | oe_jarinstall jaxmepm-${PV}.jar jaxmepm.jar | ||
53 | } | ||
54 | |||
55 | # Compile helper | ||
56 | # 1 - source dir | ||
57 | # 2 - dest dir | ||
58 | # 3 - classpath | ||
59 | # 4 - jar file name | ||
60 | jaxme_build() { | ||
61 | mkdir -p $2 | ||
62 | |||
63 | ant_sourcepath=${WORKDIR}/apache-ant-1.7.1/src/main | ||
64 | |||
65 | echo "javac -sourcepath $ant_sourcepath:$1 -cp $3 -d $2 \`find $1 -name "*.java"\`" | ||
66 | javac -sourcepath $ant_sourcepath:$1 -cp $3 -d $2 `find $1 -name "*.java" -and -not \( -wholename "*junit*" -or -wholename "*examples*" \) ` | ||
67 | (cd $1 && find . -name "*.properties" -exec cp {} ${S}/$2/{} \;) | ||
68 | |||
69 | rm -rf $2/org/apache/tools | ||
70 | |||
71 | fastjar -C $2 -c -f $4 . | ||
72 | } | ||
73 | |||
74 | SRC_URI[archive.md5sum] = "084ebfe4a816058f8ff6bd731fa70df4" | ||
75 | SRC_URI[archive.sha256sum] = "0415d721259acf95c564fb84606bb17f6227c1cc444e89b78d1cd9903c1c88dc" | ||
76 | SRC_URI[ant.md5sum] = "0d68db4a1ada5c91bcbf53cefd0c2fd7" | ||
77 | SRC_URI[ant.sha256sum] = "4dc49a7260ef90a6dc6611b7e96b9f047d507589736d4a2ad6efbe3edfc6fba6" | ||