summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarek Belisko <marek.belisko@open-nandra.com>2019-03-07 12:57:51 +0100
committerRichard Leitner <richard.leitner@skidata.com>2019-12-27 12:11:17 +0100
commitfd72459b6e1ac9f0bb11422761524396aeae249c (patch)
tree39fc84de4e84abd99cc78fb0245648eaafc9c3f7
parent481f8bc2bd1662d6bc52e5c8af79c37b7d266b53 (diff)
downloadmeta-java-fd72459b6e1ac9f0bb11422761524396aeae249c.tar.gz
jamvm: Disable inlining
This will fix crashes seen when build openjdk-8: ERROR: jaxp1.3-native-1.4.01-r0 do_compile: Function failed: do_compile (log file is located at /home/jenkins/my_build/tmp/work/x86_64-linux/jaxp1.3-native/1.4.01-r0/temp/log.do_compile.28894) ERROR: Logfile of failure stored in: /home/jenkins/my_build/tmp/work/x86_64-linux/jaxp1.3-native/1.4.01-r0/temp/log.do_compile.28894 Log data follows: | DEBUG: Executing shell function do_compile | Illegal instruction (core dumped) | WARNING: exit code 132 from a shell command. | ERROR: Function failed: do_compile (log file is located at /home/jenkins/my_build/tmp/work/x86_64-linux/jaxp1.3-native/1.4.01-r0/temp/log.do_compile.28894) ERROR: Task (virtual:native:/home/jenkins/meta-java/recipes-core/xml-commons/jaxp1.3_1.4.01.bb:do_compile) failed with exit code '1' Signed-off-by: Marek Belisko <marek.belisko@open-nandra.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/jamvm/jamvm.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-core/jamvm/jamvm.inc b/recipes-core/jamvm/jamvm.inc
index 387d799..b03a5b9 100644
--- a/recipes-core/jamvm/jamvm.inc
+++ b/recipes-core/jamvm/jamvm.inc
@@ -29,7 +29,7 @@ do_configure_append_class-native() {
29} 29}
30 30
31 31
32EXTRA_OECONF = "--with-classpath-install-dir=${prefix} --libdir=${libdir}/jamvm --enable-ffi" 32EXTRA_OECONF = "--with-classpath-install-dir=${prefix} --libdir=${libdir}/jamvm --enable-ffi --disable-int-inlining"
33 33
34# Needed for big compilation targets like OpenJDK 34# Needed for big compilation targets like OpenJDK
35CFLAGS_append_class-native = " -DDEFAULT_MAX_HEAP=1024*MB" 35CFLAGS_append_class-native = " -DDEFAULT_MAX_HEAP=1024*MB"