summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUlrich Ölmann <u.oelmann@pengutronix.de>2022-11-24 17:32:54 +0100
committerRichard Leitner <richard.leitner@skidata.com>2022-11-24 17:50:21 +0100
commit3161106f0879a6be0a016df3a8bb8fa800bd6044 (patch)
tree1feda908f5558dbed3a743efb1532c1754aa5b70
parent6b2a48c3a7b1236a9d915135f685ef7eef5dcd02 (diff)
downloadmeta-java-3161106f0879a6be0a016df3a8bb8fa800bd6044.tar.gz
openjdk-8: refresh patches
Signed-off-by: Ulrich Ölmann <u.oelmann@pengutronix.de> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/0013-autoconf-remove-Werror.patch22
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/1007-hotspot-Turn-on-the-Wreturn-type-warning.patch20
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch12
-rw-r--r--recipes-core/openjdk/patches-openjdk-8/1012-hotspot-enable-Wno-error.patch4
4 files changed, 29 insertions, 29 deletions
diff --git a/recipes-core/openjdk/patches-openjdk-8/0013-autoconf-remove-Werror.patch b/recipes-core/openjdk/patches-openjdk-8/0013-autoconf-remove-Werror.patch
index d3bd8e7..91fedb5 100644
--- a/recipes-core/openjdk/patches-openjdk-8/0013-autoconf-remove-Werror.patch
+++ b/recipes-core/openjdk/patches-openjdk-8/0013-autoconf-remove-Werror.patch
@@ -63,10 +63,10 @@ index 077efa2..b98575a 100644
63 CFLAGS_JDK="${CFLAGS_JDK} ${NO_DELETE_NULL_POINTER_CHECKS_CFLAG} ${NO_LIFETIME_DSE_CFLAG}" 63 CFLAGS_JDK="${CFLAGS_JDK} ${NO_DELETE_NULL_POINTER_CHECKS_CFLAG} ${NO_LIFETIME_DSE_CFLAG}"
64 AC_SUBST([NO_LIFETIME_DSE_CFLAG]) 64 AC_SUBST([NO_LIFETIME_DSE_CFLAG])
65diff --git a/common/autoconf/generated-configure.sh b/common/autoconf/generated-configure.sh 65diff --git a/common/autoconf/generated-configure.sh b/common/autoconf/generated-configure.sh
66index d57035b..1953dc4 100644 66index f285a74..31d41b1 100644
67--- a/common/autoconf/generated-configure.sh 67--- a/common/autoconf/generated-configure.sh
68+++ b/common/autoconf/generated-configure.sh 68+++ b/common/autoconf/generated-configure.sh
69@@ -41498,12 +41498,12 @@ $as_echo "$ac_cv_c_bigendian" >&6; } 69@@ -41503,12 +41503,12 @@ $as_echo "$ac_cv_c_bigendian" >&6; }
70 fi 70 fi
71 CXXSTD_CXXFLAG="-std=gnu++98" 71 CXXSTD_CXXFLAG="-std=gnu++98"
72 72
@@ -82,7 +82,7 @@ index d57035b..1953dc4 100644
82 ac_ext=cpp 82 ac_ext=cpp
83 ac_cpp='$CXXCPP $CPPFLAGS' 83 ac_cpp='$CXXCPP $CPPFLAGS'
84 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5' 84 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
85@@ -41654,12 +41654,12 @@ fi 85@@ -41659,12 +41659,12 @@ fi
86 NO_DELETE_NULL_POINTER_CHECKS_CFLAG="-fno-delete-null-pointer-checks" 86 NO_DELETE_NULL_POINTER_CHECKS_CFLAG="-fno-delete-null-pointer-checks"
87 87
88 88
@@ -98,7 +98,7 @@ index d57035b..1953dc4 100644
98 ac_ext=c 98 ac_ext=c
99 ac_cpp='$CPP $CPPFLAGS' 99 ac_cpp='$CPP $CPPFLAGS'
100 ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5' 100 ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
101@@ -41694,12 +41694,12 @@ $as_echo "$supports" >&6; } 101@@ -41699,12 +41699,12 @@ $as_echo "$supports" >&6; }
102 fi 102 fi
103 103
104 104
@@ -114,7 +114,7 @@ index d57035b..1953dc4 100644
114 ac_ext=cpp 114 ac_ext=cpp
115 ac_cpp='$CXXCPP $CPPFLAGS' 115 ac_cpp='$CXXCPP $CPPFLAGS'
116 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5' 116 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
117@@ -41733,8 +41733,8 @@ $as_echo "$supports" >&6; } 117@@ -41738,8 +41738,8 @@ $as_echo "$supports" >&6; }
118 fi 118 fi
119 119
120 120
@@ -125,7 +125,7 @@ index d57035b..1953dc4 100644
125 supports=no 125 supports=no
126 if test "x$C_COMP_SUPPORTS" = "xyes" -a "x$CXX_COMP_SUPPORTS" = "xyes"; then supports=yes; fi 126 if test "x$C_COMP_SUPPORTS" = "xyes" -a "x$CXX_COMP_SUPPORTS" = "xyes"; then supports=yes; fi
127 127
128@@ -41750,12 +41750,12 @@ $as_echo "$supports" >&6; } 128@@ -41755,12 +41755,12 @@ $as_echo "$supports" >&6; }
129 NO_LIFETIME_DSE_CFLAG="-fno-lifetime-dse" 129 NO_LIFETIME_DSE_CFLAG="-fno-lifetime-dse"
130 130
131 131
@@ -141,7 +141,7 @@ index d57035b..1953dc4 100644
141 ac_ext=c 141 ac_ext=c
142 ac_cpp='$CPP $CPPFLAGS' 142 ac_cpp='$CPP $CPPFLAGS'
143 ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5' 143 ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
144@@ -41789,12 +41789,12 @@ $as_echo "$supports" >&6; } 144@@ -41794,12 +41794,12 @@ $as_echo "$supports" >&6; }
145 fi 145 fi
146 146
147 147
@@ -157,7 +157,7 @@ index d57035b..1953dc4 100644
157 ac_ext=cpp 157 ac_ext=cpp
158 ac_cpp='$CXXCPP $CPPFLAGS' 158 ac_cpp='$CXXCPP $CPPFLAGS'
159 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5' 159 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
160@@ -41828,8 +41828,8 @@ $as_echo "$supports" >&6; } 160@@ -41833,8 +41833,8 @@ $as_echo "$supports" >&6; }
161 fi 161 fi
162 162
163 163
@@ -168,7 +168,7 @@ index d57035b..1953dc4 100644
168 supports=no 168 supports=no
169 if test "x$C_COMP_SUPPORTS" = "xyes" -a "x$CXX_COMP_SUPPORTS" = "xyes"; then supports=yes; fi 169 if test "x$C_COMP_SUPPORTS" = "xyes" -a "x$CXX_COMP_SUPPORTS" = "xyes"; then supports=yes; fi
170 170
171@@ -41862,12 +41862,12 @@ $as_echo "$supports" >&6; } 171@@ -41867,12 +41867,12 @@ $as_echo "$supports" >&6; }
172 # -mno-fused-madd -fno-strict-aliasing for GCC < 4.6 172 # -mno-fused-madd -fno-strict-aliasing for GCC < 4.6
173 COMPILER_FP_CONTRACT_OFF_FLAG="-ffp-contract=off" 173 COMPILER_FP_CONTRACT_OFF_FLAG="-ffp-contract=off"
174 174
@@ -184,7 +184,7 @@ index d57035b..1953dc4 100644
184 ac_ext=cpp 184 ac_ext=cpp
185 ac_cpp='$CXXCPP $CPPFLAGS' 185 ac_cpp='$CXXCPP $CPPFLAGS'
186 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5' 186 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
187@@ -41906,12 +41906,12 @@ $as_echo "$supports" >&6; } 187@@ -41911,12 +41911,12 @@ $as_echo "$supports" >&6; }
188 test "$OPENJDK_TARGET_CPU_ARCH" = "ppc"; then 188 test "$OPENJDK_TARGET_CPU_ARCH" = "ppc"; then
189 M_NO_FUSED_ADD_FLAG="-mno-fused-madd" 189 M_NO_FUSED_ADD_FLAG="-mno-fused-madd"
190 190
@@ -200,7 +200,7 @@ index d57035b..1953dc4 100644
200 ac_ext=cpp 200 ac_ext=cpp
201 ac_cpp='$CXXCPP $CPPFLAGS' 201 ac_cpp='$CXXCPP $CPPFLAGS'
202 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5' 202 ac_compile='$CXX -c $CXXFLAGS $CPPFLAGS conftest.$ac_ext >&5'
203@@ -41946,12 +41946,12 @@ $as_echo "$supports" >&6; } 203@@ -41951,12 +41951,12 @@ $as_echo "$supports" >&6; }
204 204
205 NO_STRICT_ALIASING_FLAG="-fno-strict-aliasing" 205 NO_STRICT_ALIASING_FLAG="-fno-strict-aliasing"
206 206
diff --git a/recipes-core/openjdk/patches-openjdk-8/1007-hotspot-Turn-on-the-Wreturn-type-warning.patch b/recipes-core/openjdk/patches-openjdk-8/1007-hotspot-Turn-on-the-Wreturn-type-warning.patch
index b5173a9..0dc09b6 100644
--- a/recipes-core/openjdk/patches-openjdk-8/1007-hotspot-Turn-on-the-Wreturn-type-warning.patch
+++ b/recipes-core/openjdk/patches-openjdk-8/1007-hotspot-Turn-on-the-Wreturn-type-warning.patch
@@ -36,10 +36,10 @@ Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
36 13 files changed, 17 insertions(+), 15 deletions(-) 36 13 files changed, 17 insertions(+), 15 deletions(-)
37 37
38diff --git a/hotspot/make/linux/makefiles/gcc.make b/hotspot/make/linux/makefiles/gcc.make 38diff --git a/hotspot/make/linux/makefiles/gcc.make b/hotspot/make/linux/makefiles/gcc.make
39index 36b3c8ba9..cd9511e50 100644 39index ac44b6837..7a5162a06 100644
40--- a/hotspot/make/linux/makefiles/gcc.make 40--- a/hotspot/make/linux/makefiles/gcc.make
41+++ b/hotspot/make/linux/makefiles/gcc.make 41+++ b/hotspot/make/linux/makefiles/gcc.make
42@@ -211,7 +211,7 @@ ifeq ($(USE_CLANG), true) 42@@ -212,7 +212,7 @@ ifeq ($(USE_CLANG), true)
43 WARNINGS_ARE_ERRORS += -Wno-return-type -Wno-empty-body 43 WARNINGS_ARE_ERRORS += -Wno-return-type -Wno-empty-body
44 endif 44 endif
45 45
@@ -95,7 +95,7 @@ index 4b4b4e250..196622aed 100644
95 95
96 96
97diff --git a/hotspot/src/share/vm/classfile/symbolTable.cpp b/hotspot/src/share/vm/classfile/symbolTable.cpp 97diff --git a/hotspot/src/share/vm/classfile/symbolTable.cpp b/hotspot/src/share/vm/classfile/symbolTable.cpp
98index 83369cbcf..8dd4e6b21 100644 98index ec97077b7..2621a7d62 100644
99--- a/hotspot/src/share/vm/classfile/symbolTable.cpp 99--- a/hotspot/src/share/vm/classfile/symbolTable.cpp
100+++ b/hotspot/src/share/vm/classfile/symbolTable.cpp 100+++ b/hotspot/src/share/vm/classfile/symbolTable.cpp
101@@ -249,7 +249,7 @@ Symbol* SymbolTable::lookup(const char* name, int len, TRAPS) { 101@@ -249,7 +249,7 @@ Symbol* SymbolTable::lookup(const char* name, int len, TRAPS) {
@@ -117,7 +117,7 @@ index 83369cbcf..8dd4e6b21 100644
117 117
118 Symbol* SymbolTable::lookup_only(const char* name, int len, 118 Symbol* SymbolTable::lookup_only(const char* name, int len,
119diff --git a/hotspot/src/share/vm/classfile/systemDictionary.cpp b/hotspot/src/share/vm/classfile/systemDictionary.cpp 119diff --git a/hotspot/src/share/vm/classfile/systemDictionary.cpp b/hotspot/src/share/vm/classfile/systemDictionary.cpp
120index 4541e815a..98412e1e1 100644 120index 5911d94f5..df4d56f6f 100644
121--- a/hotspot/src/share/vm/classfile/systemDictionary.cpp 121--- a/hotspot/src/share/vm/classfile/systemDictionary.cpp
122+++ b/hotspot/src/share/vm/classfile/systemDictionary.cpp 122+++ b/hotspot/src/share/vm/classfile/systemDictionary.cpp
123@@ -236,15 +236,15 @@ Klass* SystemDictionary::resolve_or_null(Symbol* class_name, Handle class_loader 123@@ -236,15 +236,15 @@ Klass* SystemDictionary::resolve_or_null(Symbol* class_name, Handle class_loader
@@ -166,10 +166,10 @@ index 2f3abae6a..d58ebecb2 100644
166 static ReservedSpace* shared_rs() { 166 static ReservedSpace* shared_rs() {
167 CDS_ONLY(return _shared_rs); 167 CDS_ONLY(return _shared_rs);
168diff --git a/hotspot/src/share/vm/oops/constantPool.hpp b/hotspot/src/share/vm/oops/constantPool.hpp 168diff --git a/hotspot/src/share/vm/oops/constantPool.hpp b/hotspot/src/share/vm/oops/constantPool.hpp
169index 68435471d..fad4a92cb 100644 169index 124c970e2..dae574c09 100644
170--- a/hotspot/src/share/vm/oops/constantPool.hpp 170--- a/hotspot/src/share/vm/oops/constantPool.hpp
171+++ b/hotspot/src/share/vm/oops/constantPool.hpp 171+++ b/hotspot/src/share/vm/oops/constantPool.hpp
172@@ -350,7 +350,7 @@ class ConstantPool : public Metadata { 172@@ -353,7 +353,7 @@ class ConstantPool : public Metadata {
173 173
174 Klass* klass_at(int which, TRAPS) { 174 Klass* klass_at(int which, TRAPS) {
175 constantPoolHandle h_this(THREAD, this); 175 constantPoolHandle h_this(THREAD, this);
@@ -177,7 +177,7 @@ index 68435471d..fad4a92cb 100644
177+ return klass_at_impl(h_this, which, THREAD); 177+ return klass_at_impl(h_this, which, THREAD);
178 } 178 }
179 179
180 Symbol* klass_name_at(int which) const; // Returns the name, w/o resolving. 180 Symbol* klass_name_at(int which); // Returns the name, w/o resolving.
181diff --git a/hotspot/src/share/vm/prims/jvm.cpp b/hotspot/src/share/vm/prims/jvm.cpp 181diff --git a/hotspot/src/share/vm/prims/jvm.cpp b/hotspot/src/share/vm/prims/jvm.cpp
182index 6f2221c41..daa69f89a 100644 182index 6f2221c41..daa69f89a 100644
183--- a/hotspot/src/share/vm/prims/jvm.cpp 183--- a/hotspot/src/share/vm/prims/jvm.cpp
@@ -192,7 +192,7 @@ index 6f2221c41..daa69f89a 100644
192 192
193 JVM_ENTRY(jboolean,JVM_DTraceIsProbeEnabled(JNIEnv* env, jmethodID method)) 193 JVM_ENTRY(jboolean,JVM_DTraceIsProbeEnabled(JNIEnv* env, jmethodID method))
194diff --git a/hotspot/src/share/vm/runtime/reflection.cpp b/hotspot/src/share/vm/runtime/reflection.cpp 194diff --git a/hotspot/src/share/vm/runtime/reflection.cpp b/hotspot/src/share/vm/runtime/reflection.cpp
195index 4b39d8ccb..9cd7b0dcb 100644 195index d9fddbe47..a5f737935 100644
196--- a/hotspot/src/share/vm/runtime/reflection.cpp 196--- a/hotspot/src/share/vm/runtime/reflection.cpp
197+++ b/hotspot/src/share/vm/runtime/reflection.cpp 197+++ b/hotspot/src/share/vm/runtime/reflection.cpp
198@@ -1093,7 +1093,7 @@ oop Reflection::invoke(instanceKlassHandle klass, methodHandle reflected_method, 198@@ -1093,7 +1093,7 @@ oop Reflection::invoke(instanceKlassHandle klass, methodHandle reflected_method,
@@ -205,10 +205,10 @@ index 4b39d8ccb..9cd7b0dcb 100644
205 } 205 }
206 206
207diff --git a/hotspot/src/share/vm/runtime/sharedRuntime.cpp b/hotspot/src/share/vm/runtime/sharedRuntime.cpp 207diff --git a/hotspot/src/share/vm/runtime/sharedRuntime.cpp b/hotspot/src/share/vm/runtime/sharedRuntime.cpp
208index d5bea29c3..50578ad63 100644 208index 013aa7a23..df4cde963 100644
209--- a/hotspot/src/share/vm/runtime/sharedRuntime.cpp 209--- a/hotspot/src/share/vm/runtime/sharedRuntime.cpp
210+++ b/hotspot/src/share/vm/runtime/sharedRuntime.cpp 210+++ b/hotspot/src/share/vm/runtime/sharedRuntime.cpp
211@@ -1041,7 +1041,7 @@ Handle SharedRuntime::find_callee_info(JavaThread* thread, Bytecodes::Code& bc, 211@@ -1045,7 +1045,7 @@ Handle SharedRuntime::find_callee_info(JavaThread* thread, Bytecodes::Code& bc,
212 // last java frame on stack (which includes native call frames) 212 // last java frame on stack (which includes native call frames)
213 vframeStream vfst(thread, true); // Do not skip and javaCalls 213 vframeStream vfst(thread, true); // Do not skip and javaCalls
214 214
diff --git a/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch b/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
index 8e70cab..711d17b 100644
--- a/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
+++ b/recipes-core/openjdk/patches-openjdk-8/1010-hotspot-fix-shark-build-common.patch
@@ -22,10 +22,10 @@ Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
22 14 files changed, 123 insertions(+), 12 deletions(-) 22 14 files changed, 123 insertions(+), 12 deletions(-)
23 23
24diff --git a/hotspot/make/Makefile b/hotspot/make/Makefile 24diff --git a/hotspot/make/Makefile b/hotspot/make/Makefile
25index ad195763b..53b5ea046 100644 25index de2607c71..3054c3fe8 100644
26--- a/hotspot/make/Makefile 26--- a/hotspot/make/Makefile
27+++ b/hotspot/make/Makefile 27+++ b/hotspot/make/Makefile
28@@ -525,7 +525,7 @@ $(EXPORT_INCLUDE_DIR)/%: $(SHARK_BUILD_DIR)/../generated/jvmtifiles/% 28@@ -536,7 +536,7 @@ $(EXPORT_INCLUDE_DIR)/%: $(SHARK_BUILD_DIR)/../generated/jvmtifiles/%
29 # Unix 29 # Unix
30 $(EXPORT_JRE_LIB_ARCH_DIR)/%.$(LIBRARY_SUFFIX): $(SHARK_BUILD_DIR)/%.$(LIBRARY_SUFFIX) 30 $(EXPORT_JRE_LIB_ARCH_DIR)/%.$(LIBRARY_SUFFIX): $(SHARK_BUILD_DIR)/%.$(LIBRARY_SUFFIX)
31 $(install-file) 31 $(install-file)
@@ -79,10 +79,10 @@ index 4707cc96e..a2b297ca0 100644
79 flow_block(blk, temp_vector, temp_set); 79 flow_block(blk, temp_vector, temp_set);
80 if (failing()) return; // Watch for bailouts. 80 if (failing()) return; // Watch for bailouts.
81diff --git a/hotspot/src/share/vm/classfile/systemDictionary.cpp b/hotspot/src/share/vm/classfile/systemDictionary.cpp 81diff --git a/hotspot/src/share/vm/classfile/systemDictionary.cpp b/hotspot/src/share/vm/classfile/systemDictionary.cpp
82index 98412e1e1..f62731c43 100644 82index df4d56f6f..b1dd335cb 100644
83--- a/hotspot/src/share/vm/classfile/systemDictionary.cpp 83--- a/hotspot/src/share/vm/classfile/systemDictionary.cpp
84+++ b/hotspot/src/share/vm/classfile/systemDictionary.cpp 84+++ b/hotspot/src/share/vm/classfile/systemDictionary.cpp
85@@ -2392,6 +2392,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid 85@@ -2371,6 +2371,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
86 spe = NULL; 86 spe = NULL;
87 // Must create lots of stuff here, but outside of the SystemDictionary lock. 87 // Must create lots of stuff here, but outside of the SystemDictionary lock.
88 m = Method::make_method_handle_intrinsic(iid, signature, CHECK_(empty)); 88 m = Method::make_method_handle_intrinsic(iid, signature, CHECK_(empty));
@@ -90,7 +90,7 @@ index 98412e1e1..f62731c43 100644
90 if (!Arguments::is_interpreter_only()) { 90 if (!Arguments::is_interpreter_only()) {
91 // Generate a compiled form of the MH intrinsic. 91 // Generate a compiled form of the MH intrinsic.
92 AdapterHandlerLibrary::create_native_wrapper(m); 92 AdapterHandlerLibrary::create_native_wrapper(m);
93@@ -2401,6 +2402,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid 93@@ -2380,6 +2381,7 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
94 "out of space in CodeCache for method handle intrinsic", empty); 94 "out of space in CodeCache for method handle intrinsic", empty);
95 } 95 }
96 } 96 }
@@ -98,7 +98,7 @@ index 98412e1e1..f62731c43 100644
98 // Now grab the lock. We might have to throw away the new method, 98 // Now grab the lock. We might have to throw away the new method,
99 // if a racing thread has managed to install one at the same time. 99 // if a racing thread has managed to install one at the same time.
100 { 100 {
101@@ -2414,9 +2416,11 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid 101@@ -2393,9 +2395,11 @@ methodHandle SystemDictionary::find_method_handle_intrinsic(vmIntrinsics::ID iid
102 } 102 }
103 103
104 assert(spe != NULL && spe->method() != NULL, ""); 104 assert(spe != NULL && spe->method() != NULL, "");
diff --git a/recipes-core/openjdk/patches-openjdk-8/1012-hotspot-enable-Wno-error.patch b/recipes-core/openjdk/patches-openjdk-8/1012-hotspot-enable-Wno-error.patch
index 2239d48..aeeba6b 100644
--- a/recipes-core/openjdk/patches-openjdk-8/1012-hotspot-enable-Wno-error.patch
+++ b/recipes-core/openjdk/patches-openjdk-8/1012-hotspot-enable-Wno-error.patch
@@ -14,10 +14,10 @@ Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
14 1 file changed, 2 insertions(+), 2 deletions(-) 14 1 file changed, 2 insertions(+), 2 deletions(-)
15 15
16diff --git a/hotspot/make/linux/makefiles/gcc.make b/hotspot/make/linux/makefiles/gcc.make 16diff --git a/hotspot/make/linux/makefiles/gcc.make b/hotspot/make/linux/makefiles/gcc.make
17index cd9511e50..94412c8fe 100644 17index 7a5162a06..67607fb26 100644
18--- a/hotspot/make/linux/makefiles/gcc.make 18--- a/hotspot/make/linux/makefiles/gcc.make
19+++ b/hotspot/make/linux/makefiles/gcc.make 19+++ b/hotspot/make/linux/makefiles/gcc.make
20@@ -200,8 +200,8 @@ else 20@@ -201,8 +201,8 @@ else
21 CFLAGS += -pipe 21 CFLAGS += -pipe
22 endif 22 endif
23 23