summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Looijmans <mike.looijmans@topic.nl>2021-03-24 09:41:24 +0100
committerRichard Leitner <richard.leitner@skidata.com>2021-04-27 13:55:26 +0200
commit984f25b6deb5fe4acf82d51c04b2c1392a542723 (patch)
treea528b65d05d6b0b17aa98b0164069d7e8e716713
parent04377d10225360bd27d018007889176911bb7532 (diff)
downloadmeta-java-984f25b6deb5fe4acf82d51c04b2c1392a542723.tar.gz
openjdk-8: Workaround TOPDIR not getting expanded in configure.ac
Somehow the TOPDIR environment doesn't get expanded in configure.ac. Suspecting a clash with OE's internal TOPDIR variable, I tried replacing it with JDKTOPDIR but that resulted in the same error. | autoreconf: configure.ac: creating directory $TOPDIR/common/autoconf/build-aux | autoreconf: error: cannot create $TOPDIR/common/autoconf/build-aux: No such file or directory The workaround implemented here is to replace $TOPDIR in the file by its assigned value ${S}. This makes the error go away and the native build succeed. Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--recipes-core/openjdk/openjdk-8-common.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-core/openjdk/openjdk-8-common.inc b/recipes-core/openjdk/openjdk-8-common.inc
index 70585a6..7d45585 100644
--- a/recipes-core/openjdk/openjdk-8-common.inc
+++ b/recipes-core/openjdk/openjdk-8-common.inc
@@ -28,6 +28,7 @@ SRC_URI = "\
28 28
29do_configure_prepend () { 29do_configure_prepend () {
30 export TOPDIR=${S} 30 export TOPDIR=${S}
31 sed -i 's#\$TOPDIR#${S}#g' ${S}/common/autoconf/configure.ac
31} 32}
32 33
33do_unpack_extract_submodules () { 34do_unpack_extract_submodules () {