summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Brunet <jbrunet@baylibre.com>2021-10-22 17:12:12 +0200
committerRichard Leitner <richard.leitner@skidata.com>2021-11-17 17:22:21 +0100
commit327a097f5a81eba365a80ee3c52ec885629d42f3 (patch)
tree978377773bb4b2fa173333a1437cb547d2eb3278
parentb30873f02150c1f0bc3d5cc84742577649765de4 (diff)
downloadmeta-java-327a097f5a81eba365a80ee3c52ec885629d42f3.tar.gz
openjdk-build-helper: fix arm64 build
When trying to build for an arm64 machine, such as qemuarm64, parsing of the recipes fails with the following messages: WARNING: /meta-java/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb: Exception during build_dependencies for LLVM_CONFIGURE_ARCH WARNING: /meta-java/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb: Error during finalise of /meta-java/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb ERROR: ExpansionError during parsing /meta-java/recipes-core/openjdk/openjdk-7_99b00-2.6.5.bb Traceback (most recent call last): File "Var <LLVM_CONFIGURE_ARCH>", line 1, in <module> File "/meta-java/classes/openjdk-build-helper.bbclass", line 86, in openjdk_build_helper_get_llvm_configure_arch(d=<bb.data_smart.DataSmart object at 0x7f08fed017c0>): else: > if 'shark' in d.getVar('PACKAGECONFIG').split(): bb.warn("%s does not support %s in Shark builds yet" % (d.getVar('PN'), arch) ); bb.data_smart.ExpansionError: Failure expanding variable LLVM_CONFIGURE_ARCH, expression was ${@openjdk_build_helper_get_llvm_configure_arch(d)} which triggered exception AttributeError: 'NoneType' object has no attribute 'split' Using 'bb.utils.contains' solves the problem. Signed-off-by: Jerome Brunet <jbrunet@baylibre.com> Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
-rw-r--r--classes/openjdk-build-helper.bbclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/classes/openjdk-build-helper.bbclass b/classes/openjdk-build-helper.bbclass
index a4b77a0..9a6c492 100644
--- a/classes/openjdk-build-helper.bbclass
+++ b/classes/openjdk-build-helper.bbclass
@@ -83,7 +83,7 @@ def openjdk_build_helper_get_llvm_configure_arch(d):
83 elif arch == "arm": 83 elif arch == "arm":
84 arch = "arm" 84 arch = "arm"
85 else: 85 else:
86 if 'shark' in d.getVar('PACKAGECONFIG').split(): 86 if bb.utils.contains('PACKAGECONFIG', 'shark', True, False, d):
87 bb.warn("%s does not support %s in Shark builds yet" % (d.getVar('PN'), arch) ); 87 bb.warn("%s does not support %s in Shark builds yet" % (d.getVar('PN'), arch) );
88 88
89 return arch 89 return arch