summaryrefslogtreecommitdiffstats
path: root/meta-crownbay/conf
Commit message (Collapse)AuthorAgeFilesLines
* crownbay: Switch to linux-yocto-3.10Tom Zanussi2013-10-171-1/+1
| | | | | | | Now that 3.10 kernel support for crownbay has been added, switch crownbay to linux-yocto-3.10. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* crownbay.conf: include meta-intel-emgd.incNitin A Kamble2013-09-181-0/+1
| | | | | | | Which brings the separate package dir for opengl related recipes to improve the build performance while building multiple BSPs. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
* meta-crownbay: move crownbay-noemgd to linux-yocto-3.101.5_M5.rc41.5_M5.rc3Tom Zanussi2013-09-181-1/+1
| | | | | | | | | | Add linux-yocto_3.10 bbappends to meta-crownbay and switch crownbay-noemgd to use them. Leave crownbay at 3.8, since the EMGD kernel branch hasn't yet been made to work with 3.10. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* crownbay: update preferred version of mesa recipe to 9.1.6Nitin A Kamble2013-08-061-1/+1
| | | | | | | | The previous version is not available anymore, so use the newer version of the mesa recipe now. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
* mesa: update BSPs to current oe-core mesa versionTom Zanussi2013-07-241-1/+1
| | | | | | | The current version of mesa was updated in oe-core. Change mesa version for these BSPs in order to avoid build errors. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* crownbay: update to use emgd 1.18 user recipeNitin A Kamble2013-07-191-1/+1
| | | | | | | | | Updating the crownbay bsp to use version 1.18 of emgd userland recipe. Update emgd version in the README Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: update preferred version of mesa recipeNitin A Kamble2013-06-121-1/+1
| | | | | | | | The newer 1.9.3 version of the mesa recipe is working well with this BSP. Mark it as a preferred version for this BSP. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: specify preferred version of the xf86-input-synaptics recipeNitin A Kamble2013-05-161-0/+1
| | | | | | | | | | | | The newer version of the xf86-input-synaptics recipe breaks with the 1.9.3 version of xorg-xserver used in this BSP. More details on the breakage can be found in the log of the commit with title: xf86-input-synaptics_1.6.3: keep older version for EMGD based BSPs Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: specify a working libva versionNitin A Kamble2013-04-121-0/+1
| | | | | | | | | | With the newer (1.1.0 & 1.1.1) versions of libva recipe video playback is giving segmentation fault at the end of playback. And the 1.0.16 version of libva is working fine for the video playback. So specifying the specific working version of libva recipe for all the EMGD based BSPs here. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* Replace references to mesa-dri with mesa in all filesLaurentiu Palcu2013-03-221-1/+1
| | | | | | | [YOCTO #3385] Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com>
* crownbay crownbay-noemgd: move BSPs to the v3.8 kernelNitin A Kamble2013-03-062-2/+2
| | | | | | | | Now the v3.8 kernel recipes are available in the oecore & meta-intel layers. And also the v3.8 kernel is validated for these BSPs. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* mesa-dri: update preferred versionAlexandru DAMIAN2013-02-281-1/+1
| | | | | | | | | | | Since mesa-dri got updated in the meta oe-core, preferred versions point to revisions that don't exist. So we update the current stable version. Signed-off-by: Alexandru DAMIAN <alexandru.damian@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Acked by: Nitin A Kamble <nitin.a.kamble@intel.com>
* crownbay.conf: use the new method for specifying VA codecsNitin A Kamble2013-01-251-8/+4
| | | | | | | | | | | | | | | | | This replaces the old VA_FEATURES method to specify the codecs. These VA codecs are included in the image when image has 'hwcodec' in the IMAGE_FEATURES. And one can disable the VA features by redefining the IMAGE_FEATURES var in the local.conf . The gst-va-intel package pulls in emgd driver and x11 pieces, hence it is moved to the XSERVERCODECS var. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: use emgd 1.16 driver for graphicsNitin A Kamble2013-01-231-1/+1
| | | | | | | | | Move from 1.14 version to 1.16 version of the emgd driver for graphics support. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-1.14: prepare for coexisting with emgd-1.16 recipeNitin A Kamble2013-01-231-1/+2
| | | | | | | | | | | | | | | | | | | | We want to use emgd-1.14 & emgd-1.16 recipe interchangeably. As the some of the generated package names include versions which will be different in the emgd-1.16 recipe, this version part is stripped from the package names so that it will match with the emgd-1.16 recipe package names. All the BSP configuration which were using these package names also change accordingly to avoid any build issues. Also with the 2 versions of emgd recipes make sure that BSPs don't start using the emgd-1.16 version until they have been validated to work by specifying the preferred emgd recipe version for the relevant BSPs. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* layer.conf: Use .= for adding to BBPATH and += to BBFILESKhem Raj2013-01-071-2/+2
| | | | | | | | | | | | | | | | | | | | Fixes parsing errors which is appearing after this commit to meta-openembedded http://cgit.openembedded.org/meta-openembedded/commit/?id=3c21a46020bd0816579648f684c41dbd6333583e This triggers exception NameError: name 'base_contains' is not defined without this change Avoid the immediate expansion operator (:=) which caused base_contains added in the previous commit to fail to expand at the time the meta-intel layer configs are parsed and replace it with one of the append operators (.= or +=) that allows for delayed variable expansion. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
* crownbay.conf: add EMGD VA components to VA_FEATURES variableNitin A Kamble2012-12-211-1/+5
| | | | | | | | | | | | | | | | | | | | | | The following EMGD subpackages provide video acceleration and have dependencies on libva and libx11: emgd-driver-video emgd-gst-plugins-va-0.10.10 emgd-gst-plugins-mixvideo-0.10.34 Include these in the VA_FEATURES variable only when the EMGD XSERVER is included in the image. For images such as core-image-lsb which do not include X components, including any of these emgd subpackages will pull in unwanted X components. This fixes that problem. This fixes the following bug: [YOCTO #3507] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: add WEBTITLE & Compliance informationNitin A Kamble2012-10-252-0/+4
| | | | | | | | The WEBTITLE will be used to publish the BSP on the Yocto Project Website. And adding the Yocto Project Compliance information for the 1.3 release. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: fix VA_FEATURES assignment in machine configsTom Zanussi2012-10-251-1/+1
| | | | | | | | | commit 2231d38 (meta-intel: make video acceleration choice dependent on LICENSE_FLAGS) inadvertently also changed '?=' to a hard assignment, making it hard to override as intended. This changes it back. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: don't require commercial licenses for gstreamer-vaapiRoss Burton2012-10-221-2/+1
| | | | | | | | Now that gstreamer-vaapi doesn't depend on ffmpeg, it can always be recommended by the machine configuration. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: specify the 8.0.4 version as preferred version of mesa-driNitin A Kamble2012-10-121-1/+1
| | | | | | | | | | | | | Avoid following warnings while building crownbay BSPs: NOTE: preferred version 7.11 of mesa-dri not available (for item virtual/libgl) NOTE: versions of mesa-dri available: 2:8.0.4 2:8.0.4+git1+c1f4867c89adb1a6b19d66ec8ad146115909f0a7 This commit addresses one of the issue reported on the bug: [YOCTO #3238] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay.conf: add kernel parameters for EMGD video accelerationNitin A Kamble2012-10-081-1/+1
| | | | | | | | | | | This is recommended in the EMGD User Guide. My understanding is that, the emgd kernel driver need to allocate memory dynamically, and the "vmalloc=256MB" parameter ensures enough will be available for the driver. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: make video acceleration choice dependent on LICENSE_FLAGSTom Zanussi2012-09-151-1/+2
| | | | | | | | | | | | The gst-ffmpeg recipe in oe-core had LICENSE_FLAGS added to make it "commercial", so to avoid build errors the BSPs that use it (via the gst-va-intel VA_FEATURE) should only include it if the user has added "commercial" to LICENSE_FLAGS_WHITELIST when building. This adds a conditional to detect that, along with a NOTE in the README to explain the need for the flag. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: use va-impl-intel MACHINE_FEATURETom Zanussi2012-08-301-1/+1
| | | | | | | Explicitly specify the va-impl-intel MACHINE_FEATURE, and update the mixvideo uses with the feature rename. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel.inc: have appropriate BSPs use itTom Zanussi2012-08-291-0/+1
| | | | | | | | ia32-base.inc no longer contains everything these BSPs need - some of what was in that file is now in meta-intel.inc, so we need to include that too. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: make v3.4 the default kernel1.3_M3.rc21.3_M3.final1.3_M3Nitin A Kamble2012-08-012-2/+2
| | | | | | Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Tested-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: use gst-va-intel and va-intel and gst-va-mixvideoTom Zanussi2012-05-301-1/+5
| | | | | | | | | | Have crownbay use gst-va-intel and va-intel so we can easily test and make use of the video acceleration capabilities of this machine. Also have it use the gst-va-mixvideo so the emgd mixvideo components get selected. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* common/meta-graphics: Add xf86-input-evdev 2.6.0Richard Purdie2012-04-251-0/+1
| | | | | | | This is needed by the pvr graphics stacks since newer versions won't build with the older xserver those platforms are using. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* meta-crownbay: switch to linux-yocto-3.2 kernelTom Zanussi2012-03-182-0/+4
| | | | | | Switch crownbay and crownbay-noemgd to the 3.2 kernel. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: add LAYERDEPENDS for layers needing the meta-intel common layer1.2_M3.rc11.2_M3Paul Eggleton2012-02-241-0/+2
| | | | | | | | | These layers all contain machine configuration that depends on having the meta-intel common layer enabled as well, so use LAYERDEPENDS in the layer configuration for each one to make this explicit. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: replace "include" with "require"Paul Eggleton2012-02-242-4/+4
| | | | | | | | | We want a failure to occur if the files specified in these statements can't be found (e.g. when there is a misconfiguration), so use require instead of include. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: remove PREFERRED_VERSION for emgd-driver-binTom Zanussi2012-01-301-1/+0
| | | | | | | | crownbay specifies a preferred version of 1.8 for emgd, but there's really no reason to do that at this point - it should be able to use the new 1.10 version. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: use gst-va-intelTom Zanussi2011-12-051-0/+2
| | | | | | | Have crownbay use gst-va-intel so we can easily test and make use of the video acceleration capabilities of this machine. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: remove common from BBFILESTom Zanussi2011-11-211-3/+1
| | | | | | | metadata in /common is now pulled in by the meta-intel layer, so remove it here. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* Have crownbay-noemgd.conf use the common ia32-base .inc file andTom Zanussi2011-11-211-37/+5
| | | | | | remove the open-coded machine settings. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* Have crownbay.conf use the common ia32-base .inc file and remove theTom Zanussi2011-11-211-36/+6
| | | | | | open-coded machine settings. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: remove virtual/xserver-xf86 referencesTom Zanussi2011-11-152-2/+0
| | | | | | | These are now deprecated (in favor of just virtual/xserver), so remove them. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay: set boot vga modeTom Zanussi2011-10-171-0/+2
| | | | | | | Set boot params to get a vesafb 1024x768 graphics mode and can see the splash screen. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* crownbay-noemgd: set boot vga modeTom Zanussi2011-10-171-0/+2
| | | | | | | Set boot params to get a vesafb 1024x768 graphics mode and can see the splash screen. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: xserver-xorg renaming updatesTom Zanussi2011-10-162-7/+21
| | | | | | | Update crownbay and crownbay-noemgd to reflect the new xserver-xorg naming. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: update BSPs to use grub2Tom Zanussi2011-09-152-0/+4
| | | | | | | | grub2 is now the default, so explicit preferred entries are unnecessary. It also needs to be installed in the rootfs, so we need to add it as a dependency. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: select emgd 1.8Tom Zanussi2011-08-251-1/+1
| | | | | | Change preferred version of emgd binaries to 1.8. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: switch to linux-yocto 3.0 kernelTom Zanussi2011-08-252-0/+4
| | | | | | | Switch crownbay and crownbay-noemgd to the 3.0 kernel, lock it down, and update kernel SRCREVs. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* allow override of kernel providerDarren Hart2011-08-112-2/+2
| | | | | | | Allow users or layers to override PREFERRED_PROVIDER_virtual/kernel. This is required to use the linux-yocto-rt kernel, for example. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
* meta-crownbay: add live fstypeTom Zanussi2011-08-032-2/+2
| | | | | | | Most of the time, we want a -live image, so add it to the IMAGE_FSTYPES by default. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: remove tune-related assignments from machine confTom Zanussi2011-08-032-4/+0
| | | | | | | These are all now handled or obsoleted by tune-atom.inc, so remove them here. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-crownbay: fix BBFILES in crownbay layer.confTom Zanussi2011-08-021-2/+2
| | | | | | | | | | The BBFILES append in crownbay's layer.conf is too broad and causes the wrong init-install.sh to be picked up, causing a bad grub install. Narrow down the BBFILES to include only what is actually needed. Fixes [YOCTO #1257]. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel/linux-yocto: update to match the renamed linux-yocto recipesBruce Ashfield2011-06-152-12/+0
| | | | | | | | | | | | | | | | | The linux-yocto recipes have been renamed to include explicit version numbers. The meta-intel bbappends must be updated to follow the new naming convention. As a consequence of the recipe renames any SRCREV specificiations that were part of a machine.conf have been moved to the corresponding bbappend file. This allows the 2.6.34 and 2.6.37 SRCREVs to co-exist. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Minor whitespace cleanup. Remove inadvertant? linux-libc-headers provider change. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
* meta-intel: update kernel SRCREVsTom Zanussi2011-06-062-4/+4
| | | | | | | Fixes for extra page compile error (commit bec3f1e8c075) now pulled in to these branches. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: update kernel SRCREVsTom Zanussi2011-06-052-4/+4
| | | | | | | To avoid extra page compile error until commit bec3f1e8c075 can be pulled in to these branches. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>