summaryrefslogtreecommitdiffstats
path: root/common
Commit message (Collapse)AuthorAgeFilesLines
* emgd-1.16: create a new recipeNitin A Kamble2013-03-203-0/+758
| | | | | | | | | | | | | | | | | | | | | Create a new recipe for the latest emgd 1.16 version of the graphics driver. Also add the custom license files of the recipe to avoid build time QA warnings. There are strange characters in the license files, because they are copied verbatim from the sources. Include RDEPENDS fix (commit bfa92b9) from Richard Purdie for danny backport: RDEPENDS should be set on specific packages, not applied to everything in general (e.g. -dev, -dbg or -doc packages). This fixes up warnings in the build. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-driver-bin: remove duplicate files & fix soft linksNitin A Kamble2013-03-201-1/+31
| | | | | | | | | | | | | | | | | Replace all the duplicate files by soft links, and also fix targets of some of the broken soft links. These changes avoid link issues like following, where detailed library versions included in the .so filenames cause linking issues. [...]/tmp/sysroots/x86_64-linux/usr/libexec/core2-poky-linux/gcc/i586-poky-linux/4.7.2/ld: warning: libEMGDegl.so, needed by [...]/tmp/sysroots/fri2/usr/lib/libGLESv2.so, not found (try using -rpath or -rpath-link) [...]/tmp/sysroots/x86_64-linux/usr/libexec/core2-poky-linux/gcc/i586-poky-linux/4.7.2/ld: warning: libemgdsrv_um.so, needed by [...]/tmp/sysroots/fri2/usr/lib/libGLESv2.so, not found (try using -rpath or -rpath-link) This fixes Bug: [YOCTO #4020] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* libva-intel-driver: workaround for concurrent VC1 and H264 playback issueTom Zanussi2013-02-122-0/+442
| | | | | | | | | | | Explanation from Terence Chiang: "encountered a GFX issue while enabling HW video playback VC-1 and H.264 simultaneously, the graphic driver report error with gfx hang on Sandy Bridge platform. We worked with Intel Linux graphic team and provided a patch" Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* mesa-dri_8.0.4.bbappend: Remove tabs from python codeKhem Raj2013-02-121-4/+4
| | | | | | | | | | | | | check for xserver to be non-empty before using it fixed errors like ERROR: Failed to parse recipe: /b/kraj/yocto/poky/meta/recipes-graphics/mesa/mesa-dri_8.0.4.bb ERROR: Error executing a python function in <code>: AttributeError: 'NoneType' object has no attribute 'split' Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* mesa-dri.bbappend: avoid conflict with emgd-driver-bin1.3.final1.3Nitin A Kamble2012-11-011-4/+23
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Extend the mesa-dri recipe from oecore to avoid conflict with files generated by emgd-driver-bin recipe. This extention is needed only when emgd-driver-bin recipe is included in the target image, so the code is conditional to run only on the machine with emgd graphics driver. The emgd binary driver also provides egl, gles1, gles2 library & headers. To avoid conflict disable egl, gles1, gles2 from meta-dri if the BSP image is bundling the emgd driver. This commits avoids these build warning WARNING: The recipe is trying to install files into a shared area when those files already exist. Those files are: /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/KHR/khrplatform.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/EGL/eglplatform.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/EGL/eglext.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/EGL/egl.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES/glplatform.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES/gl.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES/glext.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES2/gl2ext.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES2/gl2.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES2/gl2platform.h And revert the replacement change commited earlier to avoid these warnings. Revert "mesa-dri.bbappend: avoid buildtime warnings" This reverts commit 2408d28972db8e56f37ec52208adc65734c61dea. This fixes the bug: [YOCTO #3295] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* libva: remove redundant libva 1.0.12Ross Burton2012-11-011-8/+0
| | | | | | | | No BSP from meta-intel repo is requiring this version of libva now. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* libva-intel-driver: update to the latest versionNitin A Kamble2012-11-013-9/+9
| | | | | | | | | | | | | | | | | | | | The older version of libva-intel-driver recipe with newer gst-vaapi recipe was causing video playback failure. As per the discussion on the bug here: https://bugzilla.yoctoproject.org/show_bug.cgi?id=3348 The maintainer of the upstream project is recommending to update the recipe to the latest version to fix the video playback issue. Also, use the release tarball instead of a tag snapshot. Fixes [YOCTO #3348]. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* libva: update to the latest versionNitin A Kamble2012-11-012-8/+8
| | | | | | | | | | | | | | This bug https://bugzilla.yoctoproject.org/show_bug.cgi?id=3348 is triggering this change. The old versions of libva components are affecting video playback on few BSPs like sugarbay & chiefriver. Also, use the release tarball instead of a tag snapshot. Fixes [YOCTO #3348]. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gnu-efi: add missing sha256 checksumRoss Burton2012-10-311-0/+1
| | | | | Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel/common: Add License info for openssl-qat-moduleKishore Bodke2012-10-301-2/+4
| | | | | | | | openssl-qat-module has the dual license. So add GPLv2 and BSD License to openssl qat Module. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-driver-bin: The item in LICENSE_FLAGS_WHITELIST is case sensitive, fix ↵Richard Purdie2012-10-251-1/+1
| | | | | | the instructions Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* lms: Ensure do_unpack2 task can rerunRichard Purdie2012-10-251-8/+10
| | | | | | | If something triggers a rebuild of the do_unpack2 task, it will fail if its already run once. This patch ensures that it can be called multiple times. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
* gstreamer-vaapi: add missing build dependenciesRoss Burton2012-10-231-1/+1
| | | | | | | [YOCTO #3321] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel/common: Add new recipe for libcrypto module.Kishore Bodke2012-10-222-0/+97
| | | | | | | | This adds a new recipe to include the Intel Quick Assist Technology libcrypto Memory Management Module. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel/common: Add a new recipe for Zlib qat_mem Module.Kishore Bodke2012-10-222-0/+95
| | | | | | | | This adds a new recipe to build the Intel Quick Assist Technology Memory Management Module for Zlib. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gstreamer-vaapi: upgrade to 0.3.8, and remove ffmpeg dependenciesRoss Burton2012-10-191-6/+15
| | | | | Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* mesa-dri.bbappend: avoid buildtime warningsNitin A Kamble2012-10-191-0/+5
| | | | | | | | | | | | | | | | | | | | | | | | | | | Extend the mesa-dri recipe from oecore to avoid conflict with files generated by emgd-driver-bin recipe. This commits avoids these build warning WARNING: The recipe is trying to install files into a shared area when those files already exist. Those files are: /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/KHR/khrplatform.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/EGL/eglplatform.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/EGL/eglext.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/EGL/egl.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES/glplatform.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES/gl.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES/glext.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES2/gl2ext.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES2/gl2.h /srv/home/nitin/build-test-bsps/build-crownbay/tmp/sysroots/crownbay/usr/include/GLES2/gl2platform.h This resolves part of the issue reported on the bug: [Yocto #3238] This is a temporary fix, and will be fixed differently after 1.3 release. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Acked-by: Ross Burton <ross.burton@intel.com>
* ffmpeg: set LICENSE_FLAGSPaul Eggleton2012-10-171-0/+2
| | | | | Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-driver-bin: add custom-licenses dir for emgd recipe LicensesNitin A Kamble2012-10-122-0/+601
| | | | | | | | | | | | | | | | | | Add a directory common/custom-licenses to store license texts of recipes in meta-intel layer using custom licenses. Adding these licenses text for emgd-driver-bin recipe: - Intel-software-license-emgd-1.14 - Intel-user-space-graphics-driver-binary-license-emgd-1.14 This takes care of this build warning: WARNING: emgd-driver-bin: No generic license file exists for: Intel-binary-only in any provider This addresses one of the issue reported in the bug: [YOCTO #3238] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-driver-bin: note all the EMGD licensesNitin A Kamble2012-10-121-2/+3
| | | | | | | | | | | There are two files containing the custom license data for EMGD: license: which holds INTEL SOFTWARE LICENSE AGREEMENT readme.txt: which holds User Space Graphics Driver Binary License checksum both these files to track any license changes in future. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-driver_bin: Remove 1.10 in favor of 1.14Nitin A Kamble2012-10-121-93/+0
| | | | | | | All BSPs have been migrated to 1.14, we can now safely retire 1.10 Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* xf86-video-intel: Bring 2.20.0 version to match released graphics stackNitin A Kamble2012-10-123-0/+64
| | | | | | | | | | | | | | | The Intel Linux graphics stack version 12.07 released on 2012-07-24 requires version 2.20.0 as seen here: http://intellinuxgraphics.org/2012.07.html Currently oecore has 2.19.0 version. So get this 2.20.0 version in meta-intel layer to be used by sugarbay and other BSPs using the Intel graphics stack. Also took changes from version 2.20.8 recipe from Ross Burton's branch. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gst-va-intel: incude gst-ffmpeg only if 'commercial' is whitelisted1.3_M5.rc3Tom Zanussi2012-10-031-2/+3
| | | | | | | | | | | | | World and universe builds break if the newly commercial gst-ffmpeg is included without a 'commercial' entry in LICENSE_FLAGS_WHITELIST, so only add gst-ffmpeg if that's the case. Normally BSPs conditionally include gst-va-intel and thus gst-ffmpeg is included in the build only if 'commercial' is added to LICENSE_FLAGS_WHITELIST and therefore this isn't an issue, but world and universe builds are different. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd: Avoid 'already stripped' warningsDarren Hart2012-09-242-0/+4
| | | | | | | | The EMGD binaries comes stripped in the download, so there is nothing we can do about it. Avoid printing the warnings about them being already stripped. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
* emgd-driver-bin: Fix package naming issueNitin A Kamble2012-09-201-1/+7
| | | | | | | | | | | | | | | emgd-driver-bin is generating rpm package with name libegl1. This name clashes with a package with sanme name from mesa-dri recipe. This name clash blocks installation of emgd user land binaries in the image. And due to missing emgd user land components X fails to start on BSPs like crownbay. Fix this problem by specifying package names in the recipe with the PKG_ vars. This fixes bug: [YOCTO #3063] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
* meta-intel: move emgd-driver-bin_1.14 to xorg-driver/Tom Zanussi2012-09-151-0/+0
| | | | | | | emgd-driver-bin should be in common/recipes-graphics/xorg-driver rather than common/recipes-graphics/xorg-xserver so move it there. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: restore emgd 1.10Tom Zanussi2012-09-151-0/+91
| | | | | | | The upgrade to emgd 1.14 inadvertantly removed 1.10, which is still used by some BSPs, so restore it for them. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: add va-impl-intel MACHINE_FEATURETom Zanussi2012-08-302-7/+25
| | | | | | | | | | | | Add a new va-impl-intel MACHINE_FEATURE to explicitly choose intel video acceleration, rather than have it as the fallthrough default, so that anything that wants to specify something different locally doesn't get unwanted components. Also rename the gst-va-mixvideo feature to va-impl-mixvideo match and since it isn't only concerned with gst. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-romley: Move Matrox MGA Xorg driver to meta-intel/commonKishore Bodke2012-08-101-0/+19
| | | | | | | | Matrox MGA Xorg driver is being used by other meta-intel BSPs. So move this to meta-intel/common/recipes-graphics. Signed-off-by: Kishore Bodke <kishore.k.bodke@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-driver-bin: upgrade from 1.10 to 1.14Nitin A Kamble2012-08-011-8/+9
| | | | | | | | | | | | | | | | | | | | | | | | | | | | 1.14 is the latest released driver for emgd. This change is tested on crownbay machine. Add runtime dependency to libxcb-dri2 Otherwise the libxcb-dri2.so is not getting installed, and video acceleration of emgd does not work. It is dynamic dependency of emgd_drv_video.so put files in gstreamer-0.10/.debug directory to the debug package. It avoids debug files packaging warnings. add downloadfilename param to SRC_URI As the url does not have the filename of the tarball, specify it here so that updated wget bitbake fetcher can save the downloaded file accordingly. BTW now EDC has also published another download URL on our request: http://edc.intel.com/App_Shared/Downloads/LIN_IEMGD_1_14_GOLD_2443.tgz And update emgd driver version in the README. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Tested-by: Tom Zanussi <tom.zanussi@intel.com>
* gnu-efi_3.0m.bb: Fix tabs with spaces in python snippetKhem Raj2012-07-271-5/+5
| | | | | | | | This shuts up new bitbake otherwise it warns about this always. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com>
* emgd-driver-bin: remove FILES_${PN}-dev additionTom Zanussi2012-07-201-2/+1
| | | | | | | | The package reordering patches exposed a problem in that the files specified in the FILES_${PN}-dev shouldn't really be put in the -dev package in the first place - this removes them. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* va-intel.bb: Add compatible host x86/x86_64Khem Raj2012-07-201-0/+2
| | | | | | | | This lets meta-intel to play well in multi-bsp setup Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* linux-firmware: update md5sum for LICENCE.iwlwifi_firmware1.3_M2.rc11.3_M2.final1.3_M2Tom Zanussi2012-07-121-1/+1
| | | | | | | | | Update the LIC_FILES_CHKSUM, since the license changed slightly. According to the git log: "Just an extension of the copyright dates." Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* linux-firmware: Fix FILESEXTRAPATHS typoDarren Hart2012-06-201-1/+1
| | | | | | Add a missing } in the FILESEXTRAPATHS assignment. Signed-off-by: Darren Hart <dvhart@linux.intel.com>
* ffmpeg: fix checksumsTom Zanussi2012-06-011-3/+3
| | | | | | | The version was changed, but the checksums weren't updated; this updates them. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gstreamer-vaapi: fix glib includesTom Zanussi2012-05-302-1/+52
| | | | | | | | | | | Fix "Only <glib.h> can be included directly" compilation errors seen when building with 1.3/master. Patch pulled from a post-0.2.9 gstreamer-vaapi version (which however doesn't work with the current stack so a straight upgrade won't work as a fix at this point). Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* lms: new recipeTom Zanussi2012-05-303-0/+81
| | | | | | | | | | Add support for the Intel Active Management Technology (AMT) Local Manageability Service (LMS) daemon. The Intel LMS daemon allows applications to access the Intel AMT firmware via the Intel Management Engine Interface (MEI). Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gst-va-intel: clarify DESCRIPTIONTom Zanussi2012-05-301-1/+1
| | | | | | Modify the description to clarify that these are gstreamer addons. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* va-intel: new packageTom Zanussi2012-05-301-0/+20
| | | | | | | | We need some libraries for video acceleration which depend on the video implementation being used e.g. vanilla intel vs emgd, so create a new 'va-intel' package group for them. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* gst-va-intel: add conditional vaapi implementationTom Zanussi2012-05-301-0/+13
| | | | | | | | | | | | Use different versions of vaapi interface implementaion depending on what a machine specifies. The default if no MACHINE_FEATURE is specified is gstreamer-vaapi. Other machines may need a different implementation e.g. a machine using emgd would specify 'gst-va-mixvideo' in its MACHINE_FEATURES in order to have the implementation satisfied by emgd instead of gstreamer-vaapi, which this also implements. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* ffmpeg: add --enable-yasmTom Zanussi2012-05-302-1/+2
| | | | | | | Enable yasm for the ffmpeg build - we don't want a 'crippled build' or lipsync problems. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* yasm: new recipeTom Zanussi2012-05-301-0/+17
| | | | | | | | | | | | | | | | | x86 (SSE) assembler supporting NASM and GAS-syntaxes, needed by ffmpeg. Taken from oe-classic (git://git.openembedded.org/openembedded): commit 22f72e1751108cf5092332a952fcbadec5cd1a0d Author: Khem Raj <raj.khem@gmail.com> Date: Tue Mar 22 12:21:50 2011 -0700 yasm: Upgrade yasm_0.7.2.bb -> yasm_1.1.0.bb Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* ffmpeg: add --enable-gplTom Zanussi2012-05-301-0/+1
| | | | | | | libpostproc needs --enable-gpl in order to be built. This essentially changes ffmpeg's license to GPL v2+ as per the ffmpeg LICENSE file. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* ffmpeg: add --enable-vaapiTom Zanussi2012-05-302-1/+2
| | | | | | Turn on vaapi support in ffmpeg to allow video acceleration via vaapi. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* ffmpeg: new recipeTom Zanussi2012-05-302-0/+149
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | This is a modified version of the ffmpeg recipe from oe-classic (git://git.openembedded.org/openembedded), updated to ffmpeg-0.7.12, along with some changes take from meta-demo (git://git.yoctoproject.org/meta-demo). The starting point ffmpeg recipe taken from oe-classic version was ffmpeg_0.6.1.bb: commit 5316c5b1416391f15277ce867489e525b7eccd6e Author: Andreas Oberritter <obi@opendreambox.org> Date: Wed Dec 8 22:08:40 2010 +0000 ffmpeg: add recipe for 0.6.1 (LGPLv2.1+) Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> The starting point ffmpeg.inc taken from oe-classic corresponds to the starting commit: commit 709c4d66e0b107ca606941b988bad717c0b45d9b Author: Denys Dmytriyenko <denis@denix.org> Date: Tue Mar 17 14:32:59 2009 -0400 rename packages/ to recipes/ per earlier agreement See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com> up to the following commit: commit 18d59f5fad41e4ea05b5d5a8c1588a0bdbdbf815 Author: Andreas Oberritter <obi@opendreambox.org> Date: Wed Dec 8 22:08:39 2010 +0000 ffmpeg: set default license to GPLv2+, because --enable-gpl is used. * See http://www.ffmpeg.org/legal.html Signed-off-by: Andreas Oberritter <obi@opendreambox.org> The following changes were taken from meta-demo for ffmpeg.inc: commit 33513db7658b9c72bb8c6d477c57b2ab62dab669 Author: Joshua Lock <josh@linux.intel.com> Date: Tue Jan 25 18:00:00 2011 +0000 ffmpeg: Fix some path references that broke with latest master of poky Signed-off-by: Joshua Lock <josh@linux.intel.com> commit ef61afc110ee4444a1c893290079f11c96e0d560 Author: Joshua Lock <josh@linux.intel.com> Date: Tue Mar 1 17:10:20 2011 +0000 ffmpeg: fix header installation Change merged from OpenEmbedded Signed-off-by: Joshua Lock <josh@linux.intel.com> commit cae78e5c49423e9ce967f05a5a7c46920ca0cd6b Author: Darren Hart <dvhart@linux.intel.com> Date: Wed Nov 10 14:41:24 2010 -0800 License audit for meta-demo layer Correct .bb and .inc files to include the proper LICENSE and LIC_FILES_CHKSUM variables. Note that in most cases the "(at your option) a later version" clause to the L?GPL is contained in a source file, not COPYING. In those case, add a more or less core source file to the LIC_FILES_CHKSUM list. Signed-off-by: Darren Hart <dvhart@linux.intel.com> Acked-by: Saul Wold <sgw@linux.intel.com> To get the latest bug and security fixes: - updated to ffmpeg-0.7.12 Some additional changes were made to simplify and remove components that weren't strictly necessary for current needs: - removed shroedinger and libgsm dependencies - removed faac faad2 lame dependencies - removed --libgsm, --libmp3lame, --libschroedinger - removed RSUGGESTS mplayer Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: new intel-driver-1.0.15 recipeTom Zanussi2012-05-302-0/+32
| | | | | | | | libva was split in 1.0.15 into general and Intel-specific parts. This recipe addresses the intel-specific part. The general part is addressed in the separate libva_1.0.15.bb recipe. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: new libva-1.0.15 recipeTom Zanussi2012-05-301-0/+8
| | | | | | | This upgrades libva to libva-1.0.15. Intel-specific changes have been split out into intel-driver-1.0.15, contained in a separate recipe. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* meta-intel: add gstreamer-vaapi_git recipeTom Zanussi2012-05-301-0/+26
| | | | | | | | | | | | | | | | | | | | | | | | | | | Based on the gstreamer-vaapi_0.2.5.bb recipe from the Yocto Project meta-demo layer (git://git.yoctoproject.org/meta-demo): commit a33dd433b629f08bc6517ef2ad3bdd36814ebe85 Author: Joshua Lock <josh@linux.intel.com> Date: Tue Mar 22 12:11:42 2011 +0000 gstreamer-vaapi: new recipe currently untested but will likely be useful in future so commiting it so that it doesn't get lost Signed-off-by: Joshua Lock <josh@linux.intel.com> Additional changes made by Tom Zanussi <tom.zanussi@intel.com> in order to work with the other multimedia recipes in meta-intel/common: - summary and description - correct license - changed into a _git recipe in order to pick up post-0.2.5 versions - additional inherits - tested Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>
* emgd-driver-bin: skip insane ldflags checkTom Zanussi2012-05-181-0/+3
| | | | | | | Add an INSANE_SKIP for ldflags, since these are binaries we have no control over. Signed-off-by: Tom Zanussi <tom.zanussi@intel.com>