summaryrefslogtreecommitdiffstats
path: root/recipes-selftest/images/secureboot-selftest-image-unsigned.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-selftest/images/secureboot-selftest-image-unsigned.bb')
-rw-r--r--recipes-selftest/images/secureboot-selftest-image-unsigned.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes-selftest/images/secureboot-selftest-image-unsigned.bb b/recipes-selftest/images/secureboot-selftest-image-unsigned.bb
new file mode 100644
index 00000000..e03e7b47
--- /dev/null
+++ b/recipes-selftest/images/secureboot-selftest-image-unsigned.bb
@@ -0,0 +1,20 @@
1require recipes-core/images/core-image-minimal.bb
2
3DEPENDS_remove = "grub-efi"
4
5inherit uefi-comboapp
6
7WKS_FILE = "generic-bootdisk.wks.in"
8
9do_uefiapp_deploy_append() {
10 for i in ${DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME}.boot*.efi; do
11 target=`basename $i`
12 target=`echo $target | sed -e 's/${IMAGE_LINK_NAME}.//'`
13
14 cat > ${IMAGE_ROOTFS}/boot/startup.nsh << EOF
15$target
16reset
17EOF
18 break
19 done
20}