summaryrefslogtreecommitdiffstats
path: root/recipes-opencl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-opencl')
-rw-r--r--recipes-opencl/igc/files/0001-skip-execution-of-ElfPackager.patch38
-rw-r--r--recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb26
2 files changed, 64 insertions, 0 deletions
diff --git a/recipes-opencl/igc/files/0001-skip-execution-of-ElfPackager.patch b/recipes-opencl/igc/files/0001-skip-execution-of-ElfPackager.patch
new file mode 100644
index 00000000..5892209d
--- /dev/null
+++ b/recipes-opencl/igc/files/0001-skip-execution-of-ElfPackager.patch
@@ -0,0 +1,38 @@
1From d79c2e5da9c7008b3a345f1060c2fa783dbf001d Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 1 Apr 2019 18:57:25 +0800
4Subject: [PATCH] skip execution of ElfPackager
5
6ElfPackager adds the ability to convert llvm bitcode into elf files for
7easier partitioning. Skip for now until we start building a native
8version for this.
9
10Upstream-Status: Inappropriate [configuration specific]
11
12Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
13---
14 IGC/ElfPackager/CMakeLists.txt | 8 ++++----
15 1 file changed, 4 insertions(+), 4 deletions(-)
16
17diff --git a/IGC/ElfPackager/CMakeLists.txt b/IGC/ElfPackager/CMakeLists.txt
18index 2471622..e9398f2 100644
19--- a/IGC/ElfPackager/CMakeLists.txt
20+++ b/IGC/ElfPackager/CMakeLists.txt
21@@ -69,10 +69,10 @@ include_directories (
22 ${IGC_SOURCE_DIR}/AdaptorOCL/CLElfLib/
23 )
24
25-add_custom_command(TARGET ${IGC_BUILD__PROJ__ElfPackager}
26- POST_BUILD
27- COMMAND $<TARGET_FILE:${IGC_BUILD__PROJ__ElfPackager}> -includeSizet -funcList ${CMAKE_CURRENT_SOURCE_DIR}/function_bin.txt ${IGC_BUILD__BIF_DIR}/OCLBiFImpl.bc ${IGC_BUILD__BIF_DIR}/igdclbif.bin
28- )
29+#add_custom_command(TARGET ${IGC_BUILD__PROJ__ElfPackager}
30+# POST_BUILD
31+# COMMAND $<TARGET_FILE:${IGC_BUILD__PROJ__ElfPackager}> -includeSizet -funcList ${CMAKE_CURRENT_SOURCE_DIR}/function_bin.txt ${IGC_BUILD__BIF_DIR}/OCLBiFImpl.bc ${IGC_BUILD__BIF_DIR}/igdclbif.bin
32+# )
33
34
35 add_dependencies("${IGC_BUILD__PROJ__ElfPackager}" "${IGC_BUILD__PROJ__BiFModule_OCL}")
36--
372.19.1
38
diff --git a/recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb b/recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb
new file mode 100644
index 00000000..11840779
--- /dev/null
+++ b/recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb
@@ -0,0 +1,26 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b \
8 file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
9 file://IGC/Compiler/LegalizationPass.cpp;md5=554b051aebc99c20a0d2b6d695dfe4af"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https \
12 file://0001-skip-execution-of-ElfPackager.patch \
13 "
14
15SRCREV = "81d467882a26d57da18e7f6d8aa3a28cda842642"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST_libc-musl = "null"
23
24DEPENDS_class-target = " flex-native bison-native clang clang-cross-x86_64"
25
26EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=8.0.0 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2"