summaryrefslogtreecommitdiffstats
path: root/recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb')
-rw-r--r--recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb b/recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb
new file mode 100644
index 00000000..11840779
--- /dev/null
+++ b/recipes-opencl/igc/intel-graphics-compiler_19.12.1681.bb
@@ -0,0 +1,26 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://third_party/opencl_headers/LICENSE;md5=dcefc90f4c3c689ec0c2489064e7273b \
8 file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
9 file://IGC/Compiler/LegalizationPass.cpp;md5=554b051aebc99c20a0d2b6d695dfe4af"
10
11SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https \
12 file://0001-skip-execution-of-ElfPackager.patch \
13 "
14
15SRCREV = "81d467882a26d57da18e7f6d8aa3a28cda842642"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21COMPATIBLE_HOST = '(x86_64).*-linux'
22COMPATIBLE_HOST_libc-musl = "null"
23
24DEPENDS_class-target = " flex-native bison-native clang clang-cross-x86_64"
25
26EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=8.0.0 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2"