summaryrefslogtreecommitdiffstats
path: root/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb')
-rw-r--r--recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb b/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb
new file mode 100644
index 00000000..83aba578
--- /dev/null
+++ b/recipes-opencl/igc/intel-graphics-compiler_1.0.6.bb
@@ -0,0 +1,26 @@
1SUMMARY = "The Intel(R) Graphics Compiler for OpenCL(TM)"
2DESCRIPTION = "The Intel(R) Graphics Compiler for OpenCL(TM) is an \
3llvm based compiler for OpenCL(TM) targeting Intel Gen graphics \
4hardware architecture."
5
6LICENSE = "MIT & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://IGC/BiFModule/Implementation/ExternalLibraries/libclc/LICENSE.TXT;md5=311cfc1a5b54bab8ed34a0b5fba4373e \
8 file://IGC/Compiler/LegalizationPass.cpp;md5=4e9a7f0d710a0546cbf5581e1565a986"
9
10SRC_URI = "git://github.com/intel/intel-graphics-compiler.git;protocol=https \
11 file://0001-skip-execution-of-ElfPackager.patch \
12 "
13
14SRCREV = "ebfc688126900a821e407a96417800919b793447"
15
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20COMPATIBLE_HOST = '(x86_64).*-linux'
21COMPATIBLE_HOST_libc-musl = "null"
22
23DEPENDS_class-target = " flex-native bison-native clang clang-cross-x86_64"
24
25EXTRA_OECMAKE = "-DIGC_PREFERRED_LLVM_VERSION=8.0.0 -DPYTHON_EXECUTABLE=${HOSTTOOLS_DIR}/python2"
26EXTRA_OECMAKE += "-DCOMMON_CLANG_LIBRARY_NAME=common_clang"