summaryrefslogtreecommitdiffstats
path: root/recipes-oneapi
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-oneapi')
-rw-r--r--recipes-oneapi/onedpl/onedpl_2021.3.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-oneapi/onedpl/onedpl_2021.3.bb b/recipes-oneapi/onedpl/onedpl_2021.3.bb
new file mode 100644
index 00000000..981b9614
--- /dev/null
+++ b/recipes-oneapi/onedpl/onedpl_2021.3.bb
@@ -0,0 +1,24 @@
1SUMMARY = "oneAPI DPC++ Library (oneDPL)"
2DESCRIPTION = "The oneAPI DPC++ Library (oneDPL) aims to work with the \
3oneAPI DPC++ Compiler to provide high-productivity APIs to developers, \
4which can minimize DPC++ programming efforts across devices for high \
5performance parallel applications."
6HOMEPAGE = "https://github.com/oneapi-src/oneDPL"
7
8LICENSE = "Apache-2.0-with-LLVM-exception"
9LIC_FILES_CHKSUM = "file://licensing/LICENSE.txt;md5=2e982d844baa4df1c80de75470e0c5cb \
10 file://licensing/third-party-programs.txt;md5=4075f07036267ff083d9e095c6a6019f"
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/oneapi-src/oneDPL.git;protocol=https;branch=release/2021.3 \
15 "
16SRCREV = "e18b78a43fd3ec4909331723b2dc11346b667422"
17
18do_compile[noexec] = "1"
19do_configure[noexec] = "1"
20
21do_install() {
22 install -d -m 755 ${D}${includedir}/onedpl
23 cp -r ${S}/include/* ${D}${includedir}/onedpl
24}