summaryrefslogtreecommitdiffstats
path: root/recipes-oneapi/crypto/intel-crypto-mb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-oneapi/crypto/intel-crypto-mb')
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb/0001-GNU.cmake-allow-to-pass-compiler-and-linker-flags.patch29
-rw-r--r--recipes-oneapi/crypto/intel-crypto-mb/0003-CMakeLists.txt-exclude-host-system-headers.patch24
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes-oneapi/crypto/intel-crypto-mb/0001-GNU.cmake-allow-to-pass-compiler-and-linker-flags.patch b/recipes-oneapi/crypto/intel-crypto-mb/0001-GNU.cmake-allow-to-pass-compiler-and-linker-flags.patch
new file mode 100644
index 00000000..49adf8f1
--- /dev/null
+++ b/recipes-oneapi/crypto/intel-crypto-mb/0001-GNU.cmake-allow-to-pass-compiler-and-linker-flags.patch
@@ -0,0 +1,29 @@
1From c440800cae91f857949255cc63993426bdaefb26 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Wed, 16 Jun 2021 20:54:33 +0800
4Subject: [PATCH 1/4] GNU.cmake: allow to pass compiler and linker flags
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10 sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake | 3 ++-
11 1 file changed, 2 insertions(+), 1 deletion(-)
12
13diff --git a/sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake b/sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake
14index 5d148a1..4cb2289 100644
15--- a/sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake
16+++ b/sources/ippcp/crypto_mb/src/cmake/linux/GNU.cmake
17@@ -56,7 +56,8 @@ set(LINK_FLAGS_DYNAMIC "${LINK_FLAGS_DYNAMIC} ${CRYPTO_MB_SOURCES_DIR}/cmake/dll
18 # Compiler flags
19
20 # Tells the compiler to align functions and loops
21-set(CMAKE_C_FLAGS " -falign-functions=32 -falign-loops=32")
22+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -falign-functions=32 -falign-loops=32")
23+
24 # Ensures that compilation takes place in a freestanding environment
25 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -ffreestanding")
26
27--
282.17.1
29
diff --git a/recipes-oneapi/crypto/intel-crypto-mb/0003-CMakeLists.txt-exclude-host-system-headers.patch b/recipes-oneapi/crypto/intel-crypto-mb/0003-CMakeLists.txt-exclude-host-system-headers.patch
new file mode 100644
index 00000000..f9c4a923
--- /dev/null
+++ b/recipes-oneapi/crypto/intel-crypto-mb/0003-CMakeLists.txt-exclude-host-system-headers.patch
@@ -0,0 +1,24 @@
1From 7b575fc23d246373425c3682e83634203aadc4a6 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 17 Jun 2021 12:35:36 +0800
4Subject: [PATCH 3/4] CMakeLists.txt: exclude host system headers
5
6Upstream-Status: Inappropriate
7
8Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
9---
10diff --git a/sources/ippcp/crypto_mb/CMakeLists.txt b/sources/ippcp/crypto_mb/CMakeLists.txt
11index d1f3994..db9635b 100644
12--- a/sources/ippcp/crypto_mb/CMakeLists.txt
13+++ b/sources/ippcp/crypto_mb/CMakeLists.txt
14@@ -75,7 +75,6 @@ endif()
15 include_directories(
16 ${MB_INCLUDE_DIRS}
17 $<$<C_COMPILER_ID:Intel>:$ENV{ROOT}/compiler/include $ENV{ROOT}/compiler/include/icc>
18- $<$<NOT:$<C_COMPILER_ID:Intel>>:${CMAKE_SYSTEM_INCLUDE_PATH}>
19 $<$<OR:$<C_COMPILER_ID:Intel>,$<BOOL:${MSVC_IDE}>>:$ENV{INCLUDE}>
20 )
21
22--
232.17.1
24