summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/libyami/libyami-utils/0001-Fix-build-with-clang.patch23
-rw-r--r--recipes-multimedia/libyami/libyami-utils_git.bb (renamed from recipes-multimedia/libyami/libyami-utils_1.3.0.bb)10
2 files changed, 15 insertions, 18 deletions
diff --git a/recipes-multimedia/libyami/libyami-utils/0001-Fix-build-with-clang.patch b/recipes-multimedia/libyami/libyami-utils/0001-Fix-build-with-clang.patch
index a4a4029c..f7de9d16 100644
--- a/recipes-multimedia/libyami/libyami-utils/0001-Fix-build-with-clang.patch
+++ b/recipes-multimedia/libyami/libyami-utils/0001-Fix-build-with-clang.patch
@@ -1,4 +1,4 @@
1From b7e66182788cd925570bb4c310e21fbcd3185040 Mon Sep 17 00:00:00 2001 1From f2e6d2ecfea635ab952649156e31ca893d4b1a47 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 12 Aug 2017 08:49:20 -0700 3Date: Sat, 12 Aug 2017 08:49:20 -0700
4Subject: [PATCH] Fix build with clang 4Subject: [PATCH] Fix build with clang
@@ -11,9 +11,9 @@ and
11psnr.cpp:225:17: error: bool literal returned from 'main' [-Werror,-Wmain] 11psnr.cpp:225:17: error: bool literal returned from 'main' [-Werror,-Wmain]
12 12
13Signed-off-by: Khem Raj <raj.khem@gmail.com> 13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15Upstream-Status: Pending 14Upstream-Status: Pending
16 15
16---
17 tests/decodehelp.cpp | 2 +- 17 tests/decodehelp.cpp | 2 +-
18 tests/encodehelp.h | 2 +- 18 tests/encodehelp.h | 2 +-
19 tests/vpp.cpp | 2 +- 19 tests/vpp.cpp | 2 +-
@@ -22,12 +22,12 @@ Upstream-Status: Pending
22 5 files changed, 6 insertions(+), 6 deletions(-) 22 5 files changed, 6 insertions(+), 6 deletions(-)
23 23
24diff --git a/tests/decodehelp.cpp b/tests/decodehelp.cpp 24diff --git a/tests/decodehelp.cpp b/tests/decodehelp.cpp
25index a69eab6..2d96598 100644 25index b27b977..62cca63 100644
26--- a/tests/decodehelp.cpp 26--- a/tests/decodehelp.cpp
27+++ b/tests/decodehelp.cpp 27+++ b/tests/decodehelp.cpp
28@@ -70,7 +70,7 @@ bool processCmdLine(int argc, char** argv, DecodeParameter* parameters) 28@@ -81,7 +81,7 @@ bool processCmdLine(int argc, char** argv, DecodeParameter* parameters)
29 {"capi", no_argument, NULL, 0}, 29 { NULL, no_argument, NULL, 0 }
30 {NULL, no_argument, NULL, 0}}; 30 };
31 31
32- char opt; 32- char opt;
33+ int opt; 33+ int opt;
@@ -35,10 +35,10 @@ index a69eab6..2d96598 100644
35 switch (opt) { 35 switch (opt) {
36 case 'h': 36 case 'h':
37diff --git a/tests/encodehelp.h b/tests/encodehelp.h 37diff --git a/tests/encodehelp.h b/tests/encodehelp.h
38index 57ccd77..76df801 100644 38index 63580a4..651ec08 100644
39--- a/tests/encodehelp.h 39--- a/tests/encodehelp.h
40+++ b/tests/encodehelp.h 40+++ b/tests/encodehelp.h
41@@ -107,7 +107,7 @@ static VideoRateControl string_to_rc_mode(char *str) 41@@ -109,7 +109,7 @@ static VideoRateControl string_to_rc_mode(char *str)
42 42
43 static bool process_cmdline(int argc, char *argv[]) 43 static bool process_cmdline(int argc, char *argv[])
44 { 44 {
@@ -61,10 +61,10 @@ index 5a60c0a..52da43b 100644
61 { "help", no_argument, NULL, 'h' }, 61 { "help", no_argument, NULL, 'h' },
62 { "sharpening", required_argument, NULL, 's' }, 62 { "sharpening", required_argument, NULL, 's' },
63diff --git a/tests/yamitranscode.cpp b/tests/yamitranscode.cpp 63diff --git a/tests/yamitranscode.cpp b/tests/yamitranscode.cpp
64index 4cb72aa..2fc6725 100755 64index 6207209..00164ce 100755
65--- a/tests/yamitranscode.cpp 65--- a/tests/yamitranscode.cpp
66+++ b/tests/yamitranscode.cpp 66+++ b/tests/yamitranscode.cpp
67@@ -95,7 +95,7 @@ static VideoRateControl string_to_rc_mode(char *str) 67@@ -100,7 +100,7 @@ static VideoRateControl string_to_rc_mode(char *str)
68 68
69 static bool processCmdLine(int argc, char *argv[], TranscodeParams& para) 69 static bool processCmdLine(int argc, char *argv[], TranscodeParams& para)
70 { 70 {
@@ -94,6 +94,3 @@ index 5cc24c9..68bd668 100644
94 case 'i': 94 case 'i':
95 filename1 = optarg; 95 filename1 = optarg;
96 break; 96 break;
97--
982.14.1
99
diff --git a/recipes-multimedia/libyami/libyami-utils_1.3.0.bb b/recipes-multimedia/libyami/libyami-utils_git.bb
index 00f14398..505d4f65 100644
--- a/recipes-multimedia/libyami/libyami-utils_1.3.0.bb
+++ b/recipes-multimedia/libyami/libyami-utils_git.bb
@@ -10,12 +10,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
10SRC_URI = "git://github.com/intel/libyami-utils.git \ 10SRC_URI = "git://github.com/intel/libyami-utils.git \
11 file://0001-Fix-build-with-clang.patch \ 11 file://0001-Fix-build-with-clang.patch \
12 " 12 "
13SRCREV = "d9c62f6a0653aa2e59cd2af9a3c80d82122d2149" 13SRCREV = "06f0e45a34d85fa4f4858ec369adc0c7ed333469"
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
15PV = "1.3.0+git${SRCPV}"
15 16
16DEPENDS = "libva libyami" 17DEPENDS = "libva libyami"
17 18
18EXTRA_OECONF = "--enable-tests-gles --disable-md5" 19EXTRA_OECONF = "--disable-md5"
19 20
20inherit autotools pkgconfig distro_features_check 21inherit autotools pkgconfig distro_features_check
21 22
@@ -25,7 +26,6 @@ PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
25 26
26# --enable-x11 needs libva-x11 27# --enable-x11 needs libva-x11
27# gles-tests fail to build without x11: see https://github.com/intel/libyami-utils/issues/91 28# gles-tests fail to build without x11: see https://github.com/intel/libyami-utils/issues/91
28PACKAGECONFIG[x11] = "--enable-x11 --enable-tests-gles,--disable-x11 --disable-tests-gles, virtual/libx11" 29PACKAGECONFIG[x11] = "--enable-x11 --enable-egl,--disable-x11 --disable-egl, virtual/libx11"
29 30
30UPSTREAM_CHECK_URI = "http://github.com/intel/libyami-utils/releases" 31UPSTREAM_CHECK_COMMITS = "1"
31UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"