diff options
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/libyami/libyami/0005-move-c-definitions-out-of-extern-C-block.patch | 130 | ||||
-rw-r--r-- | recipes-multimedia/libyami/libyami_1.3.1.bb (renamed from recipes-multimedia/libyami/libyami_git.bb) | 6 |
2 files changed, 1 insertions, 135 deletions
diff --git a/recipes-multimedia/libyami/libyami/0005-move-c-definitions-out-of-extern-C-block.patch b/recipes-multimedia/libyami/libyami/0005-move-c-definitions-out-of-extern-C-block.patch deleted file mode 100644 index e77e85f7..00000000 --- a/recipes-multimedia/libyami/libyami/0005-move-c-definitions-out-of-extern-C-block.patch +++ /dev/null | |||
@@ -1,130 +0,0 @@ | |||
1 | From 3748cf904089878971cfcf66abf14c4d74f8241a Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 11 Aug 2017 18:03:07 -0700 | ||
4 | Subject: [PATCH 5/9] move c++ definitions out of extern "C" block | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | Upstream-Status: Pending | ||
9 | |||
10 | decoder/vaapidecoder_host.cpp | 2 +- | ||
11 | encoder/vaapiencoder_host.cpp | 3 ++- | ||
12 | interface/VideoDecoderHost.h | 8 ++++---- | ||
13 | interface/VideoEncoderHost.h | 8 ++++---- | ||
14 | interface/VideoPostProcessHost.h | 8 ++++---- | ||
15 | vpp/vaapipostprocess_host.cpp | 3 +-- | ||
16 | 6 files changed, 16 insertions(+), 16 deletions(-) | ||
17 | |||
18 | diff --git a/decoder/vaapidecoder_host.cpp b/decoder/vaapidecoder_host.cpp | ||
19 | index bcc9165..d9129f3 100644 | ||
20 | --- a/decoder/vaapidecoder_host.cpp | ||
21 | +++ b/decoder/vaapidecoder_host.cpp | ||
22 | @@ -100,9 +100,9 @@ void releaseVideoDecoder(IVideoDecoder * p) | ||
23 | { | ||
24 | delete p; | ||
25 | } | ||
26 | +} // extern "C" | ||
27 | |||
28 | std::vector<std::string> getVideoDecoderMimeTypes() | ||
29 | { | ||
30 | return VaapiDecoderFactory::keys(); | ||
31 | } | ||
32 | -} // extern "C" | ||
33 | diff --git a/encoder/vaapiencoder_host.cpp b/encoder/vaapiencoder_host.cpp | ||
34 | index 49e903a..3ee9354 100644 | ||
35 | --- a/encoder/vaapiencoder_host.cpp | ||
36 | +++ b/encoder/vaapiencoder_host.cpp | ||
37 | @@ -78,9 +78,10 @@ void releaseVideoEncoder(IVideoEncoder* p) { | ||
38 | delete p; | ||
39 | } | ||
40 | |||
41 | +} // extern "C" | ||
42 | + | ||
43 | std::vector<std::string> getVideoEncoderMimeTypes() | ||
44 | { | ||
45 | return VaapiEncoderFactory::keys(); | ||
46 | } | ||
47 | |||
48 | -} // extern "C" | ||
49 | diff --git a/interface/VideoDecoderHost.h b/interface/VideoDecoderHost.h | ||
50 | index 86210fe..fd2ba7b 100644 | ||
51 | --- a/interface/VideoDecoderHost.h | ||
52 | +++ b/interface/VideoDecoderHost.h | ||
53 | @@ -32,12 +32,12 @@ extern "C" { // for dlsym usage | ||
54 | YamiMediaCodec::IVideoDecoder *createVideoDecoder(const char *mimeType); | ||
55 | /// \brief destroy the decoder | ||
56 | void releaseVideoDecoder(YamiMediaCodec::IVideoDecoder * p); | ||
57 | -/** \fn void getVideoDecoderMimeTypes() | ||
58 | - * \brief return the MimeTypes enabled in the current build | ||
59 | -*/ | ||
60 | -std::vector<std::string> getVideoDecoderMimeTypes(); | ||
61 | |||
62 | typedef YamiMediaCodec::IVideoDecoder *(*YamiCreateVideoDecoderFuncPtr) (const char *mimeType); | ||
63 | typedef void (*YamiReleaseVideoDecoderFuncPtr)(YamiMediaCodec::IVideoDecoder * p); | ||
64 | } | ||
65 | +// \fn void getVideoDecoderMimeTypes() | ||
66 | +// \brief return the MimeTypes enabled in the current build | ||
67 | +// | ||
68 | +std::vector<std::string> getVideoDecoderMimeTypes(); | ||
69 | #endif /* VIDEO_DECODER_HOST_H_ */ | ||
70 | diff --git a/interface/VideoEncoderHost.h b/interface/VideoEncoderHost.h | ||
71 | index fb80335..5fb5ab3 100644 | ||
72 | --- a/interface/VideoEncoderHost.h | ||
73 | +++ b/interface/VideoEncoderHost.h | ||
74 | @@ -32,12 +32,12 @@ extern "C" { // for dlsym usage | ||
75 | YamiMediaCodec::IVideoEncoder *createVideoEncoder(const char *mimeType); | ||
76 | ///brief destroy encoder | ||
77 | void releaseVideoEncoder(YamiMediaCodec::IVideoEncoder * p); | ||
78 | -/** \fn void getVideoEncoderMimeTypes() | ||
79 | - * \brief return the MimeTypes enabled in the current build | ||
80 | -*/ | ||
81 | -std::vector<std::string> getVideoEncoderMimeTypes(); | ||
82 | |||
83 | typedef YamiMediaCodec::IVideoEncoder *(*YamiCreateVideoEncoderFuncPtr) (const char *mimeType); | ||
84 | typedef void (*YamiReleaseVideoEncoderFuncPtr)(YamiMediaCodec::IVideoEncoder * p); | ||
85 | } | ||
86 | #endif /* VIDEO_ENCODER_HOST_H_ */ | ||
87 | +// \fn void getVideoEncoderMimeTypes() | ||
88 | +// \brief return the MimeTypes enabled in the current build | ||
89 | +// | ||
90 | +std::vector<std::string> getVideoEncoderMimeTypes(); | ||
91 | diff --git a/interface/VideoPostProcessHost.h b/interface/VideoPostProcessHost.h | ||
92 | index de046cd..f1c5ce5 100644 | ||
93 | --- a/interface/VideoPostProcessHost.h | ||
94 | +++ b/interface/VideoPostProcessHost.h | ||
95 | @@ -34,12 +34,12 @@ YamiMediaCodec::IVideoPostProcess *createVideoPostProcess(const char *mimeType); | ||
96 | * \brief destroy encoder | ||
97 | */ | ||
98 | void releaseVideoPostProcess(YamiMediaCodec::IVideoPostProcess * p); | ||
99 | -/** \fn void getVideoPostProcessMimeTypes() | ||
100 | - * \brief return the MimeTypes enabled in the current build | ||
101 | -*/ | ||
102 | -std::vector<std::string> getVideoPostProcessMimeTypes(); | ||
103 | |||
104 | typedef YamiMediaCodec::IVideoPostProcess *(*YamiCreateVideoPostProcessFuncPtr) (const char *mimeType); | ||
105 | typedef void (*YamiReleaseVideoPostProcessFuncPtr)(YamiMediaCodec::IVideoPostProcess * p); | ||
106 | } | ||
107 | #endif /* VIDEO_POST_PROCESS_HOST_H_ */ | ||
108 | +// \fn void getVideoPostProcessMimeTypes() | ||
109 | +// \brief return the MimeTypes enabled in the current build | ||
110 | +// | ||
111 | +std::vector<std::string> getVideoPostProcessMimeTypes(); | ||
112 | diff --git a/vpp/vaapipostprocess_host.cpp b/vpp/vaapipostprocess_host.cpp | ||
113 | index cd40dea..bc06b38 100644 | ||
114 | --- a/vpp/vaapipostprocess_host.cpp | ||
115 | +++ b/vpp/vaapipostprocess_host.cpp | ||
116 | @@ -75,10 +75,9 @@ void releaseVideoPostProcess(IVideoPostProcess * p) | ||
117 | { | ||
118 | delete p; | ||
119 | } | ||
120 | +} // extern "C" | ||
121 | |||
122 | std::vector<std::string> getVideoPostProcessMimeTypes() | ||
123 | { | ||
124 | return VaapiPostProcessFactory::keys(); | ||
125 | } | ||
126 | - | ||
127 | -} // extern "C" | ||
128 | -- | ||
129 | 2.14.1 | ||
130 | |||
diff --git a/recipes-multimedia/libyami/libyami_git.bb b/recipes-multimedia/libyami/libyami_1.3.1.bb index 7ff9effd..58895c81 100644 --- a/recipes-multimedia/libyami/libyami_git.bb +++ b/recipes-multimedia/libyami/libyami_1.3.1.bb | |||
@@ -13,15 +13,13 @@ SRC_URI = "git://github.com/intel/libyami.git;branch=apache \ | |||
13 | file://0002-typecast-index-from-size_t-to-int.patch \ | 13 | file://0002-typecast-index-from-size_t-to-int.patch \ |
14 | file://0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch \ | 14 | file://0003-Add-Wno-invalid-offsetof-to-compiler-commandline.patch \ |
15 | file://0004-Typecast-POWER32SUB2-to-uint8_t.patch \ | 15 | file://0004-Typecast-POWER32SUB2-to-uint8_t.patch \ |
16 | file://0005-move-c-definitions-out-of-extern-C-block.patch \ | ||
17 | file://0006-Avoid-namespace-conflicts-by-adding-explicit-using-n.patch \ | 16 | file://0006-Avoid-namespace-conflicts-by-adding-explicit-using-n.patch \ |
18 | file://0007-Delete-unused-variables.patch \ | 17 | file://0007-Delete-unused-variables.patch \ |
19 | file://0008-NalUnit-is-declared-in-different-namespace.patch \ | 18 | file://0008-NalUnit-is-declared-in-different-namespace.patch \ |
20 | file://0009-Fix-clang-warnings.patch \ | 19 | file://0009-Fix-clang-warnings.patch \ |
21 | " | 20 | " |
22 | SRCREV = "49f32de0e537577927b98deb551e16a7fa89d892" | 21 | SRCREV = "fb48083de91f837ddbf599dd4b5ad1eb1239e1cf" |
23 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |
24 | PV = "1.3.0+git${SRCPV}" | ||
25 | 23 | ||
26 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}" | 24 | PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "x11", "", d)}" |
27 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender" | 25 | PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxrandr libxrender" |
@@ -30,5 +28,3 @@ DEPENDS = "libva" | |||
30 | inherit autotools pkgconfig distro_features_check | 28 | inherit autotools pkgconfig distro_features_check |
31 | 29 | ||
32 | REQUIRED_DISTRO_FEATURES = "opengl" | 30 | REQUIRED_DISTRO_FEATURES = "opengl" |
33 | |||
34 | UPSTREAM_CHECK_COMMITS = "1" | ||