summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/mediasdk/intel-mediasdk_19.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/mediasdk/intel-mediasdk_19.1.0.bb')
-rw-r--r--recipes-multimedia/mediasdk/intel-mediasdk_19.1.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes-multimedia/mediasdk/intel-mediasdk_19.1.0.bb b/recipes-multimedia/mediasdk/intel-mediasdk_19.1.0.bb
new file mode 100644
index 00000000..7dd4da63
--- /dev/null
+++ b/recipes-multimedia/mediasdk/intel-mediasdk_19.1.0.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Intel(R) Media SDK for hardware accelerated media processing"
2DESCRIPTION = "Intel(R) Media SDK provides an API to access hardware-accelerated \
3video decode, encode and filtering on IntelĀ® platforms with integrated graphics."
4
5HOMEPAGE = "https://github.com/Intel-Media-SDK/MediaSDK"
6BUGTRACKER = "https://github.com/Intel-Media-SDK/MediaSDK/issues"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=3cb331af679cd8f968bf799a9c55b46e"
10
11# Only for 64 bit until media-driver issues aren't fixed
12COMPATIBLE_HOST = '(x86_64).*-linux'
13
14DEPENDS += "libdrm libva intel-media-driver"
15
16PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "x11", "dri3", "", d)} \
17 ${@bb.utils.contains("DISTRO_FEATURES", "wayland", "wayland", "", d)}"
18
19PACKAGECONFIG[dri3] = "-DENABLE_X11_DRI3=ON, -DENABLE_X11_DRI3=OFF"
20PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND=ON, -DENABLE_WAYLAND=OFF, wayland wayland-native"
21
22SRC_URI = " \
23 git://github.com/Intel-Media-SDK/MediaSDK.git;protocol=https;branch=${BPN}-19.1 \
24 "
25
26SRCREV = "428b07dabe13b991ba20cf796c91f897a8d1b972"
27S = "${WORKDIR}/git"
28
29UPSTREAM_CHECK_GITTAGREGEX = "^intel-mediasdk-(?P<pver>(\d+(\.\d+)+))$"
30
31inherit cmake pkgconfig
32
33EXTRA_OECMAKE += "-DMFX_INCLUDE=${S}/api/include -DBUILD_SAMPLES=OFF"
34
35FILES_${PN} += " \
36 ${libdir}/mfx \
37 ${datadir}/mfx/plugins.cfg \
38 "