summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch')
-rw-r--r--recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch b/recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch
new file mode 100644
index 00000000..6009669a
--- /dev/null
+++ b/recipes-multimedia/itt/itt/0001-CMakeLists.txt-set-output-directory-path.patch
@@ -0,0 +1,33 @@
1From 6bced614fe448ee7fc6216b528e2c5684446f9c6 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Tue, 14 May 2019 16:57:27 +0800
4Subject: [PATCH] CMakeLists.txt: set output directory path
5
6Installer section of CMakeLists.txt expect bin
7direcotry should be present at PROJECT_SOURCE_DIR
8
9set(SEA_PROJECT_BIN ${PROJECT_SOURCE_DIR}/bin)
10
11Upstream-Status: Inappropriate
12
13Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
14---
15 CMakeLists.txt | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/CMakeLists.txt b/CMakeLists.txt
19index 479c443..01f0124 100644
20--- a/CMakeLists.txt
21+++ b/CMakeLists.txt
22@@ -65,7 +65,7 @@ foreach (Flag ${Flags})
23 message(STATUS "${Flag} = ${${Flag}}")
24 endforeach()
25
26-set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/../../bin)
27+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${PROJECT_SOURCE_DIR}/bin)
28
29 set(EXECUTABLE_OUTPUT_PATH ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
30 set(LIBRARY_OUTPUT_PATH ${CMAKE_RUNTIME_OUTPUT_DIRECTORY})
31--
322.17.0
33