summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.10.bb6
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.4.bb6
-rw-r--r--recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch94
-rw-r--r--recipes-kernel/linux/linux-intel_5.10.bb7
-rw-r--r--recipes-kernel/linux/linux-intel_5.4.bb6
5 files changed, 107 insertions, 12 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_5.10.bb b/recipes-kernel/linux/linux-intel-rt_5.10.bb
index bba48759..c0f534e9 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.10.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.10.bb
@@ -18,9 +18,9 @@ KMETA_BRANCH = "yocto-5.10"
18 18
19DEPENDS += "elfutils-native openssl-native util-linux-native" 19DEPENDS += "elfutils-native openssl-native util-linux-native"
20 20
21LINUX_VERSION ?= "5.10.59" 21LINUX_VERSION ?= "5.10.100"
22SRCREV_machine ?= "3ab3139402e6adc34f10481f1c1c60459bcd0a7e" 22SRCREV_machine ?= "ff3955ce463b15f419cfaf1f86d31851483c76d0"
23SRCREV_meta ?= "f8afd84b117f336477846b9e22178ebefb26c08d" 23SRCREV_meta ?= "64fb693a6c11f21bab3ff9bb8dcb65a70abe05e3"
24 24
25LINUX_KERNEL_TYPE = "preempt-rt" 25LINUX_KERNEL_TYPE = "preempt-rt"
26 26
diff --git a/recipes-kernel/linux/linux-intel-rt_5.4.bb b/recipes-kernel/linux/linux-intel-rt_5.4.bb
index adc01e6b..464dfedb 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.4.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.4.bb
@@ -18,9 +18,9 @@ KMETA_BRANCH = "yocto-5.4"
18 18
19DEPENDS += "elfutils-native openssl-native util-linux-native" 19DEPENDS += "elfutils-native openssl-native util-linux-native"
20 20
21LINUX_VERSION ?= "5.4.143" 21LINUX_VERSION ?= "5.4.170"
22SRCREV_machine ?= "2dc0f2c1ee89b9ce92944e397f2619062ebb77f8" 22SRCREV_machine ?= "196e38246d15096460031f4a17913922c006b12d"
23SRCREV_meta ?= "e14d587eec888fba8693da2a072f729219acfb41" 23SRCREV_meta ?= "98cce1c95fcc9a26965cbc5f038fd71d53c387c8"
24 24
25LINUX_KERNEL_TYPE = "preempt-rt" 25LINUX_KERNEL_TYPE = "preempt-rt"
26 26
diff --git a/recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch b/recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch
new file mode 100644
index 00000000..e3608238
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel/0001-io-mapping-Cleanup-atomic-iomap.patch
@@ -0,0 +1,94 @@
1From cc3ff5fe73139251070775308dcaadf474566b4b Mon Sep 17 00:00:00 2001
2From: Thomas Gleixner <tglx@linutronix.de>
3Date: Tue, 3 Nov 2020 10:27:32 +0100
4Subject: [PATCH] io-mapping: Cleanup atomic iomap
5
6Switch the atomic iomap implementation over to kmap_local and stick the
7preempt/pagefault mechanics into the generic code similar to the
8kmap_atomic variants.
9
10Rename the x86 map function in preparation for a non-atomic variant.
11
12Upstream-Status: Backport [https://github.com/torvalds/linux/commit/351191ad55c8a1eccaf23e4187c62056229c0779]
13
14Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
15Cc: Linus Torvalds <torvalds@linuxfoundation.org>
16Cc: Christoph Hellwig <hch@lst.de>
17Cc: Andrew Morton <akpm@linux-foundation.org>
18Link: https://lore.kernel.org/r/20201103095858.625310005@linutronix.de
19---
20 arch/x86/include/asm/iomap.h | 9 +--------
21 arch/x86/mm/iomap_32.c | 6 ++----
22 include/linux/io-mapping.h | 8 ++++++--
23 3 files changed, 9 insertions(+), 14 deletions(-)
24
25diff --git a/arch/x86/include/asm/iomap.h b/arch/x86/include/asm/iomap.h
26index 0be7a30fd6bc..e2de092fc38c 100644
27--- a/arch/x86/include/asm/iomap.h
28+++ b/arch/x86/include/asm/iomap.h
29@@ -13,14 +13,7 @@
30 #include <asm/cacheflush.h>
31 #include <asm/tlbflush.h>
32
33-void __iomem *iomap_atomic_pfn_prot(unsigned long pfn, pgprot_t prot);
34-
35-static inline void iounmap_atomic(void __iomem *vaddr)
36-{
37- kunmap_local_indexed((void __force *)vaddr);
38- pagefault_enable();
39- preempt_enable();
40-}
41+void __iomem *__iomap_local_pfn_prot(unsigned long pfn, pgprot_t prot);
42
43 int iomap_create_wc(resource_size_t base, unsigned long size, pgprot_t *prot);
44
45diff --git a/arch/x86/mm/iomap_32.c b/arch/x86/mm/iomap_32.c
46index e0a40d7cc66c..9aaa756ddf21 100644
47--- a/arch/x86/mm/iomap_32.c
48+++ b/arch/x86/mm/iomap_32.c
49@@ -44,7 +44,7 @@ void iomap_free(resource_size_t base, unsigned long size)
50 }
51 EXPORT_SYMBOL_GPL(iomap_free);
52
53-void __iomem *iomap_atomic_pfn_prot(unsigned long pfn, pgprot_t prot)
54+void __iomem *__iomap_local_pfn_prot(unsigned long pfn, pgprot_t prot)
55 {
56 /*
57 * For non-PAT systems, translate non-WB request to UC- just in
58@@ -60,8 +60,6 @@ void __iomem *iomap_atomic_pfn_prot(unsigned long pfn, pgprot_t prot)
59 /* Filter out unsupported __PAGE_KERNEL* bits: */
60 pgprot_val(prot) &= __default_kernel_pte_mask;
61
62- preempt_disable();
63- pagefault_disable();
64 return (void __force __iomem *)__kmap_local_pfn_prot(pfn, prot);
65 }
66-EXPORT_SYMBOL_GPL(iomap_atomic_pfn_prot);
67+EXPORT_SYMBOL_GPL(__iomap_local_pfn_prot);
68diff --git a/include/linux/io-mapping.h b/include/linux/io-mapping.h
69index 0a1a186a43c5..e9743cfd8585 100644
70--- a/include/linux/io-mapping.h
71+++ b/include/linux/io-mapping.h
72@@ -69,13 +69,17 @@ io_mapping_map_atomic_wc(struct io_mapping *mapping,
73
74 BUG_ON(offset >= mapping->size);
75 phys_addr = mapping->base + offset;
76- return iomap_atomic_pfn_prot(PHYS_PFN(phys_addr), mapping->prot);
77+ preempt_disable();
78+ pagefault_disable();
79+ return __iomap_local_pfn_prot(PHYS_PFN(phys_addr), mapping->prot);
80 }
81
82 static inline void
83 io_mapping_unmap_atomic(void __iomem *vaddr)
84 {
85- iounmap_atomic(vaddr);
86+ kunmap_local_indexed((void __force *)vaddr);
87+ pagefault_enable();
88+ preempt_enable();
89 }
90
91 static inline void __iomem *
92--
932.17.1
94
diff --git a/recipes-kernel/linux/linux-intel_5.10.bb b/recipes-kernel/linux/linux-intel_5.10.bb
index 90a95db2..26790d9f 100644
--- a/recipes-kernel/linux/linux-intel_5.10.bb
+++ b/recipes-kernel/linux/linux-intel_5.10.bb
@@ -6,13 +6,14 @@ KMETA_BRANCH = "yocto-5.10"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 6LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
7 7
8SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ 8SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
9 file://0001-io-mapping-Cleanup-atomic-iomap.patch \
9 " 10 "
10 11
11DEPENDS += "elfutils-native openssl-native util-linux-native" 12DEPENDS += "elfutils-native openssl-native util-linux-native"
12 13
13LINUX_VERSION ?= "5.10.59" 14LINUX_VERSION ?= "5.10.100"
14SRCREV_machine ?= "9efba09f984bb30bd3ea01a811c500eb26356a15" 15SRCREV_machine ?= "8e5c6f8269920b343e40bdf7b3b1a33918009395"
15SRCREV_meta ?= "f8afd84b117f336477846b9e22178ebefb26c08d" 16SRCREV_meta ?= "64fb693a6c11f21bab3ff9bb8dcb65a70abe05e3"
16 17
17# For Crystalforest and Romley 18# For Crystalforest and Romley
18KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio" 19KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio"
diff --git a/recipes-kernel/linux/linux-intel_5.4.bb b/recipes-kernel/linux/linux-intel_5.4.bb
index 570f692b..24a6fa0e 100644
--- a/recipes-kernel/linux/linux-intel_5.4.bb
+++ b/recipes-kernel/linux/linux-intel_5.4.bb
@@ -9,9 +9,9 @@ SRC_URI:append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurs
9 9
10DEPENDS += "elfutils-native openssl-native util-linux-native" 10DEPENDS += "elfutils-native openssl-native util-linux-native"
11 11
12LINUX_VERSION ?= "5.4.143" 12LINUX_VERSION ?= "5.4.170"
13SRCREV_machine ?= "8246417e2e14117a0a9f3625c2122fc26c92c6bd" 13SRCREV_machine ?= "36f93ff941f127f4137ab369aecbdd995fb58c66"
14SRCREV_meta ?= "e14d587eec888fba8693da2a072f729219acfb41" 14SRCREV_meta ?= "98cce1c95fcc9a26965cbc5f038fd71d53c387c8"
15 15
16# For Crystalforest and Romley 16# For Crystalforest and Romley
17KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio" 17KERNEL_MODULE_AUTOLOAD:append:core2-32-intel-common = " uio"