summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux')
-rw-r--r--recipes-kernel/linux/linux-intel-dev.bb10
-rw-r--r--recipes-kernel/linux/linux-intel-rt_5.4.bb11
-rw-r--r--recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch50
-rw-r--r--recipes-kernel/linux/linux-intel_5.4.bb11
4 files changed, 71 insertions, 11 deletions
diff --git a/recipes-kernel/linux/linux-intel-dev.bb b/recipes-kernel/linux/linux-intel-dev.bb
index 4da6e3b9..12dda6cb 100644
--- a/recipes-kernel/linux/linux-intel-dev.bb
+++ b/recipes-kernel/linux/linux-intel-dev.bb
@@ -6,7 +6,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-intel:"
6SRC_URI = " \ 6SRC_URI = " \
7 git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \ 7 git://github.com/intel/mainline-tracking.git;protocol=https;name=machine;nobranch=1; \
8 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \ 8 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=${KMETA_BRANCH};destsuffix=${KMETA} \
9 file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \ 9 file://0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch \
10 " 10 "
11SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg" 11SRC_URI_append_core2-32-intel-common = " file://disable_skylake_sound.cfg"
12 12
@@ -15,13 +15,13 @@ KCONF_BSP_AUDIT_LEVEL = "2"
15 15
16KMETA_BRANCH = "master" 16KMETA_BRANCH = "master"
17 17
18LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814" 18LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
19 19
20DEPENDS += "elfutils-native openssl-native util-linux-native" 20DEPENDS += "elfutils-native openssl-native util-linux-native"
21 21
22LINUX_VERSION ?= "5.5-rc3" 22LINUX_VERSION ?= "5.19.0"
23SRCREV_machine ?= "0c5d381c6f1ebd88b4da2c3392f86d1611daba84" 23SRCREV_machine ?= "270ddbd02fe9e1761ebccf792acadbb3cd52b69f"
24SRCREV_meta ?= "1b65db46af4e00e257a6be18cb06736cb83d54dd" 24SRCREV_meta ?= "423df1333e1e2a0c2bff9b29d40d16d74b775a79"
25 25
26LINUX_VERSION_EXTENSION ?= "-mainline-tracking-${LINUX_KERNEL_TYPE}" 26LINUX_VERSION_EXTENSION ?= "-mainline-tracking-${LINUX_KERNEL_TYPE}"
27PV = "${LINUX_VERSION}+git${SRCPV}" 27PV = "${LINUX_VERSION}+git${SRCPV}"
diff --git a/recipes-kernel/linux/linux-intel-rt_5.4.bb b/recipes-kernel/linux/linux-intel-rt_5.4.bb
index 38a536c0..15c8febf 100644
--- a/recipes-kernel/linux/linux-intel-rt_5.4.bb
+++ b/recipes-kernel/linux/linux-intel-rt_5.4.bb
@@ -17,8 +17,13 @@ KMETA_BRANCH = "yocto-5.4"
17 17
18DEPENDS += "elfutils-native openssl-native util-linux-native" 18DEPENDS += "elfutils-native openssl-native util-linux-native"
19 19
20LINUX_VERSION ?= "5.4.138" 20LINUX_VERSION ?= "5.4.209"
21SRCREV_machine ?= "45e3b0f5357fc86bf0e766a5249fc7faa33c1be8" 21SRCREV_machine ?= "70a06857dca28633fad857b852c6c86189438afb"
22SRCREV_meta ?= "b8c82ba37370e4698ff0c42f3e54b8b4f2fb4ac0" 22SRCREV_meta ?= "c917f683a6394ae00f81139ae57ae0112d4b7528"
23 23
24LINUX_KERNEL_TYPE = "preempt-rt" 24LINUX_KERNEL_TYPE = "preempt-rt"
25
26# Kernel config 'CONFIG_GPIO_LYNXPOINT' goes by a different name 'CONFIG_PINCTRL_LYNXPOINT' in
27# linux-intel 5.4 specifically. This causes a warning during kernel config audit. Suppress the
28# harmless warning for now.
29KCONF_BSP_AUDIT_LEVEL = "0"
diff --git a/recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch b/recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch
new file mode 100644
index 00000000..0ebbb008
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel/0001-v5.19-menuconfig-mconf-cfg-Allow-specification-of-ncurses-.patch
@@ -0,0 +1,50 @@
1From ecb938c19d20543382c9bbc42588c29b5ebfd3ed Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@windriver.com>
3Date: Fri, 12 Aug 2022 13:12:18 +0800
4Subject: [PATCH] menuconfig,mconf-cfg: Allow specification of ncurses location
5
6In some cross build environments such as the Yocto Project build
7environment it provides an ncurses library that is compiled
8differently than the host's version. This causes display corruption
9problems when the host's curses includes are used instead of the
10includes from the provided compiler are overridden. There is a second
11case where there is no curses libraries at all on the host system and
12menuconfig will just fail entirely.
13
14The solution is simply to allow an override variable in
15check-lxdialog.sh for environments such as the Yocto Project. Adding
16a CROSS_CURSES_LIB and CROSS_CURSES_INC solves the issue and allowing
17compiling and linking against the right headers and libraries.
18
19Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
20cc: Michal Marek <mmarek@suse.cz>
21cc: linux-kbuild@vger.kernel.org
22Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
23Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
24---
25 scripts/kconfig/mconf-cfg.sh | 9 +++++++++
26 1 file changed, 9 insertions(+)
27
28diff --git a/scripts/kconfig/mconf-cfg.sh b/scripts/kconfig/mconf-cfg.sh
29index 025b565e0b7c..6514d19790e6 100755
30--- a/scripts/kconfig/mconf-cfg.sh
31+++ b/scripts/kconfig/mconf-cfg.sh
32@@ -4,6 +4,15 @@
33 PKG="ncursesw"
34 PKG2="ncurses"
35
36+if [ "$CROSS_CURSES_LIB" != "" ]; then
37+ echo libs=\'$CROSS_CURSES_LIB\'
38+ if [ x"$CROSS_CURSES_INC" != x ]; then
39+ echo cflags=\'$CROSS_CURSES_INC\'
40+ fi
41+ exit 0
42+fi
43+
44+
45 if [ -n "$(command -v ${HOSTPKG_CONFIG})" ]; then
46 if ${HOSTPKG_CONFIG} --exists $PKG; then
47 echo cflags=\"$(${HOSTPKG_CONFIG} --cflags $PKG)\"
48--
492.25.1
50
diff --git a/recipes-kernel/linux/linux-intel_5.4.bb b/recipes-kernel/linux/linux-intel_5.4.bb
index f0615a92..df56b370 100644
--- a/recipes-kernel/linux/linux-intel_5.4.bb
+++ b/recipes-kernel/linux/linux-intel_5.4.bb
@@ -9,9 +9,9 @@ SRC_URI_append = " file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurs
9 9
10DEPENDS += "elfutils-native openssl-native util-linux-native" 10DEPENDS += "elfutils-native openssl-native util-linux-native"
11 11
12LINUX_VERSION ?= "5.4.143" 12LINUX_VERSION ?= "5.4.209"
13SRCREV_machine ?= "8246417e2e14117a0a9f3625c2122fc26c92c6bd" 13SRCREV_machine ?= "ea2d8185fa954bc9c9a0c703cc4ff9c4b5cb8df5"
14SRCREV_meta ?= "b8c82ba37370e4698ff0c42f3e54b8b4f2fb4ac0" 14SRCREV_meta ?= "c917f683a6394ae00f81139ae57ae0112d4b7528"
15 15
16# For Crystalforest and Romley 16# For Crystalforest and Romley
17KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio" 17KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
@@ -19,3 +19,8 @@ KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
19 19
20# Functionality flags 20# Functionality flags
21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc" 21KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/security/security.scc"
22
23# Kernel config 'CONFIG_GPIO_LYNXPOINT' goes by a different name 'CONFIG_PINCTRL_LYNXPOINT' in
24# linux-intel 5.4 specifically. This causes a warning during kernel config audit. Suppress the
25# harmless warning for now.
26KCONF_BSP_AUDIT_LEVEL = "0"