summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto_4.9.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-yocto_4.9.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto_4.9.bbappend21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.9.bbappend b/recipes-kernel/linux/linux-yocto_4.9.bbappend
new file mode 100644
index 00000000..a09fe1a4
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_4.9.bbappend
@@ -0,0 +1,21 @@
1KERNEL_FEATURES_INTEL_COMMON = ""
2
3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
4KMACHINE_core2-32-intel-common = "intel-core2-32"
5KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
6
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10
11COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
12KMACHINE_i586-nlp-32-intel-common = "intel-quark"
13KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
14
15# For Crystalforest and Romley
16KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
17KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
18
19# For FRI2, NUC
20KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
21KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"