summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto_4.4.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-yocto_4.4.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto_4.4.bbappend43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.4.bbappend b/recipes-kernel/linux/linux-yocto_4.4.bbappend
new file mode 100644
index 00000000..3b02a932
--- /dev/null
+++ b/recipes-kernel/linux/linux-yocto_4.4.bbappend
@@ -0,0 +1,43 @@
1FILESEXTRAPATHS_prepend_intel-x86-common := "${THISDIR}/${PN}:"
2
3LINUX_VERSION_INTEL_COMMON = "4.4.87"
4SRCREV_META_INTEL_COMMON = "804d2b3164ec25ed519fd695de9aa0908460c92e"
5SRCREV_MACHINE_INTEL_COMMON = "57746baa7ae35660fe807c65b6809e6b16d4a448"
6
7KBRANCH_INTEL_COMMON = "standard/intel/base"
8
9KERNEL_FEATURES_INTEL_COMMON ?= ""
10
11LINUX_VERSION_core2-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
12COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
13KMACHINE_core2-32-intel-common = "intel-core2-32"
14KBRANCH_core2-32-intel-common = "${KBRANCH_INTEL_COMMON}"
15SRCREV_meta_core2-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
16SRCREV_machine_core2-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
17KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
18
19LINUX_VERSION_corei7-64-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
20COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
21KMACHINE_corei7-64-intel-common = "intel-corei7-64"
22SRCREV_meta_corei7-64-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
23SRCREV_machine_corei7-64-intel-common ?= "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'a249f6388ace2a4035220c2333649b42c300faa9', '${SRCREV_MACHINE_INTEL_COMMON}', d)}"
24KBRANCH_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'standard/intel/bxt-rebase;rebaseable=1', '${KBRANCH_INTEL_COMMON}', d)}"
25KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
26
27# Quark / X1000 BSP Info
28LINUX_VERSION_i586-nlp-32-intel-common = "${LINUX_VERSION_INTEL_COMMON}"
29COMPATIBLE_MACHINE_i586-nlp-32-intel-common = "${MACHINE}"
30KMACHINE_i586-nlp-32-intel-common = "intel-quark"
31KBRANCH_i586-nlp-32-intel-common = "${KBRANCH_INTEL_COMMON}"
32SRCREV_meta_i586-nlp-32-intel-common ?= "${SRCREV_META_INTEL_COMMON}"
33SRCREV_machine_i586-nlp-32-intel-common ?= "${SRCREV_MACHINE_INTEL_COMMON}"
34KERNEL_FEATURES_append_i586-nlp-32-intel-common = ""
35
36
37# For Crystalforest and Romley
38KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
39KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
40
41# For FRI2, NUC
42KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
43KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"