summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-yocto_4.12.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-yocto_4.12.bbappend')
-rw-r--r--recipes-kernel/linux/linux-yocto_4.12.bbappend18
1 files changed, 1 insertions, 17 deletions
diff --git a/recipes-kernel/linux/linux-yocto_4.12.bbappend b/recipes-kernel/linux/linux-yocto_4.12.bbappend
index b99001ed..daa7dd6b 100644
--- a/recipes-kernel/linux/linux-yocto_4.12.bbappend
+++ b/recipes-kernel/linux/linux-yocto_4.12.bbappend
@@ -1,17 +1 @@
1KERNEL_FEATURES_INTEL_COMMON ?= "" require meta-intel-compat-kernel.inc
2
3COMPATIBLE_MACHINE_core2-32-intel-common = "${MACHINE}"
4KMACHINE_core2-32-intel-common = "intel-core2-32"
5KERNEL_FEATURES_append_core2-32-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
6
7COMPATIBLE_MACHINE_corei7-64-intel-common = "${MACHINE}"
8KMACHINE_corei7-64-intel-common = "intel-corei7-64"
9KERNEL_FEATURES_append_corei7-64-intel-common = "${KERNEL_FEATURES_INTEL_COMMON}"
10
11# For Crystalforest and Romley
12KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " uio"
13KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " uio"
14
15# For FRI2, NUC
16KERNEL_MODULE_AUTOLOAD_append_core2-32-intel-common = " iwlwifi"
17KERNEL_MODULE_AUTOLOAD_append_corei7-64-intel-common = " iwlwifi"