summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch')
-rw-r--r--recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch b/recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch
deleted file mode 100644
index 66cb981e..00000000
--- a/recipes-kernel/linux/linux-intel/libtraceevent-fix-build-with-binutils-25.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 1fe4ee7f680c3f69f620d68a5d2f7341e8db693b Mon Sep 17 00:00:00 2001
2From: Ben Hutchings <ben@decadent.org.uk>
3Date: Sat, 25 Jul 2020 02:06:23 +0100
4Subject: libtraceevent: Fix build with binutils 2.35
5
6In binutils 2.35, 'nm -D' changed to show symbol versions along with
7symbol names, with the usual @@ separator. When generating
8libtraceevent-dynamic-list we need just the names, so strip off the
9version suffix if present.
10
11Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
12Tested-by: Salvatore Bonaccorso <carnil@debian.org>
13Reviewed-by: Steven Rostedt <rostedt@goodmis.org>
14Cc: linux-trace-devel@vger.kernel.org
15Cc: stable@vger.kernel.org
16Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com>
17
18Upstream-Status: Backport [https://github.com/torvalds/linux/commit/39efdd94e314336f4acbac4c07e0f37bdc3bef71]
19Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
20---
21 tools/lib/traceevent/plugins/Makefile | 2 +-
22 1 file changed, 1 insertion(+), 1 deletion(-)
23
24diff --git a/tools/lib/traceevent/plugins/Makefile b/tools/lib/traceevent/plugins/Makefile
25index f440989fa55e..23c3535bcbd6 100644
26--- a/tools/lib/traceevent/plugins/Makefile
27+++ b/tools/lib/traceevent/plugins/Makefile
28@@ -196,7 +196,7 @@ define do_generate_dynamic_list_file
29 xargs echo "U w W" | tr 'w ' 'W\n' | sort -u | xargs echo`;\
30 if [ "$$symbol_type" = "U W" ];then \
31 (echo '{'; \
32- $(NM) -u -D $1 | awk 'NF>1 {print "\t"$$2";"}' | sort -u;\
33+ $(NM) -u -D $1 | awk 'NF>1 {sub("@.*", "", $$2); print "\t"$$2";"}' | sort -u;\
34 echo '};'; \
35 ) > $2; \
36 else \
37--
38cgit v1.2.2-1-g5e49
39