summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-intel-rt_4.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-intel-rt_4.9.bb')
-rw-r--r--recipes-kernel/linux/linux-intel-rt_4.9.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-intel-rt_4.9.bb b/recipes-kernel/linux/linux-intel-rt_4.9.bb
new file mode 100644
index 00000000..02192735
--- /dev/null
+++ b/recipes-kernel/linux/linux-intel-rt_4.9.bb
@@ -0,0 +1,17 @@
1
2require linux-intel.inc
3
4# Skip processing of this recipe if it is not explicitly specified as the
5# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
6# to build multiple virtual/kernel providers, e.g. as dependency of
7# core-image-rt-sdk, core-image-rt.
8python () {
9 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-intel-rt":
10 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-intel-rt to enable it")
11}
12
13KBRANCH = "base-rt"
14SRCREV_machine ?= "44f76edc2079f1551be33b8ab473349d00f814a7"
15SRCREV_meta ?= "3d5b27b2d138b71052a1d17a5cca73aa0ec75328"
16
17LINUX_KERNEL_TYPE = "preempt-rt"