summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/intel-ethernet/ixgbevf_4.3.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/intel-ethernet/ixgbevf_4.3.6.bb')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf_4.3.6.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbevf_4.3.6.bb b/recipes-kernel/intel-ethernet/ixgbevf_4.3.6.bb
deleted file mode 100644
index 824c371e..00000000
--- a/recipes-kernel/intel-ethernet/ixgbevf_4.3.6.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1SUMMARY="ixgbevf kernel driver for Intel Magnolia Park 10GbE"
2DESCRIPTION="This virtual function driver supports kernel versions 2.6.x and newer \
3This driver supports 82599, X540, X550, and X552-based virtual function devices \
4that can only be activated on kernels that support SR-IOV. \
5SR-IOV requires the correct platform and OS support. \
6The guest OS loading this driver must support MSI-X interrupts."
7
8HOMEPAGE = "https://sourceforge.net/projects/e1000/"
9SECTION = "kernel/network"
10LICENSE = "GPLv2"
11LIC_FILES_CHKSUM = "file://${WORKDIR}/${BP}/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/${BP}.tar.gz \
14 file://0001-ixgbevf-skip-host-depmod.patch \
15 file://0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch \
16 "
17
18SRC_URI[md5sum] = "fc53be00bf5e71939a9a39e9802d5b77"
19SRC_URI[sha256sum] = "61ac4e93808fa4316b044bae40f2a1dc40e4d9ae9a1785a753cdfc79b515d695"
20
21UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/"
22UPSTREAM_CHECK_REGEX = "ixgbevf%20stable/(?P<pver>\d+(\.\d+)+)/"
23
24S = "${WORKDIR}/${BP}/src"
25MODULES_INSTALL_TARGET = "install"
26
27EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
28
29KERNEL_MODULE_AUTOLOAD_append_intel-core2-32 = " ixgbevf"
30KERNEL_MODULE_AUTOLOAD_append_intel-corei7-64 = " ixgbevf"
31
32inherit module
33
34do_install_append () {
35 # Install scripts/set_irq_affinity
36 install -d ${D}${sysconfdir}/network
37 install -m 0755 ${S}/../scripts/set_irq_affinity ${D}${sysconfdir}/network
38
39 rm -rf ${D}${prefix}/man
40}
41
42PACKAGES += "${PN}-script"
43
44FILES_${PN}-script += "${sysconfdir}/network/set_irq_affinity"