summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/intel-ethernet/ixgbevf_4.14.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/intel-ethernet/ixgbevf_4.14.5.bb')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf_4.14.5.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbevf_4.14.5.bb b/recipes-kernel/intel-ethernet/ixgbevf_4.14.5.bb
new file mode 100644
index 00000000..842b0400
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbevf_4.14.5.bb
@@ -0,0 +1,47 @@
1SUMMARY="ixgbevf kernel driver for Intel Magnolia Park 10GbE"
2DESCRIPTION="This virtual function driver supports kernel versions 2.6.x and newer \
3This driver supports 82599, X540, X550, and X552-based virtual function devices \
4that can only be activated on kernels that support SR-IOV. \
5SR-IOV requires the correct platform and OS support. \
6The guest OS loading this driver must support MSI-X interrupts."
7
8HOMEPAGE = "https://sourceforge.net/projects/e1000/"
9SECTION = "kernel/network"
10LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://${WORKDIR}/${BP}/COPYING;md5=a216b4192dc6b777b6f0db560e9a8417"
12
13SRC_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/${PV}/${BP}.tar.gz \
14 "
15
16SRC_URI[sha256sum] = "499f1097305d541e9988e3161d7327425db6d1e5d9bce9feb2dbf05d80efa65e"
17
18UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/e1000/files/ixgbevf%20stable/"
19UPSTREAM_CHECK_REGEX = "ixgbevf%20stable/(?P<pver>\d+(\.\d+)+)/"
20
21CVE_PRODUCT = "linux:linux_kernel_ixgbe"
22
23S = "${WORKDIR}/${BP}/src"
24
25EXTRA_OEMAKE='KSRC="${STAGING_KERNEL_BUILDDIR}" KVER="${KERNEL_VERSION}" INSTALL_MOD_PATH="${D}"'
26
27KERNEL_MODULE_AUTOLOAD:append:intel-core2-32 = " ixgbevf"
28KERNEL_MODULE_AUTOLOAD:append:intel-corei7-64 = " ixgbevf"
29
30inherit module
31
32do_install:append () {
33 # Install scripts/set_irq_affinity
34 install -d ${D}${sysconfdir}/network
35 install -m 0755 ${S}/../scripts/set_irq_affinity ${D}${sysconfdir}/network
36
37 rm -rf ${D}${prefix}/man
38}
39
40PACKAGES += "${PN}-script"
41
42FILES:${PN}-script += "${sysconfdir}/network/set_irq_affinity"
43
44# This was fixed in kernel v4.4
45CVE_CHECK_IGNORE += "CVE-2015-1142857"
46
47EXCLUDE_FROM_WORLD = "1"