summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/intel-ethernet/ixgbevf
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/intel-ethernet/ixgbevf')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch27
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch32
-rw-r--r--recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch23
3 files changed, 27 insertions, 55 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch b/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch
new file mode 100644
index 00000000..49a59496
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbevf/0001-Makefile-check-for-CONFIG_IXGBEVF-instead.patch
@@ -0,0 +1,27 @@
1From b1d7f46442e50458311573443a5c78637874f62b Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Thu, 12 Apr 2018 11:46:15 +0800
4Subject: [PATCH] Makefile: check for CONFIG_IXGBEVF instead
5
6Check for the correct config, otherwise it won't build with kbuild.
7
8Upstream-Status: Pending
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 src/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/Makefile b/Makefile
16index 968ef5e..e3cb81b 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -28,7 +28,7 @@ ifneq ($(KERNELRELEASE),)
20 # Makefile for the Intel(R) 10GbE PCI Express Virtual Function Driver
21 #
22
23-obj-$(CONFIG_IXGBE) += ixgbevf.o
24+obj-$(CONFIG_IXGBEVF) += ixgbevf.o
25
26 define ixgbevf-y
27 ixgbevf_main.o
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch b/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch
deleted file mode 100644
index 8234f589..00000000
--- a/recipes-kernel/intel-ethernet/ixgbevf/0001-ixgbevf-src-Makefile-change-make-install-to-make.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 511ee0d8d40a3e76b3e9875a96228ff370dbdfc6 Mon Sep 17 00:00:00 2001
2From: "Goh, Wen Sen" <wen.sen.goh@intel.com>
3Date: Wed, 22 Jun 2016 11:25:41 +0800
4Subject: [PATCH] ixgbevf_patch
5
6---
7 Makefile | 4 ++--
8 1 file changed, 2 insertions(+), 2 deletions(-)
9
10diff --git a/Makefile b/Makefile
11index 8df134a..8d5660e 100644
12--- a/Makefile
13+++ b/Makefile
14@@ -100,7 +100,7 @@ clean:
15 @-rm -rf *.${MANSECTION}.gz *.ko
16
17 # Install the modules and manpage
18-install: default manfile
19+modules_install: default manfile
20 @echo "Copying manpages..."
21 @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz
22 @echo "Installing modules..."
23@@ -145,6 +145,6 @@ help:
24 @echo ' Other variables may be available for tuning make process, see'
25 @echo ' Kernel Kbuild documentation for more information'
26
27-.PHONY: default noisy clean manfile silent sparse ccc install uninstall help
28+.PHONY: default noisy clean manfile silent sparse ccc modules_install uninstall help
29
30 endif # ifneq($(KERNELRELEASE),)
31--
322.8.3
diff --git a/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch b/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch
deleted file mode 100644
index d442e24d..00000000
--- a/recipes-kernel/intel-ethernet/ixgbevf/0002-ixgbevf_common.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1From f74fbcd821a394dec58263fd2c2ea62eae298b2f Mon Sep 17 00:00:00 2001
2From: "Goh, Wen Sen" <wen.sen.goh@intel.com>
3Date: Sun, 26 Jun 2016 12:01:36 +0800
4Subject: [PATCH] ixgbevf patch
5
6---
7 common.mk | 1 +
8 1 file changed, 1 insertion(+)
9
10diff --git a/common.mk b/common.mk
11index b9b01c7..228a926 100644
12--- a/common.mk
13+++ b/common.mk
14@@ -289,6 +289,7 @@ export INSTALL_MOD_DIR ?= updates/drivers/net/ethernet/intel/${DRIVER}
15 kernelbuild = ${MAKE} $(if ${GCC_I_SYS},CC="${GCC_I_SYS}") \
16 ${CCFLAGS_VAR}="${EXTRA_CFLAGS}" \
17 -C "${KSRC}" \
18+ CONFIG_IXGBE=m \
19 CONFIG_${DRIVER_UPPERCASE}=m \
20 M="${CURDIR}" \
21 ${2} ${1};
22--
232.8.3