summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/intel-ethernet/ixgbe
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/intel-ethernet/ixgbe')
-rw-r--r--recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-skip-host-depmod.patch31
-rw-r--r--recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch40
2 files changed, 71 insertions, 0 deletions
diff --git a/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-skip-host-depmod.patch b/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-skip-host-depmod.patch
new file mode 100644
index 00000000..e53f86e5
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-skip-host-depmod.patch
@@ -0,0 +1,31 @@
1From e32eab62e3f79ddd40946ca698d9e650bd7d9b2d Mon Sep 17 00:00:00 2001
2From: sweeaun <swee.aun.khor@intel.com>
3Date: Sat, 7 Oct 2017 20:49:36 -0700
4Subject: [PATCH] ixgbe: skip host depmod
5
6Upstream-Status: Inappropriate [Cross-Compile]
7
8Depmod during do_install is irrelevant when cross-compiling.
9Remove the depmod steps during do_install.
10
11Signed-off-by: sweeaun <swee.aun.khor@intel.com>
12---
13 Makefile | 2 --
14 1 file changed, 2 deletions(-)
15
16diff --git a/Makefile b/Makefile
17index fa92f81..b39283a 100644
18--- a/Makefile
19+++ b/Makefile
20@@ -141,8 +141,6 @@ modules_install: default manfile
21 @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz
22 @echo "Installing modules..."
23 @+$(call devkernelbuild,modules_install)
24- @echo "Running depmod..."
25- @$(call cmd_depmod)
26
27 uninstall:
28 rm -f ${INSTALL_MOD_PATH}/lib/modules/${KVER}/${INSTALL_MOD_DIR}/${DRIVER}.ko;
29--
302.7.4
31
diff --git a/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch b/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch
new file mode 100644
index 00000000..88f5335a
--- /dev/null
+++ b/recipes-kernel/intel-ethernet/ixgbe/0001-ixgbe-src-Makefile-change-make-install-to-make.patch
@@ -0,0 +1,40 @@
1From 09c7a5afa76530a3720d97726f2b372f72b0af08 Mon Sep 17 00:00:00 2001
2From: "Goh, Wen Sen" <wen.sen.goh@intel.com>
3Date: Wed, 22 Jun 2016 11:18:37 +0800
4Subject: [PATCH] ixgbe: src/Makefile: change make install to make
5 modules_install
6
7Per guideline from Linux Documentation at
8Documentation/kbuild/modules.txt
9the correct target is "modules_install" not "install".
10
11Upstream-Status: Inappropriate [It is tarball released by Intel Network
12driver group]
13
14---
15 src/Makefile | 4 ++--
16 1 file changed, 2 insertions(+), 2 deletions(-)
17
18diff --git a/Makefile b/Makefile
19index 852becb..480ecee 100644
20--- a/Makefile
21+++ b/Makefile
22@@ -136,7 +136,7 @@ clean:
23 @-rm -rf *.${MANSECTION}.gz *.ko
24
25 # Install the modules and manpage
26-install: default manfile
27+modules_install: default manfile
28 @echo "Copying manpages..."
29 @install -D -m 644 ${DRIVER}.${MANSECTION}.gz ${INSTALL_MOD_PATH}${MANDIR}/man${MANSECTION}/${DRIVER}.${MANSECTION}.gz
30 @echo "Installing modules..."
31@@ -191,6 +191,6 @@ help:
32 @echo ' Other variables may be available for tuning make process, see'
33 @echo ' Kernel Kbuild documentation for more information'
34
35-.PHONY: default noisy clean manfile silent sparse ccc install uninstall help
36+.PHONY: default noisy clean manfile silent sparse ccc modules_install uninstall help
37
38 endif # ifneq($(KERNELRELEASE),)
39--
402.8.3