diff options
Diffstat (limited to 'recipes-graphics')
4 files changed, 143 insertions, 0 deletions
diff --git a/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.19.bb b/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.19.bb new file mode 100644 index 00000000..de9ed609 --- /dev/null +++ b/recipes-graphics/intel-gpu-tools/intel-gpu-tools_1.19.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | require ${COREBASE}/meta/recipes-graphics/xorg-app/xorg-app-common.inc | ||
2 | |||
3 | SUMMARY = "Intel GPU tools" | ||
4 | DESCRIPTION = "Variety of small tools for testing intel graphics." | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=e4b3dd344780e0400593b21b115a6947" | ||
7 | |||
8 | LICENSE_append = " & ISC" | ||
9 | |||
10 | inherit autotools gtk-doc | ||
11 | |||
12 | DEPENDS += "libdrm libpciaccess cairo udev glib-2.0 libxv libx11 libxext libxrandr procps" | ||
13 | RDEPENDS_${PN} += "bash" | ||
14 | RDEPENDS_${PN}-tests += "bash" | ||
15 | |||
16 | PACKAGE_BEFORE_PN = "${PN}-benchmarks ${PN}-tests" | ||
17 | |||
18 | SRC_URI[md5sum] = "4fdfa56acca3b046fc61fb12686656f3" | ||
19 | SRC_URI[sha256sum] = "a49c8ae7c0431c1f33cd9492f83ec4e06e98a48429178e4bd22d9a1a87e3b0f1" | ||
20 | |||
21 | PACKAGECONFIG ??= "" | ||
22 | PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind,libunwind" | ||
23 | |||
24 | EXTRA_OECONF = "--disable-nouveau --disable-shader-debugger" | ||
25 | COMPATIBLE_HOST = "(x86_64.*|i.86.*)-linux" | ||
26 | COMPATIBLE_HOST_libc-musl_class-target = "null" | ||
27 | |||
28 | gputools_sysroot_preprocess() { | ||
29 | rm -f ${SYSROOT_DESTDIR}${libdir}/pkgconfig/intel-gen4asm.pc | ||
30 | } | ||
31 | SYSROOT_PREPROCESS_FUNCS += "gputools_sysroot_preprocess" | ||
32 | |||
33 | FILES_${PN} += "${libdir}/intel_aubdump.so" | ||
34 | FILES_${PN}-benchmarks += "${libexecdir}/intel-gpu-tools/benchmarks" | ||
35 | FILES_${PN}-tests += "\ | ||
36 | ${libexecdir}/intel-gpu-tools/*\ | ||
37 | ${datadir}/intel-gpu-tools/1080p-right.png\ | ||
38 | ${datadir}/intel-gpu-tools/1080p-left.png\ | ||
39 | ${datadir}/intel-gpu-tools/pass.png\ | ||
40 | ${datadir}/intel-gpu-tools/test-list.txt" | ||
diff --git a/recipes-graphics/xorg-driver/xf86-video-ast_1.1.5.bb b/recipes-graphics/xorg-driver/xf86-video-ast_1.1.5.bb new file mode 100644 index 00000000..090efd62 --- /dev/null +++ b/recipes-graphics/xorg-driver/xf86-video-ast_1.1.5.bb | |||
@@ -0,0 +1,12 @@ | |||
1 | require recipes-graphics/xorg-driver/xorg-driver-video.inc | ||
2 | |||
3 | SUMMARY = "X.Org X server -- ASpeed Technologies graphics driver" | ||
4 | |||
5 | DESCRIPTION = "ast is an Xorg driver for ASpeed Technologies video cards" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=0b8c242f0218eea5caa949b7910a774b" | ||
8 | |||
9 | DEPENDS += "libpciaccess" | ||
10 | |||
11 | SRC_URI[md5sum] = "4f85febe48d51e53624550a96fc9e9ee" | ||
12 | SRC_URI[sha256sum] = "1edbbc55d47d3fd71dec99b15c2483e22738c642623a0fb86ef4a81a9067a2de" | ||
diff --git a/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch b/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch new file mode 100644 index 00000000..ceae6dfb --- /dev/null +++ b/recipes-graphics/xorg-driver/xf86-video-mga/checkfile.patch | |||
@@ -0,0 +1,68 @@ | |||
1 | Upstream-Status: Submitted [https://bugs.freedesktop.org/show_bug.cgi?id=57606] | ||
2 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
3 | |||
4 | From c9014a8f3c9b691b5aa7b1f3ec66cf7c84b8211b Mon Sep 17 00:00:00 2001 | ||
5 | From: Ross Burton <ross.burton@intel.com> | ||
6 | Date: Thu, 29 Nov 2012 11:00:43 +0000 | ||
7 | Subject: [PATCH] build: dont use AC_CHECK_FILE when enabling DRI | ||
8 | |||
9 | Automatically enabling or disabling a feature based on installed files isn't | ||
10 | deterministic, and AC_CHECK_FILE returns an error when cross-compiling. | ||
11 | |||
12 | Fix this by enabling DRI by default, and removing the explicit file checks as | ||
13 | pkg-config is good enough. | ||
14 | |||
15 | (#57606) | ||
16 | |||
17 | Signed-off-by: Ross Burton <ross.burton@intel.com> | ||
18 | --- | ||
19 | configure.ac | 25 ++----------------------- | ||
20 | 1 file changed, 2 insertions(+), 23 deletions(-) | ||
21 | |||
22 | diff --git a/configure.ac b/configure.ac | ||
23 | index fca1a9c..d2aa2ed 100644 | ||
24 | --- a/configure.ac | ||
25 | +++ b/configure.ac | ||
26 | @@ -55,9 +55,9 @@ AC_ARG_WITH(xorg-module-dir, | ||
27 | [moduledir="$libdir/xorg/modules"]) | ||
28 | |||
29 | AC_ARG_ENABLE(dri, AS_HELP_STRING([--disable-dri], | ||
30 | - [Disable DRI support [[default=auto]]]), | ||
31 | + [Disable DRI support [[default=enabled]]]), | ||
32 | [DRI="$enableval"], | ||
33 | - [DRI=auto]) | ||
34 | + [DRI=yes]) | ||
35 | AC_ARG_ENABLE(exa, | ||
36 | AS_HELP_STRING([--disable-exa], | ||
37 | [Disable EXA support [[default=enabled]]]), | ||
38 | @@ -76,27 +76,6 @@ sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server` | ||
39 | |||
40 | # Checks for libraries. | ||
41 | |||
42 | -if test "x$DRI" != xno; then | ||
43 | - AC_CHECK_FILE([${sdkdir}/dri.h], | ||
44 | - [have_dri_h="yes"], [have_dri_h="no"]) | ||
45 | - AC_CHECK_FILE([${sdkdir}/sarea.h], | ||
46 | - [have_sarea_h="yes"], [have_sarea_h="no"]) | ||
47 | - AC_CHECK_FILE([${sdkdir}/dristruct.h], | ||
48 | - [have_dristruct_h="yes"], [have_dristruct_h="no"]) | ||
49 | -fi | ||
50 | - | ||
51 | -AC_MSG_CHECKING([whether to include DRI support]) | ||
52 | -if test "x$DRI" = xauto; then | ||
53 | - if test "x$have_dri_h" = xyes && \ | ||
54 | - test "x$have_sarea_h" = xyes && \ | ||
55 | - test "x$have_dristruct_h" = xyes; then | ||
56 | - DRI="yes" | ||
57 | - else | ||
58 | - DRI="no" | ||
59 | - fi | ||
60 | -fi | ||
61 | -AC_MSG_RESULT([$DRI]) | ||
62 | - | ||
63 | AM_CONDITIONAL(DRI, test "x$DRI" = xyes) | ||
64 | if test "x$DRI" = xyes; then | ||
65 | PKG_CHECK_MODULES(DRI, [libdrm >= 2.0 xf86driproto]) | ||
66 | -- | ||
67 | 1.7.10.4 | ||
68 | |||
diff --git a/recipes-graphics/xorg-driver/xf86-video-mga_1.6.5.bb b/recipes-graphics/xorg-driver/xf86-video-mga_1.6.5.bb new file mode 100644 index 00000000..d30936b6 --- /dev/null +++ b/recipes-graphics/xorg-driver/xf86-video-mga_1.6.5.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | require recipes-graphics/xorg-driver/xorg-driver-video.inc | ||
2 | |||
3 | SUMMARY = "X.Org X server -- Matrox MGA display driver" | ||
4 | |||
5 | DESCRIPTION = "mga is an Xorg driver for Matrox video cards" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=bc1395d2cd32dfc5d6c57d2d8f83d3fc" | ||
8 | |||
9 | SRC_URI += "file://checkfile.patch" | ||
10 | |||
11 | DEPENDS += "virtual/libx11 libpciaccess" | ||
12 | |||
13 | PR = "r1" | ||
14 | |||
15 | COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)' | ||
16 | |||
17 | SRC_URI[md5sum] = "3ee2549247e01de3e7bce52c27483118" | ||
18 | SRC_URI[sha256sum] = "b663cd8e6364f7c4e2637b9fcab9861d0e3971518c73b00d213f6545a1289422" | ||
19 | |||
20 | PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'dri', '', d)}" | ||
21 | PACKAGECONFIG[dri] = "--enable-dri,--disable-dri,drm xf86driproto,xserver-xorg-extension-dri" | ||
22 | |||
23 | RDEPENDS_${PN} = "xserver-xorg-module-exa" | ||