summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libva/libva-intel_2.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/libva/libva-intel_2.14.0.bb')
-rw-r--r--recipes-graphics/libva/libva-intel_2.14.0.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/recipes-graphics/libva/libva-intel_2.14.0.bb b/recipes-graphics/libva/libva-intel_2.14.0.bb
new file mode 100644
index 00000000..a08ccb27
--- /dev/null
+++ b/recipes-graphics/libva/libva-intel_2.14.0.bb
@@ -0,0 +1,54 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "https://github.com/intel/libva/releases/download/${PV}/libva-${PV}.tar.bz2"
21SRC_URI[sha256sum] = "511e9a74d1ccfb548bc192290603082c11074ac59b17aadfd5d56a3f93e58454"
22
23S = "${WORKDIR}/libva-${PV}"
24
25UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
26
27DEPENDS = "libdrm"
28
29inherit meson pkgconfig
30
31PACKAGECONFIG ??= " \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \
33 ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
34"
35
36PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
37PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
38
39PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
40
41PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
42
43RDEPENDS:${PN}-x11 =+ "${PN}"
44RDEPENDS:${PN}-glx =+ "${PN}-x11"
45
46FILES:${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
47FILES:${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
48FILES:${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"
49
50PROVIDES += "libva"
51RPROVIDES:${PN} += "libva"
52RPROVIDES:${PN}-x11 += "libva-x11"
53RPROVIDES:${PN}-glx += "libva-glx"
54RPROVIDES:${PN}-wayland += "libva-wayland"