summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/libva/libva-intel-utils_2.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/libva/libva-intel-utils_2.14.0.bb')
-rw-r--r--recipes-graphics/libva/libva-intel-utils_2.14.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-graphics/libva/libva-intel-utils_2.14.0.bb b/recipes-graphics/libva/libva-intel-utils_2.14.0.bb
new file mode 100644
index 00000000..ae9eba3b
--- /dev/null
+++ b/recipes-graphics/libva/libva-intel-utils_2.14.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "libva-utils is a collection of utilities from libva project"
2
3DESCRIPTION = "libva-utils is a collection of utilities \
4and examples to exercise VA-API in accordance with the libva \
5project.VA-API is an open-source library and API specification, \
6which provides access to graphics hardware acceleration capabilities \
7for video processing. It consists of a main library and driver-specific \
8acceleration backends for each supported hardware vendor"
9
10HOMEPAGE = "https://01.org/linuxmedia/vaapi"
11BUGTRACKER = "https://github.com/intel/libva-utils/issues"
12
13SECTION = "x11"
14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
16
17SRC_URI = "git://github.com/intel/libva-utils.git;branch=v2.14-branch;protocol=https"
18SRCREV = "f478fe4f9b66a19ac7ebc952223025f8771b2aba"
19S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+)+))"
22
23DEPENDS = "libva"
24
25inherit meson pkgconfig features_check
26
27# depends on libva which requires opengl
28REQUIRED_DISTRO_FEATURES = "opengl"
29
30PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
31PACKAGECONFIG[x11] = "-Dx11=true, -Dx11=false,virtual/libx11 libxext libxfixes"
32PACKAGECONFIG[wayland] = "-Dwayland=true, -Dwayland=false,wayland-native wayland"
33
34PROVIDES = "libva-utils"
35RPROVIDES:${PN} += "libva-utils"