diff options
Diffstat (limited to 'recipes-devtools/opencl')
-rw-r--r-- | recipes-devtools/opencl/opencl-clang-native_8.0.0.bb | 25 |
1 files changed, 0 insertions, 25 deletions
diff --git a/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb b/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb deleted file mode 100644 index cfba8d97..00000000 --- a/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | SUMMARY = "Common clang is a thin wrapper library around clang" | ||
2 | DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \ | ||
3 | to compile OpenCL C kernels to SPIR-V modules." | ||
4 | |||
5 | LICENSE = "NCSA" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c" | ||
7 | |||
8 | SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=https" | ||
9 | |||
10 | SRCREV = "daf5e4dd718477ae8cf89a283c653939d9182f15" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | inherit native | ||
15 | |||
16 | do_configure[noexec] = "1" | ||
17 | |||
18 | do_compile() { | ||
19 | ${CC} linux_linker/linux_resource_linker.cpp -o linux_resource_linker | ||
20 | } | ||
21 | |||
22 | do_install() { | ||
23 | install -d ${D}${bindir} | ||
24 | install -m 0755 linux_resource_linker ${D}${bindir}/ | ||
25 | } | ||