summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/opencl/opencl-clang-native_8.0.0.bb')
-rw-r--r--recipes-devtools/opencl/opencl-clang-native_8.0.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb b/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb
new file mode 100644
index 00000000..cfba8d97
--- /dev/null
+++ b/recipes-devtools/opencl/opencl-clang-native_8.0.0.bb
@@ -0,0 +1,25 @@
1SUMMARY = "Common clang is a thin wrapper library around clang"
2DESCRIPTION = "Common clang has OpenCL-oriented API and is capable \
3 to compile OpenCL C kernels to SPIR-V modules."
4
5LICENSE = "NCSA"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e8a15bf1416762a09ece07e44c79118c"
7
8SRC_URI = "git://github.com/intel/opencl-clang.git;branch=ocl-open-80;protocol=https"
9
10SRCREV = "daf5e4dd718477ae8cf89a283c653939d9182f15"
11
12S = "${WORKDIR}/git"
13
14inherit native
15
16do_configure[noexec] = "1"
17
18do_compile() {
19 ${CC} linux_linker/linux_resource_linker.cpp -o linux_resource_linker
20}
21
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 linux_resource_linker ${D}${bindir}/
25}