summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/ngraph/ngraph_0.29.0-rc0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/ngraph/ngraph_0.29.0-rc0.bb')
-rw-r--r--recipes-devtools/ngraph/ngraph_0.29.0-rc0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-devtools/ngraph/ngraph_0.29.0-rc0.bb b/recipes-devtools/ngraph/ngraph_0.29.0-rc0.bb
new file mode 100644
index 00000000..e0170681
--- /dev/null
+++ b/recipes-devtools/ngraph/ngraph_0.29.0-rc0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "nGraph Compiler Stack"
2DESCRIPTION = "nGraph Compiler aims to accelerate developing AI workloads using \
3any deep learning framework and deploying to a variety of \
4hardware targets."
5HOMEPAGE = "https://www.ngraph.ai"
6
7SRC_URI = "git://github.com/NervanaSystems/ngraph.git;protocol=https \
8 file://0001-install-cmake-modules-correctly.patch \
9 "
10
11SRCREV = "b8419c354e5fc70805f1501d7dfff533ac790bec"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
15
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20OECMAKE_GENERATOR = "Unix Makefiles"
21
22EXTRA_OECMAKE += " \
23 -DNGRAPH_CPU_ENABLE=FALSE \
24 -DNGRAPH_UNIT_TEST_ENABLE=FALSE \
25 -DNGRAPH_TEST_UTIL_ENABLE=FALSE \
26 -DNGRAPH_INTERPRETER_ENABLE=FALSE \
27 -DNGRAPH_JSON_ENABLE=FALSE \
28 -DNGRAPH_NATIVE_ARCH_ENABLE=FALSE \
29 -DNGRAPH_TOOLS_ENABLE=FALSE \
30 -DNGRAPH_NOP_ENABLE=FALSE \
31 -DNGRAPH_GENERIC_CPU_ENABLE=FALSE \
32 -DNGRAPH_LIB_VERSIONING_ENABLE=TRUE \
33 -DNGRAPH_CURRENT_RELEASE_TAG=0.29.0-rc0 \
34 "