summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/libxcam/files/0001-modules-vulkan-point-to-correct-location-of-spv-shad.patch30
-rw-r--r--recipes-core/libxcam/libxcam_git.bb31
2 files changed, 61 insertions, 0 deletions
diff --git a/recipes-core/libxcam/files/0001-modules-vulkan-point-to-correct-location-of-spv-shad.patch b/recipes-core/libxcam/files/0001-modules-vulkan-point-to-correct-location-of-spv-shad.patch
new file mode 100644
index 00000000..911d7aac
--- /dev/null
+++ b/recipes-core/libxcam/files/0001-modules-vulkan-point-to-correct-location-of-spv-shad.patch
@@ -0,0 +1,30 @@
1From 99f7a588ee827e25a153ac066a4f80f13a86e10e Mon Sep 17 00:00:00 2001
2From: Anuj Mittal <anuj.mittal@intel.com>
3Date: Mon, 29 Jul 2019 12:27:19 +0800
4Subject: [PATCH] modules/vulkan: point to correct location of spv shaders
5
6They are not generated and are present in source directory.
7
8Upstream-Status: Submitted [https://github.com/intel/libxcam/pull/654]
9
10Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
11---
12 modules/vulkan/Makefile.am | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/modules/vulkan/Makefile.am b/modules/vulkan/Makefile.am
16index 22763f0..56578ec 100644
17--- a/modules/vulkan/Makefile.am
18+++ b/modules/vulkan/Makefile.am
19@@ -5,7 +5,7 @@ XCAM_VK_CXXFLAGS = \
20 $(LIBVULKAN_CFLAGS) \
21 -I$(top_srcdir)/xcore \
22 -I$(top_srcdir)/modules \
23- -I$(top_builddir)/shaders/spv \
24+ -I$(top_srcdir)/shaders/spv \
25 $(NULL)
26
27 XCAM_VK_LIBS = \
28--
292.7.4
30
diff --git a/recipes-core/libxcam/libxcam_git.bb b/recipes-core/libxcam/libxcam_git.bb
new file mode 100644
index 00000000..80bef154
--- /dev/null
+++ b/recipes-core/libxcam/libxcam_git.bb
@@ -0,0 +1,31 @@
1SUMMARY = "libXCam is a project for extended camera(not limited in camera) \
2features and focus on image quality improvement and video analysis"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8c911f084a3e5f46b21582a6cc9973e6"
5SECTION = "lib"
6
7inherit autotools pkgconfig
8
9S = "${WORKDIR}/git"
10SRCREV = "28769ade4793006c8db9a1720359c310fa1e0d6a"
11SRC_URI = "git://github.com/intel/libxcam.git;branch=1.2.2 \
12 file://0001-modules-vulkan-point-to-correct-location-of-spv-shad.patch \
13 "
14
15COMPATIBLE_HOST_libc-musl = "null"
16
17PACKAGECONFIG ??= " gst \
18 ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gles", "", d)} \
19 ${@bb.utils.contains("DISTRO_FEATURES", "vulkan", "vulkan", "", d)} \
20 "
21
22PACKAGECONFIG[gst] = "--enable-gst, --disable-gst, gstreamer1.0 gstreamer1.0-plugins-base"
23PACKAGECONFIG[aiq] = "--enable-aiq, --disable-aiq,"
24PACKAGECONFIG[libcl] = "--enable-libcl, --disable-libcl,"
25PACKAGECONFIG[opencv] = "--enable-opencv, --disable-opencv, opencv"
26PACKAGECONFIG[render] = "--enable-render, --disable-render,"
27PACKAGECONFIG[gles] = "--enable-gles, --disable-gles, virtual/mesa"
28PACKAGECONFIG[vulkan] = "--enable-vulkan, --disable-vulkan, vulkan-loader virtual/mesa"
29PACKAGECONFIG[dnn] = "--enable-dnn, --disable-dnn,"
30
31FILES_${PN} += "${libdir}/gstreamer-*/*.so"